Mouse scroll speed & pop up windows

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
Post Reply
birkopf
Level 2
Level 2
Posts: 64
Joined: Sun Jun 19, 2011 5:53 am

Mouse scroll speed & pop up windows

Post by birkopf »

Hi guys,

I cannot find options for increasing scroll speed on my mouse. Also, all pop-up windows come under currently open windows and I cannot see / notice them. I couldn't find options for changing these, but on the flip side - Mint is now much more developed so I am sure options are there I just cannot track them.

Could you help please ?
sadhu
Level 5
Level 5
Posts: 674
Joined: Fri Nov 22, 2013 9:48 am
Contact:

Re: Mouse scroll speed & pop up windows

Post by sadhu »

sabbe sattā bhavantu sukhitattā. LN 19.3-64 Cinn 4.4.8, Mobo: ASUSTeK STRIX B250G GAMING v, Dual core Pntm G4560, Intel Gfx. Laptop:ASUS, Core i3, 4G RAM Intel Gfx
birkopf
Level 2
Level 2
Posts: 64
Joined: Sun Jun 19, 2011 5:53 am

Re: Mouse scroll speed & pop up windows

Post by birkopf »

Thanks, sadly I cannot get it working by that program
sadhu
Level 5
Level 5
Posts: 674
Joined: Fri Nov 22, 2013 9:48 am
Contact:

Re: Mouse scroll speed & pop up windows

Post by sadhu »

There's a more complete answer here: http://www.webupd8.org/2015/12/how-to-c ... speed.html

After creating the new ./imwheelrc configuration file in your home directory, then turn off or disable all other applications that might be watching scroll events.

In my case it was the Accessibility applet, in which I had enabled "zoom", because my 74-year-old eyes can't always make out the tiny and low-contrast text many web developers think is stylish. So after turning off Zoom, I changed the scroll to 6 and it works great.

Note that your .imwheelrc file can be set up to control scrolling on a per-window basis. You might want to keep the scroll to 3 in terminals, but maybe 10 for editors.

BTW another thing I have done is TURN OFF the middle button, because when I scroll, I'm often a bit thumb-fingered and I get a middle-click event on the mouse. I disabled the middle button using xmodmap, and setting my .Xmodmap configuration file as follows

Code: Select all

keycode 66 = Shift_L Caps_Lock NoSymbol NoSymbol
pointer = 1 0 3 4 5 6 7 8 9 10 11 12 13 14 15 16
The first line turns off CapsLock, and makes Left-Shift+CapLock the actual capslock function on my generic USA keyboard. In the 2nd line, the 0 in the 2nd place turns off the middle button. Invoke xmodmap as follows:

Code: Select all

xmodmap [path-to-your-personal-.Xmodmap-file]
I think it ought to work for you now. I hope.

Sadhu
sabbe sattā bhavantu sukhitattā. LN 19.3-64 Cinn 4.4.8, Mobo: ASUSTeK STRIX B250G GAMING v, Dual core Pntm G4560, Intel Gfx. Laptop:ASUS, Core i3, 4G RAM Intel Gfx
Post Reply

Return to “Cinnamon”