Page 1 of 1

[solved] LM 19.1 Cinnamon - Dead black icon in Panel

Posted: Mon Apr 15, 2019 11:00 am
by JRG
I have LM 19.1 Cinnamon installed on an Intel NUC7i7. All updates have been applied.

The panel is the default, however I have moved it to the right-hand side of the screen. At the bottom (normally on right side of horizontal panel) are applets. There is one square black icon (the panel has a background that looks black, but is a very dark shade of grey so the the really black icon is visible).
panel icon 2019-04-15.png
panel icon 2019-04-15.png (11.23 KiB) Viewed 315 times
Hovering over it or left or right clicking on it does nothing. I cannot tell what applet, if any, is displaying this icon and I have been unsuccessful in getting rid of it. It persists from session to session and reboots.

I have searched the forums for related topics and can only find ones involving black icons on the panel (but the icons are functional).

Is there a configuration file in which these applets (or whatever) are listed? If so, I could manually edit it to get rid of this annoyance.

Re: LM 19.1 Cinnamon - Dead black icon in Panel

Posted: Tue Apr 16, 2019 1:48 am
by kyphi
There are several things I would try.

1. Press Ctrl+Alt+Esc to reset Cinnamon.
2. Look in System Settings, Applets to check for updates for installed applets as well as any that are flagged as possibly being problematic (temporarily disable these).
3. Right click on the panel, go to Troubleshoot, click on the triangle and select Restore all settings to default. This will also erase any icons you have added and you will have to add these again.

Re: LM 19.1 Cinnamon - Dead black icon in Panel

Posted: Tue Apr 16, 2019 1:55 am
by smurphos
Don't do no 3.... :)

It's a broken systray icon.....

Logout, log back in once the desktop has loaded please report back the output of this command. This should include what applications are tying to load to the systray (along with what applets are loading just in case it is an applet).

Copy the ouput from the terminal and paste back in between [code][/code] tags.

Code: Select all

cat ~/.xsession-errors

Re: LM 19.1 Cinnamon - Dead black icon in Panel

Posted: Fri Apr 19, 2019 12:45 pm
by cpu2910
I got this icon every time, when I start KeePass2 via autostart. It behaves the same like you describe.
Eventually you have a similar programm in autostart and it is running in the background?

Re: LM 19.1 Cinnamon - Dead black icon in Panel

Posted: Sun Apr 21, 2019 12:25 pm
by JRG
Thanks all :)

First I tried cpu2910's suggestion. I checked what was being auto-started on login. There it was! The Print Queue Applet, whose icon was not appearing in the panel. I set it not to auto-start and logged-out and back in. No more black icon.

I suspect the problem is my not yet having added a printer. I had to re-install LM because of a different problem but did not have to recreate /home (it is a separate partition) and it had settings from the previous LM install.

Further, I expect to be able to add a printer (or two) and then re-enable the auto-start of the Print Queue Applet and have everything work correctly.

Again, thanks to cpu2910 and smurphos for pointing me in the correct direction.