Am I a professional UI breaking or something? (Login loop pls help)

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
FatheredPuma81
Level 1
Level 1
Posts: 6
Joined: Sun Jun 09, 2019 12:46 am

Am I a professional UI breaking or something? (Login loop pls help)

Post by FatheredPuma81 » Tue Jun 11, 2019 2:37 am

Sorry if this isn't the right place for this.

Backstory:
So I installed Linux Mint and the first thing I did was disable Mouse Acceleration. When I logged out for it to take effect I was met with a blinking cursor for a long while. I hard reset and I was greeted with a text log in. Tried looking up fixes, tried reinstalling xorg, reinstalling mdm and reconf. it, and gave up and reinstalled. This isn't the first time I've broken the UI on Linux and not known how to fix it.
So after reinstalling Linux Mint I decided to put off the Mouse Acceleration thing and installed Discord and Steam to try out gaming with Proton. Spoiler it was worse than I expected. I then installed drivers to see if it would help which it did not and all was good.
'
The Issue:
Today I logged in and decided to install DXVK which required Wine of which I found out was no longer possible to get via apt-get and couldn't find it in the App installer so I installed PlayonLinux and a few other things that looked like might be it. This worked and I was then told I need to install Lutris. I installed it without too much hassle and was told by Lutris I didn't have Vulkan installed (apparently the Vulkan Pro drivers don't count). So I then used their link to attempt and install Vulkan too no avail. I then saw that I might have to restart for it to take effect so I did and was met with a nice log-in screen that goes to a blinking cursor for a second and then met with another log-in screen.
I can however go to another Desktop and Sudo StartX and get into the Desktop without my background or any Desktop items. I tried using TimeShift to revert to several days ago but it didn't work. I even tried updating to see if that'd help but it didn't.

Shortened:
I attempted to install Wine, DXVK, Lutris, and Vulkan and ended up with a log-in loop. I can Sudo StartX on another Desktop but can't start it normally. TimeShift doesn't help.


Any ideas? I also tried the mdm fix I saw on a forum to no avail.

User avatar
Lord Boltar
Level 5
Level 5
Posts: 674
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: Am I a professional UI breaking or something? (Login loop pls help)

Post by Lord Boltar » Tue Jun 11, 2019 11:27 am

Lets start with WINE

How to Install WINE 4.0.1 stable from the terminal on Ubuntu based systems

If your system is 64 bit, you first need to enable the 32 bit architecture - run

Code: Select all

sudo dpkg --add-architecture i386


Next we need to add the repository and get the WINE Public key - run the following

Code: Select all

wget -nc https://dl.winehq.org/wine-builds/winehq.key

Code: Select all

sudo apt-key add winehq.key

Code: Select all

sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'

Code: Select all

sudo apt-get update

Code: Select all

sudo apt-get install --install-recommends winehq-stable
After it has finished installing we need to configure WINE - run -

Code: Select all

winecfg
This will install Wine Grecko and Wine Mono after this is done you are now finished with the WINE installation. Only one last thing to do you will need to associate the ".exe" file extension to the WINE installer - simply right click the ".exe" file and select Properties, now select the "Open With" drop down tab and select "Wine Windows Program Loader"

Hope This Helps
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

Post Reply

Return to “Cinnamon”