Windows follow the mouse with latency when dragged

Please post suggestions for improvement of Cinnamon here
Post Reply
Level 1
Level 1
Posts: 2
Joined: Thu Jul 11, 2019 1:57 pm

Windows follow the mouse with latency when dragged

Post by Ilasid » Thu Jul 11, 2019 2:26 pm


I'm stuck with an unpleasant behaviour in Linux Mint 19.1 Tessa and Cinnamon 4.0.10:
- when I drag a window with the mouse, the window follows the mouse with some latency.
- if "Force Composition Pipeline" is enabled in Nvidia settings, the issue is still present by default. But it disappears for all windows when any of VSCode, Blender or Stellarium is active in any workspace (and reappears if I close all of them).

Result of inxi -Fxz :

Code: Select all

System:    Host: desktop Kernel: 4.15.0-54-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.0.10 
           Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop Mobo: ASUSTeK model: P8P67 EVO v: Rev 1.xx serial: <filter> BIOS: American Megatrends v: 3207 
           date: 04/13/2012 
Battery:   Device-1: hidpp_battery_0 model: Logitech M510 charge: 55% status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i5-2500K bits: 64 type: MCP arch: Sandy Bridge rev: 7 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 26485 
           Speed: 1605 MHz min/max: 1600/5900 MHz Core speeds (MHz): 1: 1605 2: 1605 3: 1605 4: 1605 
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: Micro-Star MSI driver: nvidia v: 430.26 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.19.6 driver: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 430.26 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Device-2: NVIDIA GM204 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k4.15.0-54-generic 
Network:   Device-1: Intel 82579V Gigabit Network vendor: ASUSTeK P8P67 Deluxe driver: e1000e v: 3.2.6-k port: f040 
           bus ID: 00:19.0 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Realtek RTL-8110SC/8169SC Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: 2.3LK-NAPI port: c000 
           bus ID: 07:02.0 
           IF: enp7s2 state: down mac: <filter> 
           Device-3: Atheros AR3011 Bluetooth type: USB driver: btusb bus ID: 2-1.7:5 
           IF-ID-1: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 4.13 TiB used: 890.65 GiB (21.0%) 
           ID-1: /dev/sda vendor: Seagate model: ST3000DM001-1CH166 size: 2.73 TiB 
           ID-2: /dev/sdb vendor: Western Digital model: WD1002FAEX-00Z3A0 size: 931.51 GiB 
           ID-3: /dev/sdc vendor: SanDisk model: SSD PLUS 480 GB size: 447.14 GiB 
           ID-4: /dev/sdd type: USB vendor: SanDisk model: Extreme size: 58.43 GiB 
Partition: ID-1: / size: 36.73 GiB used: 12.90 GiB (35.1%) fs: ext4 dev: /dev/sdc5 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 56 C 
           Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0% 
Info:      Processes: 234 Uptime: 1h 05m Memory: 15.63 GiB used: 2.11 GiB (13.5%) Init: systemd runlevel: 5 Compilers: 
           gcc: 9.1.0 Shell: bash v: 4.4.20 inxi: 3.0.27

Level 1
Level 1
Posts: 8
Joined: Mon Jul 08, 2019 7:04 am

Re: Windows follow the mouse with latency when dragged

Post by LostGolfBall » Fri Jul 12, 2019 7:56 pm

Hi Ilasid,

By what you told us, it almost feels as if you ran into the less pleasant performance of software rendering. But I'm confident it is not that. Though, I would not be surprised if it was driver related. Have you tried switching drivers in the Driver Manager? I would love to hear if this issue persists when you change to the recommended driver for Nvidia cards, since if I'm not wrong, you are currently using the proprietary driver.

Keep us posted what that experiment does for you!

Level 1
Level 1
Posts: 2
Joined: Thu Jul 11, 2019 1:57 pm

Re: Windows follow the mouse with latency when dragged

Post by Ilasid » Tue Jul 16, 2019 3:28 pm

Actually, I have already experimented the same issue with the recommended driver (I've tried 4 or 5 drivers).

Currently, the only solution for me is to launch an application which uses the GPU, it "unleashes" the desktop.

Post Reply

Return to “Cinnamon”