Sound effects for extra system events (text box popups)

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
User avatar
VlC
Level 1
Level 1
Posts: 1
Joined: Sun Aug 18, 2019 12:23 pm

Sound effects for extra system events (text box popups)

Post by VlC » Fri Sep 06, 2019 11:39 am

I moved on to Linux Mint from Windows 10 fairly recently, and while I got it up and running the way I want, there's something that I still miss and that I couldn't solve (even after searching through Google or these forums themselves). My problem is:
How can I make it so a certain sound effect sounds when a system dialog shows up?

With "dialog" I mean the common system text boxes that appear in various occasions. Information text boxes, Warning/Error dialogs, the typical "Do you want to save?" popups, or even the "Aunthentication needed for..." insert-your-password dialogs, etc, etc. A couple of screenshots for even less confusion:
Example of "Authentication needed for..." dialog
Example of "Authentication needed for..." dialog
Example of another dialog
Example of another dialog
Screenshot from 2019-08-18 21-53-13.png (6.58 KiB) Viewed 267 times
These mentioned are mainly the ones that I'd like a sound effect assigned to. In Windows, this was easy to do by going to the "Sound" panel, but I can't seem to find what I need in the same menu in Mint.

Is there any way of doing this sort of thing?

**Not sure what exactly other info I should put; if needed, tell me and I'll be happy to provide it. In the meantime, I'll list this:
System:

Code: Select all

Kernel: 5.0.0-25-generic x86_64 bits: 64 compiler: gcc 
  v: 7.4.0 Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina 
  base: Ubuntu 18.04 bionic

User avatar
MrEen
Level 13
Level 13
Posts: 4655
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound effects for extra system events (text box popups)

Post by MrEen » Fri Sep 06, 2019 12:34 pm

Hi VlC, and welcome to the forum.

I use Xfce which has a very different system sounds setup, so I'm guessing here, but try Menu > Preferences > Sound > Sounds tab, and scroll down to and enable Showing notifications. Also make sure the volume is turned up at the top of the window.

Hope that helps.

Post Reply

Return to “Cinnamon”