Page 1 of 1

Avoiding workspace transition

Posted: Tue Dec 03, 2019 5:51 am
by james-r
I don't like the workspace animation effect when switching workspaces.
I'd like to turn it off and have an "instantaneous" switch without the Workspace n label either.

Adding to this I'd like to know whether there's a way of assigning workspaces to particular programs, like opening Firefox in the 2nd workspace by default or switching workspaces using something like Ctrl+Alt+n instead of shifting through them.

Re: Avoiding workspace transition

Posted: Tue Dec 03, 2019 8:40 am
by Hoser Rob
james-r wrote:
Tue Dec 03, 2019 5:51 am
I don't like the workspace animation effect when switching workspaces.
I'd like to turn it off and have an "instantaneous" switch without the Workspace n label either.
Go to desktop effects in Settings to change animations and Workspaces for workspace labels. You don't say what Mint release or DE you're using but they all work the same.
Adding to this I'd like to know whether there's a way of assigning workspaces to particular programs, like opening Firefox in the 2nd workspace by default or switching workspaces using something like Ctrl+Alt+n instead of shifting through them.
AFAIK the only DE that does this is KDE via Activities but KDE isn't supported for Mint 19.x

Re: Avoiding workspace transition

Posted: Tue Dec 03, 2019 9:09 am
by gm10
Nah, every window manager does it differently. But it's likely Cinnamon because the other default window managers don't animate by default (they can't all have Compiz' cube ;)).

See here for an example of how to open applications in specific workspaces: viewtopic.php?p=1529405#p1529405

Check your keybinds on how to access a numbered workspace directly, or if your DE does not have such a keybind then create one using wmctrl -s <workspace>.

Re: Avoiding workspace transition

Posted: Sun Mar 15, 2020 12:11 am
by james-r
Hoser Rob wrote:
Tue Dec 03, 2019 8:40 am
Go to desktop effects in Settings to change animations and Workspaces for workspace labels. You don't say what Mint release or DE you're using but they all work the same.
I can't find such option. I am using Linux Mint 19.3 Tricia.

Re: Avoiding workspace transition

Posted: Sun Mar 15, 2020 2:53 am
by smurphos
james-r wrote:
Sun Mar 15, 2020 12:11 am
I can't find such option. I am using Linux Mint 19.3 Tricia.
Cinnamon, MATE or XFCE