[SOLVED] Cinnamon Sound Applet Problem...

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
Post Reply
User avatar
invex
Level 3
Level 3
Posts: 161
Joined: Sun Aug 14, 2016 12:38 pm

[SOLVED] Cinnamon Sound Applet Problem...

Post by invex »

Any idea how I can clear this?
I'm not playing any music but I can't remove 'Chromium Stopped'.
Thanks in advance.
Attachments
Selection_840.png
Selection_840.png (35.41 KiB) Viewed 880 times
Last edited by invex on Fri Sep 18, 2020 7:17 pm, edited 1 time in total.
munkybut
Level 1
Level 1
Posts: 6
Joined: Mon Jul 26, 2010 12:47 am

Re: Cinnamon Sound Applet Problem...

Post by munkybut »

I'm having this same issue! Did you ever figure it out?

I don't even have Chromium installed.
User avatar
invex
Level 3
Level 3
Posts: 161
Joined: Sun Aug 14, 2016 12:38 pm

Re: Cinnamon Sound Applet Problem...

Post by invex »

I didn't find a solution.
It annoyed me so much that I turned off the Control Players option in Sound applet.
sverx
Level 2
Level 2
Posts: 57
Joined: Mon Oct 02, 2017 4:58 am

Re: Cinnamon Sound Applet Problem...

Post by sverx »

I guess the only option is to close the browser
User avatar
smurphos
Level 17
Level 17
Posts: 7332
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Cinnamon Sound Applet Problem...

Post by smurphos »

Hi,

You can disable Chrome / Chromium's media key handling to workaround this irritant.

Visit chrome://flags/ search for Hardware Media Key Handling and disable.

Cinnamon bug report is here - https://github.com/linuxmint/cinnamon/issues/9022
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.
User avatar
smurphos
Level 17
Level 17
Posts: 7332
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Cinnamon Sound Applet Problem...

Post by smurphos »

Another workaround to tweak the sound applet so it always shows the launch players menu item, so even if Chrome/Chromium is blocking you can still launch an alternative player from the applet.

Code: Select all

xed admin:////usr/share/cinnamon/applets/sound@cinnamon.org/applet.js
Navigate to line 1359

Code: Select all

    _updatePlayerMenuItems() {
        if (this.playerControl && this._activePlayer) {
            this._launchPlayerItem.actor.hide();
            this._chooseActivePlayerItem.actor.show();
Change this._launchPlayerItem.actor.hide(); to this._launchPlayerItem.actor.show();

Code: Select all

    _updatePlayerMenuItems() {
        if (this.playerControl && this._activePlayer) {
            this._launchPlayerItem.actor.show();
            this._chooseActivePlayerItem.actor.show();
Save the file and restart Cinnamon with Ctrl-Alt-Esc

I'll see if I can work out how to get the applet to ignore Chrome/Chromium when it's advertising itself as stopped, which is probably the right workaround.

This Chromium bug report looks to be relevant - https://bugs.chromium.org/p/chromium/is ... id=1016161
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.
User avatar
invex
Level 3
Level 3
Posts: 161
Joined: Sun Aug 14, 2016 12:38 pm

Re: Cinnamon Sound Applet Problem...

Post by invex »

Thank you for the tips.
Hardware Media Key Handling is disabled but it didn't help.
I didn't try the other tip because when I use Rhythmbox the album covers and controls are displayed properly.
Only when I exit Rhythmbox I again see Chrome Stopped.
rtcunningham
Level 1
Level 1
Posts: 3
Joined: Fri Sep 18, 2020 3:24 am
Location: Hawaii (Temporarily)
Contact:

Re: Cinnamon Sound Applet Problem...

Post by rtcunningham »

smurphos wrote:
Thu Jan 23, 2020 2:10 pm
Hi,

You can disable Chrome / Chromium's media key handling to workaround this irritant.

Visit chrome://flags/ search for Hardware Media Key Handling and disable.

Cinnamon bug report is here - https://github.com/linuxmint/cinnamon/issues/9022
This worked for me in the Brave web browser using brave://flags. Thank you.
User avatar
invex
Level 3
Level 3
Posts: 161
Joined: Sun Aug 14, 2016 12:38 pm

Re: Cinnamon Sound Applet Problem...

Post by invex »

Perfect!
Thank you so much.
Post Reply

Return to “Cinnamon”