Page 1 of 1

[SOLVED] i3wm in Mint 20 Cinnamon problems

Posted: Thu Oct 15, 2020 11:06 pm
by bufolino
Hi everyone, i just recently started using linux, so mint was perfect for me, and I really like Cinnamon, and after a few weeks I wanted to try i3, so after a lot of work I got it running, but now I have two issues; authentication, and video.
I couldn't use any of the administration settings, running cinnamon-settings from the console showed authentication errors and it only worked with sudo, searching I found this post where someone had a similar problem, in the i3 config file I put the command

Code: Select all

/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
and that seems to do the trick. Is that the right way, or there is something else to repair it?

And video...the webcam works, I can watch videos on youtube, reddit, etc, but I just can't play any video file, vlc and celluloid just crash immediately, and back in the cinnamon desktop it doesn't work either. I haven't found any info on this, so any help would be great.

Re: i3wm in Mint 20 Cinnamon problems

Posted: Fri Oct 16, 2020 7:55 am
by Kadaitcha Man
bufolino wrote:
Thu Oct 15, 2020 11:06 pm
i just recently started using linux ... I wanted to try i3, so after a lot of work I got it running, but now I have two issues; authentication, and video.
You have created your very own Frankenstein, a Frankendesktop. Backup your import files and clean install. It's your mess, and it's up to you to clean up. Next time, you might try a distribution that supports the i3 DE.

Re: i3wm in Mint 20 Cinnamon problems

Posted: Sat Oct 17, 2020 1:27 pm
by bufolino
yeah thanks, but that doesn't help at all. I just used timeshift to restore, try again, and everything works, except for the video again, I would like to find whats the problem. I used virtualbox and tried it with mint xfce and video works, but that's a virtual machine, so maybe my Intel drivers?.

Re: i3wm in Mint 20 Cinnamon problems

Posted: Sun Oct 18, 2020 1:59 am
by bufolino
OK, I found the solution
I opened a video file from the command line, disable video and it didn't freeze and there was sound, so I run it again with video enabled and watch the error it gave me,
error 6 in iris_dri.so

The video problem was with the intel iris driver, here i found the info, and what to do, just put in the /etc/environment file the line

Code: Select all

MESA_LOADER_DRIVER_OVERRIDE=i965

Now video works without crashing.