Page 1 of 1

12 hour clock stuck in 24 hour mode SOLVED

Posted: Wed Jan 25, 2012 11:09 pm
by trefall
As always any help is appreciated. I switched to Cinnamon from Gnome (not exactly sure of the difference) using Mint 12. Now, even though my 'Date and Time Settings' show my clock is set in 12 hour (AM/PM) mode the clock display on the desktop only shows in 24 hour mode. Any ideas?

Re: 12 hour clock stuck in 24 hour mode

Posted: Thu Jan 26, 2012 1:27 am
by KoHoSo
I am having the same problem with LM12. I've been using Cinnamon for a while now. The problem showed up a few days ago, perhaps after the most recent update for Cinnamon showed up in the Update Manager. I verified that the setting had not been switched. I clicked it over to 24 hour, closed, and then went back to 12 hour but still no change. It's only a minor thing but a fix would be nice.

Re: 12 hour clock stuck in 24 hour mode

Posted: Thu Jan 26, 2012 1:35 am
by trefall
Found it in the Cinnamon notes page. http://forum.linuxmint.com/viewtopic.php?f=208&t=89411&start=380. Change the 'Cinnamon Settings' - H to l (Upper case H to lower case L)

Re: 12 hour clock stuck in 24 hour mode SOLVED

Posted: Thu Jan 26, 2012 2:43 am
by craig10x
crzen and kmb42vt provided the solution on that linked thread...
I started having the problem when i installed the latest version (1.2)...Clem is aware and it will be fixed in future version...meanwhile you (or anyone else with the problem) can fix it as they outlined below:

craig in cinnamon-settings -> calender. change the date format in panel.
the cap "H" means 24 hour. cap "I" means 12 hour:
%a %b %e, %I:%M or
%a %b %e, %I:%M %p


You'll also need to add "%p" after the line above if you want to see AM/PM after the time as well:

%A %b %e %l:%M %p = Monday Jan 23 2:50 PM (the "time" is just an example of course).

You'll notice a link in Cinnamon settings/Calendar labeled: "Generate your own date formats"? Clicking on that link open your browser to this page:

Re: 12 hour clock stuck in 24 hour mode SOLVED

Posted: Sat Jan 28, 2012 5:27 pm
by woodsmoke
Hi
I'm running kind of late, but was able to get into the site and found the same as outlined above by craig10x and and can confirm that it works on my superos/mint/cinnamon install.

woodsmoke

Re: 12 hour clock stuck in 24 hour mode SOLVED

Posted: Sat Feb 18, 2012 6:37 pm
by webguy64
I'm having the same problem. Glad it's not just me.
I'll stick with Gnome for now until it's fixed

Re: 12 hour clock stuck in 24 hour mode SOLVED

Posted: Fri May 25, 2012 10:02 pm
by skunkjar
Thanks, that worked perfectly. I love this community!

Re: 12 hour clock stuck in 24 hour mode SOLVED

Posted: Sun Aug 19, 2012 5:58 pm
by tbrownarcher2
the same question the same success. I too am happy that this community exists. It worked

Thanks,
Nate

Re: 12 hour clock stuck in 24 hour mode SOLVED

Posted: Fri Jan 04, 2013 4:50 am
by TheKOAD
This shoul be fixed by now. make it an update "fixes confusing clock bug"

Re: 12 hour clock stuck in 24 hour mode SOLVED

Posted: Fri Jan 11, 2013 7:53 pm
by beachgardener
Thanks for this :)