Cinnamon not starting with second monitor plugged in

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
sceo
Level 1
Level 1
Posts: 7
Joined: Tue Dec 06, 2011 9:34 am

Cinnamon not starting with second monitor plugged in

Post by sceo » Mon Apr 02, 2012 12:58 pm

A brand new Lisa 12 / Cinnamon 1.4 install on a Dell Inspiron 15r. When I have my second monitor plugged in, when I start Cinnamon it shows me my wallpaper but it doesn't fully start (no panels, for example). When I do (occasionally) get icons on the Desktop (i.e. "Computer") and use them to start Nautilus, the Nautilus window doesn't have any title bar at all, and you can't actually interact with the window at all (thought it does draw).

However, if I start Gnome 3 it works fine, it's only if I start Cinnamon. Cinnamon is definitely my preferred experience, so if there's some way to make it work, I'd be willing to provide any info.

Note that my co-worker's Mint+Cinnamon works fine on his 15r, although he started with Lisa before Cinnamon was a reality, and has upgraded from Cinnamon 1.3 on his install, so I'm not sure how that makes any difference, but it seems to. The only other difference is that his external monitor is different.

(FOR SEARCH ENGINES: cinnamon 1.4 multiple dual second monitor monitors)

AlbertP
Level 16
Level 16
Posts: 6725
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Cinnamon not starting with second monitor plugged in

Post by AlbertP » Mon Apr 02, 2012 1:29 pm

What graphics driver do you use? If it's NVidia, please make sure you use TwinView instead of Seperate X Screens option.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

sceo
Level 1
Level 1
Posts: 7
Joined: Tue Dec 06, 2011 9:34 am

Re: Cinnamon not starting with second monitor plugged in

Post by sceo » Mon Apr 02, 2012 2:06 pm

It is not nvidia, it is an Intel (the i915 driver). I DID notice that my coworker was on a newer version of xserver-xorg-video-intel, so I upgraded that but it does not help.

sceo
Level 1
Level 1
Posts: 7
Joined: Tue Dec 06, 2011 9:34 am

Re: Cinnamon not starting with second monitor plugged in

Post by sceo » Tue Apr 17, 2012 3:10 pm

Weird thing happened today. My co-worker plugged his 15r into the projector to give a presentation, and since doing that, he now has the same behavior as I do. We tried logging in as guest, and then changing the display settings, and that all works perfectly, so we were wondering if there were a way to completely remove cinnamon's settings so that they started from scratch, since that might work (as it does for guest). We tried renaming the cinnamon folder in .local/share and in .gconf/ -- are there other places we should be looking?

sceo
Level 1
Level 1
Posts: 7
Joined: Tue Dec 06, 2011 9:34 am

Re: Cinnamon not starting with second monitor plugged in

Post by sceo » Tue Apr 17, 2012 3:33 pm

OK, I tried to sudo apt-get autoremove --purge cinnamon and then reinstall it. Still same behavior.

When I start gnome3 and then run "cinnamon" or "cinnamon --replace" on the command line, I get the following:

Code: Select all

(cinnamon:24246): Clutter-WARNING **: Attempting to add actor of type 'CinnamonGenericContainer' to a container of type 'StBoxLayout', but the actor has already a parent of type 'StBoxLayout'.

(cinnamon:24246): Clutter-WARNING **: Attempting to add actor of type 'StScrollView' to a container of type 'StBoxLayout', but the actor has already a parent of type 'StBoxLayout'.
    JS ERROR: !!!   WARNING: 'anonymous function does not always return a value'
    JS ERROR: !!!   WARNING: file '/usr/share/cinnamon/applets/window-list@cinnamon.org/applet.js' line 377 exception 0 number 157
      JS LOG: Cannot find connection for active (or connection cannot be read)
      JS LOG: Cannot find connection for active (or connection cannot be read)

(cinnamon:24246): St-WARNING **: percentage lengths not currently supported
Window manager warning: Log level 16: The program 'cinnamon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 573 error_code 2 request_code 148 minor_code 31)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


sceo
Level 1
Level 1
Posts: 7
Joined: Tue Dec 06, 2011 9:34 am

Re: Cinnamon not starting with second monitor plugged in

Post by sceo » Tue Apr 17, 2012 6:02 pm

Changing my orientation so that the laptop display is left and the external display is right has fixed the problem, which I found in the Cinnamon issue queue:
https://github.com/linuxmint/Cinnamon/issues/577

I believe this is also related:
https://github.com/linuxmint/Cinnamon/issues/302

tiger2wander
Level 1
Level 1
Posts: 1
Joined: Wed May 23, 2012 4:04 am

Re: Cinnamon not starting with second monitor plugged in

Post by tiger2wander » Wed May 23, 2012 4:07 am

I have found a way to work around on this issue:

Run this command on your terminal before switch layout to classic or flipped

Code: Select all

   xrandr --output LVDS1 --preferred --auto --primary
This command will make laptop screen to primary then you will good to go with classic or flipped.

Sent from my ArchLinux :-)

Molgaard
Level 1
Level 1
Posts: 8
Joined: Mon Apr 16, 2012 7:01 am

Re: Cinnamon not starting with second monitor plugged in

Post by Molgaard » Wed May 23, 2012 9:30 am

You'd be most welcome to offer yourself as a tester, alongside myself, at http://forums.linuxmint.com/viewtopic.p ... 8&t=102450 . My reason for asking you is that the first answer seems to suggest an interest in solving the problem, but some difficulty with testing, due to developers' lack of multi-head setups, and my hope is that we can get enough testers (either in that thread, this, or another) to get the coders to post possible, untested, patches in that thread, knowing that they will be likely to be tested by at least one sooner rather than later.

The last posts in the linked thread are a bit rude IMHO, but I take them to support my notion that this should be fixed.

Best regards,

Sune Mølgaard

standev
Level 1
Level 1
Posts: 8
Joined: Sun Jun 17, 2012 10:24 am

Re: Cinnamon not starting with second monitor plugged in

Post by standev » Sun Jun 17, 2012 10:52 am

I have a similar problem with Linux Mint 13 Cinnamon on desktop with two monitors. By default, it's using one monitor and it's fine. However if I want to add 2nd monitor, I can't do it through (Settings -> Displays), 2nd monitor is not detected there at all. I wonder why?

So I run nvidia-settings, and then add 2nd monitor there. TwinView option is disabled for some reason, so I have to choose "separate X screen". After saving configuration to /etc/X11/xorg.conf and restarting Xorg, I get two monitors working, only instead of Cinnamon, MATE is loaded. At first it was alright, but after I've played with the configuration several times, now its taskbar is messed up, each item at the taskbar is duplicated multiple times (for example, there are four "Start" buttons, four "Show desktop" buttons and if I launch Firefox, it will create 4 Firefox slots in the taskbar). So I gave up, disabled the 2nd monitor, reset Xorg to default settings and using one monitor only. This is quite frustrating.

Technical details: 1st monitor is HP ZR30W, 2nd is Acer 27. Graphics card is nvidia gtx 690.
I've tried Ubuntu 12.04 too, and there are similar issues there too. Perhaps nvidia driver for Linux still sucks at supporting new gtx 690 card properly?

AlbertP
Level 16
Level 16
Posts: 6725
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Cinnamon not starting with second monitor plugged in

Post by AlbertP » Sun Jun 17, 2012 1:25 pm

You cannot use Cinnamon with Seperate X Screens because it has no 3D acceleration that way. I don't know why TwinView is disabled - what driver version do you use? You can run inxi -Gx to see it - when the second screen is disabled, as in Seperate X Screens mode the 3D information is not displayed.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

standev
Level 1
Level 1
Posts: 8
Joined: Sun Jun 17, 2012 10:24 am

Re: Cinnamon not starting with second monitor plugged in

Post by standev » Sun Jun 17, 2012 3:50 pm

Dear AlbertP, thank you for your help. This is what I see when I run that command.

Code: Select all

$inxi -Gx
Graphics:  Card: NVIDIA Device 1188 bus-ID: 03:00.0 
           X.Org: 1.11.3 drivers: nvidia (unloaded: nouveau,vesa,fbdev) Resolution: 2560x1600@50.0hz 
           GLX Renderer: GeForce GTX 690/PCIe/SSE2 GLX Version: 4.2.0 NVIDIA 295.49 Direct Rendering: Yes
NVIDIA driver is the most recent one from default Linux Mint 13 repositories. From what I've read about 295.49 version, it's supposed to support GTX 690 card. I'll try updating the driver from ppa:ubuntu-x-swat/x-updates and I'll post on results shortly.

UPD. Okay, did that, it updated me to 295.59 version with no effect. Still TwinView option is not available as a choice. What I can choose in nvidia settings for 2nd monitor is either "Disabled" or "Separate X screen". For the 1st monitor it's "Separate X screen" only, no choice.

AlbertP
Level 16
Level 16
Posts: 6725
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Cinnamon not starting with second monitor plugged in

Post by AlbertP » Mon Jun 18, 2012 3:57 am

Please run sudo nvidia-xconfig in terminal to clean up the xorg.conf file. Maybe twinview will become available then.

By the way, please try upgrading to the just released 302 driver using this PPA: https://launchpad.net/~ubuntu-x-swat/+archive/x-updates
First, uninstall the nvidia driver in case you manually installed it (if you used a DEB package you can leave it installed), then you can add the PPA:

Code: Select all

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
apt update
If you still have the nvidia-current package installed, you can then find an update to it in the updater (shield-like icon in the tray), else you can install the new version from the repository after adding the PPA.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

standev
Level 1
Level 1
Posts: 8
Joined: Sun Jun 17, 2012 10:24 am

Re: Cinnamon not starting with second monitor plugged in

Post by standev » Tue Jun 19, 2012 4:22 am

Thank you for your help, I really appreciate it.

I've launched sudo nvidia-xconfig as per your recommendation. I've also updated the driver to the 302 version. TwinView is still disabled.

Code: Select all

$ inxi -Gx
Graphics:  Card: NVIDIA Device 1188 bus-ID: 03:00.0 X.Org: 1.11.3 driver: nvidia Resolution: 2560x1600@60.0hz 
           GLX Renderer: GeForce GTX 690/PCIe/SSE2 GLX Version: 4.2.0 NVIDIA 302.17 Direct Rendering: Yes
This is my current xorg.conf:

Code: Select all

$ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 302.17  (buildmeister@swio-display-x86-rhel47-04.nvidia.com)  Tue Jun 12 17:05:44 PDT 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

AlbertP
Level 16
Level 16
Posts: 6725
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Cinnamon not starting with second monitor plugged in

Post by AlbertP » Tue Jun 19, 2012 4:29 am

Maybe you could try connecting the monitor to another output on the card?

It was a GTX 690, right? That's a dual-gpu card. Maybe the driver does not yet support using monitors connected to different gpu's on the same card as the 690 is still brand new.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

standev
Level 1
Level 1
Posts: 8
Joined: Sun Jun 17, 2012 10:24 am

Re: Cinnamon not starting with second monitor plugged in

Post by standev » Tue Jun 19, 2012 5:31 am

Good thinking! Did that and after loading into Linux Mint, the Displays section was able to see both monitors, and Nvidia Settings had TwinView option enabled for both monitors by default.

I wasn't able to rearrange which display should be left, and which should be right (it was vice versa). When I tried to do it via Displays, after the change the Cinnamon taskbar disappeared somewhere, so I removed .config/monitors.xml to return to workable state. When I tried to do the same via Nvidia Settings, when I clicked Apply button, it gave back a warning: "Failed to set MetaMode (1) 'DFP-0: nvidia-auto-select @2560x1600 +1920+0, DFP-2: nvidia-auto-select @1920x1080 +0+0' (Mode 4480x1600, id: 51) on X screen 0." Probably that's the reason why Displays section couldn't do it properly.

After several attempts I figured I can simply physically switch the monitor cables to make it as I want it (left display to be left, right to be right). So after I did that, it now works like a charm. Still can't change which display should be primary screen (i.e. which display should have taskbar), but that's a very minor issue to me and default option (first display is primary) is perfectly usable.

Thank you so very much! :D

AlbertP
Level 16
Level 16
Posts: 6725
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Cinnamon not starting with second monitor plugged in

Post by AlbertP » Tue Jun 19, 2012 5:37 am

The primary screen can be changed by moving the "taskbar" in Displays to the other monitor.

Since the 302 version the driver now also supports using Displays to set up dual-head. Previously you needed to use NVidia X Server Settings and save things to xorg.conf instead of your own monitors.xml file.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

standev
Level 1
Level 1
Posts: 8
Joined: Sun Jun 17, 2012 10:24 am

Re: Cinnamon not starting with second monitor plugged in

Post by standev » Tue Jun 19, 2012 5:54 am

Unfortunately, after any change if I click Apply in Displays section, the taskbar is gone. So all I can do from there is remove .config/monitors.xml, restart X server and avoid changing anything in Displays to keep system workable.

Another minor issue is that when I use Hot Corner function Workspace selection (ala Compiz Expo) which lets to see all the workspaces and windows like the Mission Control, it only shows windows from the first display. Windows from the second displays are ignored. So I switched it to Window selection (ala Compiz Scale) which works fine.

Thank you again for all the help, having properly working dual screen setup in Linux Mint just rocks! :) Now I don't have to boot Windows to use both displays.

AlbertP
Level 16
Level 16
Posts: 6725
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Cinnamon not starting with second monitor plugged in

Post by AlbertP » Tue Jun 19, 2012 6:30 am

The Expo indeed doesn't like dual monitor yet. There are a number of known bugs about it at https://github.com/linuxmint/Cinnamon
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

Post Reply

Return to “Cinnamon”