Have context menu's keyboard navigation shortcuts underlined by default

Forum rules
Before you post please read how to get help
Post Reply
Tokenson
Level 1
Level 1
Posts: 1
Joined: Wed Jun 27, 2018 2:34 am

Have context menu's keyboard navigation shortcuts underlined by default

Post by Tokenson » Wed Jun 27, 2018 3:00 am

Hello. I have a (hopefully temporary) disability where I cannot have my head pointed in the same direction for long without experiencing pain. On Windows and Cent OS, one of the key ways I am able to get around this is by using the keyboard to navigate, since the mouse requires me to maintain a stable gaze for longer, and so relying primarily on the mouse shortens the time I can comfortably use a computer drastically. I cannot find the setting to enable underlining the keyboard options in the context menus. By default, in Mint-X on Cinnamon, the underlines in the context menus (for nemo in particular) seem to appear only after using the arrow keys to navigate them. For anyone unaware of the term, a context menu is what comes up when you right-click, although there are other ways to trigger them.

Is there a way to change some setting so that the underlines show up by default in most applications? If not how can I tell nemo to show me the lines? I have checked every setting in Nemo's Edit->Preferences for this, and most of the settings in the Control Centre to no avail. I do not want to install a different theme if possible, and am perfectly comfortable editing settings files by hand if I have to. I found an post where a Cinnamon developer refused to address this issue, and mentioned that this behaviour is controlled by the theme, so I know I am not the only one who would benefit from this knowledge.

User avatar
BG405
Level 7
Level 7
Posts: 1537
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Have context menu's keyboard navigation shortcuts underlined by default

Post by BG405 » Thu Jun 28, 2018 3:06 pm

Hi, I just tried this and I see what you mean. Which version of Mint are you using e.g. 17.x, 18.x, 19?

It will help if you can post the output of inxi -Fxz (note: capital F if you type rather than copy/paste}. That should provide enough information.

Unfortunately I haven't been able to find where that setting might be, I'll keep looking as I have a few possible ideas. Might mean a modification to the theme though.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Acer D255E 2GB - Manjaro KDE, LM17.3 KDE 32
Toshiba NB305 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

Post Reply

Return to “Themes, Icons, & Wallpaper”