linuxmint 19 backgrounds settings do not work

Forum rules
Before you post please read how to get help
Post Reply
obastet
Level 1
Level 1
Posts: 3
Joined: Fri Jul 20, 2018 10:51 am

linuxmint 19 backgrounds settings do not work

Post by obastet » Fri Jul 20, 2018 5:25 pm

Hi,
I am using Linuxmint 19, fresh install, Cinnamon. Everything works great except for the backgrounds settings: all the options (no picture / mosaic / centred / scaled / stretched / zoom / spanned) do the same: they stretch the picture. It is always the same whether I use the original Tara backgrounds or some that I imported (Sonya, Sylvia). Could anyone help me solve this problem and make the backgrounds settings work?
Cheers,
Olivier.

User avatar
xenopeek
Level 24
Level 24
Posts: 23215
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: linuxmint 19 backgrounds settings do not work

Post by xenopeek » Sat Jul 21, 2018 6:05 am

It all works here from the v2 ISO.

Have you applied updates in Update Manager? I can't think of a possible reason for this aside from some patch update for Cinnamon or Muffin you haven't install yet. Or possibly issue with your graphics card driver? Suggest to add the output of command inxi -Fxrz run from the terminal here for others to perhaps have some more insight on that.
Image

obastet
Level 1
Level 1
Posts: 3
Joined: Fri Jul 20, 2018 10:51 am

Re: linuxmint 19 backgrounds settings do not work

Post by obastet » Sat Jul 21, 2018 11:24 am

Thanks for answering. I install all the updates as soon as they are proposed.
Here's what appears in my terminal after I run the command:

Code: Select all

System:    Host: olivier-HP-ENVY-Notebook-13-ab0XX Kernel: 4.15.0-29-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: HP product: HP ENVY Notebook 13-ab0XX v: Type1ProductConfigId serial: N/A
           Mobo: HP model: 82B9 v: KBC Version 03.18 serial: N/A
           UEFI: Insyde v: F.11 date: 12/09/2016
Battery    BAT0: charge: 7.6 Wh 14.6% condition: 52.0/52.0 Wh (100%)
           model: Hewlett-Packard Primary status: Discharging
CPU:       Dual core Intel Core i5-7200U (-MT-MCP-) 
           arch: Kaby Lake rev.9 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10848
           clock speeds: max: 3100 MHz 1: 400 MHz 2: 400 MHz 3: 400 MHz
           4: 400 MHz
Graphics:  Card: Intel HD Graphics 620 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@59.97hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)
           version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.15.0-29-generic
Network:   Card: Intel Wireless 7265 driver: iwlwifi bus-ID: 01:00.0
           IF: wlp1s0 state: up mac: <filter>
Drives:    HDD Total Size: 256.1GB (46.1% used)
           ID-1: /dev/nvme0n1 model: SAMSUNG_MZVLW256HEHP size: 256.1GB
Partition: ID-1: / size: 164G used: 110G (71%) fs: ext4 dev: /dev/nvme0n1p6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 35.0C mobo: 0.0C
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com tara main upstream import backport
           deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ bionic partner
Info:      Processes: 204 Uptime: 2 min Memory: 1765.2/7736.5MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56

obastet
Level 1
Level 1
Posts: 3
Joined: Fri Jul 20, 2018 10:51 am

Re: linuxmint 19 backgrounds settings do not work

Post by obastet » Tue Jul 31, 2018 2:49 pm

Hi. Due to the mentioned bug, and other little but annoying problems, I decided to re-install LM19. Works well now, but I have an overall impression that LM19 is less stable than LM18.3.
Thanks anyway.
Cheers,

User avatar
eastrader
Level 1
Level 1
Posts: 10
Joined: Wed May 03, 2017 12:35 pm
Location: Dallas, Texas

Re: linuxmint 19 backgrounds settings do not work

Post by eastrader » Fri Aug 17, 2018 1:54 pm

This seems the closest thread to my problem. First I updated 18.3 to 19 for some of the new capability. All went well, or so I thought. I recently decided to change my background from Tara to another and found it seemed locked somehow. I could download new backgrounds but could never change anything. All the photos in Tara are grey and I am unable to force a change. Yes my updates are done, and I have refreshed the packages, and performed the fix broken. My other pc with a fresh install of 19 does not have this problem at all and works perfect. I am using the installed drivers.
here is my results inxi -Fxrz:

System: Host: ed-GB-BXi3-5010 Kernel: 4.15.0-041500-generic x86_64
bits: 64 gcc: 7.2.0
Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1)
Distro: Linux Mint 19 Tara
Machine: Device: desktop Mobo: GIGABYTE model: MQLP3AP-00 v: 1.x serial: N/A
UEFI [Legacy]: American Megatrends v: F3 date: 03/06/2015
CPU: Dual core Intel Core i3-5010U (-MT-MCP-)
arch: Broadwell rev.4 cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8381
clock speeds: max: 2000 MHz 1: 1015 MHz 2: 922 MHz 3: 853 MHz
4: 910 MHz
Graphics: Card: Intel HD Graphics 5500 bus-ID: 00:02.0
Display Server: x11 (X.Org 1.19.6 )
drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.00hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio: Card-1 Intel Broadwell-U Audio Controller
driver: snd_hda_intel bus-ID: 00:03.0
Card-2 Intel Wildcat Point-LP High Def. Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-041500-generic
Network: Card-1: Intel Wireless 3160 driver: iwlwifi bus-ID: 02:00.0
IF: wlp2s0 state: down mac: <filter>
Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 03:00.0
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 120.0GB (48.0% used)
ID-1: /dev/sda model: Patriot_Pyro_m3 size: 120.0GB temp: 48C
Partition: ID-1: / size: 103G used: 47G (48%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 8.40GB used: 0.00GB (0%)
fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 50.0C mobo: 27.8C
Fan Speeds (in rpm): cpu: N/A
Repos: Active apt sources in file: /etc/apt/sources.list.d/danielrichter2007-grub-customizer-bionic.list
deb http://ppa.launchpad.net/danielrichter2 ... zer/ubuntu bionic main
deb-src http://ppa.launchpad.net/danielrichter2 ... zer/ubuntu bionic main
Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http://packages.linuxmint.com tara main upstream import backport
deb http://mirror.lstn.net/ubuntu bionic main restricted universe multiverse
deb http://mirror.lstn.net/ubuntu bionic-updates main restricted universe multiverse
deb http://mirror.lstn.net/ubuntu bionic-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ bionic partner
Active apt sources in file: /etc/apt/sources.list.d/spotify.list
deb http://repository.spotify.com stable non-free
Info: Processes: 227 Uptime: 1 day Memory: 3882.7/7805.0MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56
Always learning.

Post Reply

Return to “Themes, Icons, & Wallpaper”