Light grey text on bright white background in dark themes. (Solved)

Forum rules
Before you post please read how to get help
Post Reply
User avatar
farkas
Level 4
Level 4
Posts: 248
Joined: Mon Sep 21, 2015 6:10 pm
Location: Oregon

Light grey text on bright white background in dark themes. (Solved)

Post by farkas » Thu Aug 08, 2019 3:35 am

Mint 19.2 installed and running great!
Really appreciate the great choices available in Mint Themes. The theme I'm using is Cinnamox-Kashmire-Blue.
The problem I have is when I start vbox the right hand pane is bright white with very light grey text. Impossible to read! It is the same with all other dark themes that I tried. To make it readable I have to change Controls to a light theme, black text on bright white background. Don't know if this only on my machine or only in vbox, maybe someone else has the same problem. With Firefox and Thunderbird I can change background and font colors, haven't found a way to adjust that in vbox. It's a bit annoying, but I can live with it.

One more thing, using text editor with a dark theme to compose this post with spell check enabled. Spell checker underlines errors in a tiny red line, barely visible, how do you make it brighter and/or bolder?
Is there a way to change the background while composing a post in Mint Forums?
Great job Mint Team!
Thank you all.
Last edited by farkas on Fri Aug 09, 2019 8:18 pm, edited 1 time in total.
If your query has been resolved, edit your first post and add [SOLVED] to the subject line.
If you found a solution on your own please post it.

User avatar
smurphos
Level 12
Level 12
Posts: 4086
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Light grey text on bright white background in dark themes

Post by smurphos » Thu Aug 08, 2019 1:02 pm

Presumably this is Virtualbox 6?

It's gtk2 theme integration is completely broken.

Luckily you've made a good choice of theme :roll: :wink:

The Cinnamox themes ship with a qt5ct colour scheme file which you can apply with the Qt5 settings app from the menu which mostly fixes the issue.

First do this as per the theme readme -

If you need support for qt5ct configuration the theme includes a premade qt5ct.conf file and a helper script to install it to the correct location `~/.config/qt5ct/colors`

To run the script open a terminal window (Ctrl-Alt-T) and use the following command to make the script executable and launch it.

Code: Select all

chmod +x ~/.themes/Cinnamox-Kashmir-Blue/qt5ct/cinnamox_enable_qt5ct.sh && ~/.themes/Cinnamox-Kashmir-Blue/qt5ct/cinnamox_enable_qt5ct.sh
Then open the QT5 settings app and apply the newly installed colour scheme.

Image

For non Cinnamox users with a dark theme the other workaround is launch Virtualbox with the QT theme Fusion which generally doesn't clash to much with most dark themes. See viewtopic.php?p=1567976

Re the text editor - assuming you are using Xed - you can apply one of Xeds built in themes to the editor window. Edit > Peferences > Themes.
Last edited by smurphos on Fri Aug 09, 2019 1:52 am, edited 2 times in total.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
farkas
Level 4
Level 4
Posts: 248
Joined: Mon Sep 21, 2015 6:10 pm
Location: Oregon

Re: Light grey text on bright white background in dark themes

Post by farkas » Thu Aug 08, 2019 4:52 pm

Thanks for your reply!
Using vbox 6.0.10 and Xed.
Tried to run the command from your post, not sure it got copied completely.
Results

Code: Select all

steve@steve-lap:~$ chmod +x ~/.themes/Cinnamox-Kashmir-Blue/qt5ct/cinnamox_enable_qt5ct.sh && ~/.themes/Cinnamox-Kashmir-Blue/qt5ct
bash: /home/steve/.themes/Cinnamox-Kashmir-Blue/qt5ct: Is a directory
steve@steve-lap:~$ 
Opened Qt5 settings, there was no choice for custom color scheme.
If your query has been resolved, edit your first post and add [SOLVED] to the subject line.
If you found a solution on your own please post it.

User avatar
smurphos
Level 12
Level 12
Posts: 4086
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Light grey text on bright white background in dark themes

Post by smurphos » Fri Aug 09, 2019 1:52 am

Sorry the quote cut off the end of the command

Code: Select all

chmod +x ~/.themes/Cinnamox-Kashmir-Blue/qt5ct/cinnamox_enable_qt5ct.sh && ~/.themes/Cinnamox-Kashmir-Blue/qt5ct/cinnamox_enable_qt5ct.sh
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
farkas
Level 4
Level 4
Posts: 248
Joined: Mon Sep 21, 2015 6:10 pm
Location: Oregon

Re: Light grey text on bright white background in dark themes

Post by farkas » Fri Aug 09, 2019 8:17 pm

Thank you for your reply smurphos!
Your edit worked.
The vbox right pane looks great.
If your query has been resolved, edit your first post and add [SOLVED] to the subject line.
If you found a solution on your own please post it.

Post Reply

Return to “Themes, Icons, & Wallpaper”