Segmentation fault in fusion-icon: Linuxmint 15

Forum rules
Before you post please read how to get help
Post Reply
i3cx9f
Level 1
Level 1
Posts: 1
Joined: Sat Jun 08, 2013 5:16 pm

Segmentation fault in fusion-icon: Linuxmint 15

Post by i3cx9f » Mon Jun 10, 2013 7:51 pm

Hi,

I have successfully enabled compiz on mate 1.6. But when I try to run fusion-icon it gives segmentation fault error.
Below is the output from fusion-icon

Code: Select all

 * Detected Session: mate
 * Searching for installed applications...
Segmentation fault
I ran it under gdb to see what's going on. The output is below.

Code: Select all

(gdb) exec-file python
(gdb) run /usr/bin/fusion-icon
Starting program: /usr/bin/python2.7 /usr/bin/fusion-icon
warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7ffff7ffa000
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
 * Detected Session: mate
 * Searching for installed applications...

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff5e79624 in ccsObjectGetInterface_ () from /usr/lib/libcompizconfig.so.0
(gdb) bt
#0  0x00007ffff5e79624 in ccsObjectGetInterface_ () from /usr/lib/libcompizconfig.so.0
#1  0x00007ffff5e8360c in ccsConfigFileReadConfigOption () from /usr/lib/libcompizconfig.so.0
#2  0x00007ffff5e7d8ed in ?? () from /usr/lib/libcompizconfig.so.0
#3  0x00007ffff5e7db0e in ccsEmptyContextNew () from /usr/lib/libcompizconfig.so.0
#4  0x00007ffff65def5b in ?? () from /usr/lib/python2.7/dist-packages/compizconfig.so
#5  0x00000000004b1958 in ?? ()
#6  0x00000000004b1920 in ?? ()
#7  0x0000000000a56530 in ?? ()
#8  0x00000000009a22e0 in ?? ()
#9  0x0000000000a568a0 in ?? ()
#10 0x0000000000a56a40 in ?? ()
#11 0x000000000047c19d in ?? ()
#12 0x0000000000000000 in ?? ()
Can someone please tell me what's happening here? I dont quiet understand gdb :?

aac74
Level 2
Level 2
Posts: 55
Joined: Sat Dec 08, 2012 2:29 pm

Re: Segmentation fault in fusion-icon: Linuxmint 15

Post by aac74 » Sun Aug 18, 2013 2:43 pm

I can't get fusion-icon to start either in mint 15 32bit xfce


Post Reply

Return to “Compiz, Conky, Docks, & Widgets”