compiz just does not work

Forum rules
Before you post please read how to get help
rp1040
Level 1
Level 1
Posts: 3
Joined: Wed Apr 06, 2016 12:55 pm

compiz just does not work

Postby rp1040 » Fri Sep 16, 2016 3:06 pm

I'm new to this forums only used it once with no success.here gose.
was given a laptop by a friend. it's a hp pavilion entertainment pc
amd turion 64 x2
NVidia graphic card
120 gig hard drive
2 gig of memory

I have installed linux mint 18 sarah mate desktop for the 12th time just can not get compiz to work at all I keep getting these errors
dark screen
white screen with lines
desktop disappears
or simply does not boot

I did install Ubuntu 14.04 and that worked fine.i realy like mint and would like to get I to work.
I've read and tried most of the method on this forum but didn't work for me. the learning curve with linux and the terminal is steep to say the least

User avatar
kdemeoz
Level 3
Level 3
Posts: 181
Joined: Thu Jan 14, 2016 2:17 am
Location: Land of Oz

Re: compiz just does not work

Postby kdemeoz » Mon Sep 19, 2016 4:03 am

I'm afraid i cannot help you regarding the compatibility of Compiz with Mint 18 Mate [though i would have imagined they should be fine together]. Maybe your hardware might be the problem? However, i can confidently offer you the following info, based on my own personal experience over the last couple of weeks with Mint 18 Xfce + Compiz. Basically, they are fabulous together!

My Tower & Laptop have both run Mint 17.3 KDE4 until recently, when i converted the Laptop to 18 Xfce+Compiz. I took that step after weeks of playing with Mint 18 Xfce in a VM i created in my Tower, specifically for me to learn about Xfce & Compiz [i'd not used either before, only KDE] & determine if Xfce would be a good candidate for my Laptop. At first i struggled with Compiz, not getting it to work at all, then getting it going a bit, then tweaking something else & completely breaking Xfce needing a reinstallation. Once i was running again i continued to explore Compiz, learning bit by bit [i find it is very complex, often unintuitive, & scarily easy to break; KDE KWin feels more robust & less dangerous IMO]. However i persisted, & reached the point of great happiness with the results. I now have LOTS of great eye-candy & functionality, including 18 VDs [in effect, functionally, a quasi- 3 Activity 6 VD KDE-metaphor] with individual wallpapers, wobbly windows, cube, expo etc. Also, only today, i discovered gnome-color-chooser & installed that too [via Synaptic], so now my Lappy's new OS is really functional, tricky and pretty!

I mentioned all that because if you continue to have disappointment with Mate + Compiz, you might want to consider trying Xfce + Compiz instead. If that also does not work for you then it would definitely be your hardware's fault, or your method, given my intensive experience in a VM then in my real Lappy proves Mint 18 Xfce + Compiz is a winner!

Good luck.
openSUSE Tumbleweed Plasma 5.11.3, & Manjaro KDE 5.11.4 [Mint 17.x KDE4 2014-2016]

User avatar
kdemeoz
Level 3
Level 3
Posts: 181
Joined: Thu Jan 14, 2016 2:17 am
Location: Land of Oz

Re: compiz just does not work

Postby kdemeoz » Tue Sep 20, 2016 3:36 am

Update on my first paragraph, FYI. I'd forgotten til today that i already have an existing VM for Mint 18 Mate [very little used because i find Mate quite boring & restricted, so it had entirely slipped my mind that i even had set it up back in early July]. On a whim therefore i launched it, activated Compiz then imported my successful Xfce config file for it. Not a sausage [ie, not a single one of my wonderful Xfce Compiz special effects worked in Mate]! I intuit hence that Compiz might be broken in Mate...
openSUSE Tumbleweed Plasma 5.11.3, & Manjaro KDE 5.11.4 [Mint 17.x KDE4 2014-2016]

bmac6446
Level 1
Level 1
Posts: 9
Joined: Tue Jan 21, 2014 10:30 am

Re: compiz just does not work

Postby bmac6446 » Sat Sep 24, 2016 4:49 pm

Have you installed the proprietary video drivers for your Nvidia card? It sounds like your desktop isn't set up for compositing yet. Check in Menu/Administration/Driver Manager and see which video driver is installed and is selected. Chances are you may still be on the Nouveau driver.


Return to “Compiz, Conky, Docks, & Widgets”