Gnome Flashback does not work

Forum rules
Before you post please read how to get help
Post Reply
User avatar
mnom
Level 1
Level 1
Posts: 13
Joined: Thu Jun 23, 2016 6:42 pm

Gnome Flashback does not work

Post by mnom » Sat Feb 04, 2017 5:09 pm

Hello!
I have installed gnome-session-flashback but after logging out and trying to change session, I get back to Mate.

Code: Select all

cat $DESKTOP_SESSION
cat: mate: No such file or directory
So, I'm still on Mate. How to fix it?

User avatar
karlchen
Level 19
Level 19
Posts: 9190
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Gnome Flashback does not work

Post by karlchen » Sat Feb 04, 2017 5:22 pm

Hello, mnom.

$DESKTOP_SESSION is not a file, but an environment variable. The commandline to display the content of the environment variable $DESKTOP_SESSION therefore is not cat, but

Code: Select all

echo $DESKTOP_SESSION
Is Gnome-Flashback (Compiz) or Gnome-Flashback (Metacity) listed in the MDM Greeter Screen (login) at all? Cf. Install and tweak the GNOME Flashback Session in Ubuntu 14.04

Regards,
Karl
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

User avatar
mnom
Level 1
Level 1
Posts: 13
Joined: Thu Jun 23, 2016 6:42 pm

Re: Gnome Flashback does not work

Post by mnom » Sun Feb 05, 2017 3:24 pm

I walked through the article.
Of course installed flashback

Code: Select all

sudo apt-get install gnome-session-flashback
Than nothing new got installed on

Code: Select all

sudo apt-get install compizconfig-settings-manager
The rest is optional.

Yes, I have both gnome flashbacks available in starting screen.
But the behavior is strange. If I choose either of them the screen goes black with only pointer or it boots into Mate. $DESKTOP_SESSION confirms that it is Mate.

So, no luck for now.

Post Reply

Return to “Compiz, Conky, Docks, & Widgets”