CPU Fan Speed Not Detected

Forum rules
Before you post please read how to get help
Post Reply
Pizzly
Level 1
Level 1
Posts: 17
Joined: Wed Mar 18, 2015 10:04 am

CPU Fan Speed Not Detected

Post by Pizzly » Wed Feb 22, 2017 4:08 pm

I dual-boot Linux Mint 17.3 & Linux Mint 18.1

Boards' a Gigabyte Z97X-UD5H-BK.

I installed 'lm-sensors' in Linux Mint 17.3 & 18.1, but the 'cpu fan speed' is only displayed in version 18.1.

This occurs both in Conky and in terminal when I type [sensors], re: 17.3 & 18.1.

Mint 17.3, no cpu fan speed in Conky or terminal, mint 18.1, cpu fan speed detected and displayed in conky and terminal.

Anyone know how to resolve this?

Mint 18.1 is my main OS, but some PPA's I need programs from do not support Xenial 16.04, so I occasionally need to revert to Mint 17.3.

Thank-you,

User avatar
richyrich
Level 18
Level 18
Posts: 8819
Joined: Mon May 04, 2009 8:31 pm

Re: CPU Fan Speed Not Detected

Post by richyrich » Wed Feb 22, 2017 7:38 pm

Did you get any hits at all when you ran sensors-detect on the 17.3 machine ?

Pizzly
Level 1
Level 1
Posts: 17
Joined: Wed Mar 18, 2015 10:04 am

Re: CPU Fan Speed Not Detected

Post by Pizzly » Wed Feb 22, 2017 8:06 pm

Everything is working fine on the 18.1 volume, but there's no cpu fan speed on the 17.3 volume-

Conky 1.10.6-1 on both, I think I even tried 1.10.3-1 without results-

Same Conky on both too....

I abandoned Conky 1.9 and upgraded both Conky's to work with Conky 1.10.x

Well?............. :mrgreen:

User avatar
richyrich
Level 18
Level 18
Posts: 8819
Joined: Mon May 04, 2009 8:31 pm

Re: CPU Fan Speed Not Detected

Post by richyrich » Wed Feb 22, 2017 8:43 pm

You didn't answer my question. :shock:

Edit: lm-sensors (cpu fan speed) will NOT work until you run sensors-detect.

Pizzly
Level 1
Level 1
Posts: 17
Joined: Wed Mar 18, 2015 10:04 am

Re: CPU Fan Speed Not Detected

Post by Pizzly » Thu Feb 23, 2017 5:57 am

Yes, I ran sensors-detect...

Post Reply

Return to “Compiz, Conky, Docks, & Widgets”