Page 1 of 1

Can't get cairo dock to work (SOLVED)

Posted: Thu Jun 08, 2017 8:28 pm
by kevin3331
I can't get cairo dock to work on mint kde 18.1 no matter what i try don't know if it is a hardware issue or what. when installed most settings are greyed out so can not
be configured. here is my system info.

Also can only download from package manager can not get from ppa. searched for days for ppa and searched for days for a fix for solution to issue
updated nividia driver from 375 to 381 thinking that might be the issue. also down graded from 3.1 open gl setting to 2.0 open gl setting to see
if possible that might help no difference. pulling my hair out. hope someone can help.

Code: Select all

kevin@kevin-desktop ~ $ inxi -Fxz
System:    Host: kevin-desktop Kernel: 4.4.0-75-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: KDE Plasma 5.8.5 (Qt 5.6.1) Distro: Linux Mint 18.1 Serena
Machine:   Mobo: ASUSTeK model: SABERTOOTH 990FX R2.0 v: Rev 1.xx
           Bios: American Megatrends v: 2501 date: 04/08/2014
CPU:       Octa core AMD FX-8350 Eight-Core (-MCP-) cache: 16384 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 65821
           clock speeds: max: 4113 MHz 1: 4113 MHz 2: 4113 MHz 3: 4113 MHz 4: 4113 MHz
           5: 4113 MHz 6: 4113 MHz 7: 4113 MHz 8: 4113 MHz
Graphics:  Card: NVIDIA GM107 [GeForce GTX 750 Ti] bus-ID: 07:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz, 1680x1050@59.95hz
           GLX Renderer: GeForce GTX 750 Ti/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 381.22 Direct Rendering: Yes
Audio:     Card-1 NVIDIA Device 0fbc driver: snd_hda_intel bus-ID: 07:00.1
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-3 Licensed by Sony Entertainment America driver: USB Audio usb-ID: 007-002
           Card-4 Logitech Webcam C310 driver: USB Audio usb-ID: 001-002
           Sound: Advanced Linux Sound Architecture v: k4.4.0-75-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: b000 bus-ID: 0a:00.0
           IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 3120.6GB (30.3% used)
           ID-1: /dev/sda model: Samsung_SSD_840 size: 120.0GB
           ID-2: USB /dev/sdb model: Expansion_Desk size: 3000.6GB
Partition: ID-1: / size: 38G used: 14G (38%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 73G used: 8.1G (12%) fs: ext4 dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 27.0C mobo: 18.1C gpu: 0.0:30C
           Fan Speeds (in rpm): cpu: 0 fan-1: 1214 fan-2: 1315 fan-3: 383
Info:      Processes: 233 Uptime: 2:53 Memory: 1247.7/16025.9MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0 Client: Shell (bash 4.3.481) inxi: 2.2.35 

Re: Can't get cairo dock to work

Posted: Wed Jun 14, 2017 12:08 am
by CaptainKirksChair
I don't believe Cairo Dock works with KDE. Something about it being a GTK app. I know it works fine with Cinnamon, though.


Re: Can't get cairo dock to work

Posted: Wed Jun 14, 2017 1:39 pm
by kevin3331
Thanks for replying i came to that conclusion also. i just went with plank. i just wanted cairo cause of all the bells and whistles.
plank suits my needs though. just wanted something for my editing apps and and ide apps on my second monitor to be easily
accessible. I think it might be a Kwin issue or cairo don't play well with out compiz not sure . but i love my Kwin so not installing
compiz. but anyways thanks for replying.

Re: Can't get cairo dock to work

Posted: Tue Jun 27, 2017 9:18 pm
by Ubulindy
Cairo most def works in KDE. There is 2 different modes: cairo-dock and cairo-dock fallback mode. I "think" you might be in fallback mode.
Launch it again. A box will come up and I cant remember exactly what is says, but tick the box that say "remember my choice" . Has to do with the modes. Do not choose fallback. Also when you installed cairo-dock, make you you grabbed all the plugins, ect., I see you were looking for a PPA? Why? You're on Mint KDE, Im on KDE Neon. In Mint your package manager might be Synaptic? In KDE Neon it is Discover/Muon. You might not have grabbed all the extras that you need. Also, the orange icon that will show in the dock so that you can get to the cairo settings....just do a right click on ANY of the icons in the dock, you'll see the orange one for cairo, and create a laucher for it. Do not just click on it to open it once you have created that icon. That also has 2 modes. You MUST right click and open the menu, one is "simple config", the other one is full on settings, basically expert mode. If you forget and accidentally just click on the orange icon to open up the settings, it will create 2 docks right on top of each other. If it happens, just go into ksysguard and kill one of them. After it is working, go into "system settings" > "startup and shutdown">"auto start" and "add program" Add: Cairo Dock.... command: cairo-dock Bam! Done! Enjoy.

Re: Can't get cairo dock to work

Posted: Sun Jul 09, 2017 6:39 pm
by kevin3331
Ok found my problem and was my fault. turns out for some reason cairo installs as root.
so have to change permission and access and boom all works. dumb mistake on my part.
problem solved.

Re: Can't get cairo dock to work (SOLVED)

Posted: Sun Jul 09, 2017 6:40 pm
by kevin3331
Solved the issue