Compiz Watereffect not working

Forum rules
Before you post please read how to get help
MSt1982
Level 1
Level 1
Posts: 49
Joined: Mon Jul 13, 2015 11:01 pm

Compiz Watereffect not working

Postby MSt1982 » Wed Jul 05, 2017 2:13 am

Hi,
since several releases of Mate (years ago it was fine) I am getting more and more problems (here and there my hardware changed, too) - however,
my actual problem is that with my GTX 660 since some releases of Mate the compiz-water-effect does not work anymore.

I activate it in the settings but if I press the key-combination to activate it nothing happens. The cube is (almost) fine.

Why - and more important - how to solve this? Using Nvidia 375.66 and Mint Mate 18.2, fresh installed. Any ideas? Many thanks already.

pemartins
Level 1
Level 1
Posts: 26
Joined: Wed Jul 05, 2017 3:41 pm

Re: Compiz Watereffect not working

Postby pemartins » Wed Aug 02, 2017 7:51 pm

Try changing the initiate key combination, it's possible that there is a conflict with the predefined key combination. In example set it as Ctrl+Alt+< and check if it works.

MSt1982
Level 1
Level 1
Posts: 49
Joined: Mon Jul 13, 2015 11:01 pm

Re: Compiz Watereffect not working

Postby MSt1982 » Sat Aug 26, 2017 5:38 pm

Not helping, what else can I do?

Is there any log-file or something like that to see what is going wrong exactly?

MSt1982
Level 1
Level 1
Posts: 49
Joined: Mon Jul 13, 2015 11:01 pm

Re: Compiz Watereffect not working

Postby MSt1982 » Sun Sep 17, 2017 8:42 am

How can I find out why the watereffect does not work? Is there any log?

Does the effect work on your pc actually?

User avatar
richyrich
Level 18
Level 18
Posts: 8677
Joined: Mon May 04, 2009 8:31 pm

Re: Compiz Watereffect not working

Postby richyrich » Sun Sep 17, 2017 12:42 pm

Check in Synaptic Package Manager to see if you have both compiz-plugins-default and compiz-plugins installed.

MSt1982
Level 1
Level 1
Posts: 49
Joined: Mon Jul 13, 2015 11:01 pm

Re: Compiz Watereffect not working

Postby MSt1982 » Wed Sep 27, 2017 12:02 am

Yes, they are both installed.
More ideas?

Does it work on your computers as it should??


Is there any logfile or any way to let compiz it output whats wrong??

Wobbly windows works, cube works (almost, except little glitches when moving windows across the border as mentioned in another thread)...it seems just rain/watereffect does not work anymore on several systems (ati, nvidia) here since some years and several releases of mint mate - does it work on your systems?

zcot
Level 1
Level 1
Posts: 24
Joined: Wed Oct 19, 2016 6:08 pm

Re: Compiz Watereffect not working

Postby zcot » Wed Sep 27, 2017 7:35 pm

Have you tried with/without "Mate compatibility" selected in the General section of compiz panel?

Aside from that, the key shortcut is combined with super key so it(and any other super related key combo) is not going to work, however that was an issue fixed for 18.2.

At this case you can change the main menu key shortcut from super to free it up, and then it will work for you, or as previously mentioned change the water key. maybe <Shift>F10 is free right with the other ones.

For me, <Shift>F9 rain is more interesting. But on 3 systems that I tested the water does push out some splash damage from the mouse while you hold the keys. The other 2 effects are toggles.

Have you tried the "reset compiz to default" thing in the Desktop Setting window manager section?

it works the same on an xfce box too.

...just throwing stuff out there.

MSt1982
Level 1
Level 1
Posts: 49
Joined: Mon Jul 13, 2015 11:01 pm

Re: Compiz Watereffect not working

Postby MSt1982 » Mon Oct 30, 2017 9:49 am

It just does not work here, even if I activate "Mate compatibility" or not, same with changing the keys...

There definately is another problem.

Is there no logfile anywhere? Or any other way to see why it does not work??


Return to “Compiz, Conky, Docks, & Widgets”