Page 1 of 1

[SOLVED(or no longer relevant more like)] Can't Configure Appletts in Cinnamon 19.1

Posted: Sun Mar 03, 2019 2:20 am
by Spyhunter10
I have been doing quite a bit of customization of the appearance and layout in my system, in preparation to create my own personal custom distribution that i may perhaps share with a friend or two. I came upon an issue when i tried to adjust the menu. I had installed the CinnVIIStarkMenu, which i like quite a bit, but when i went back to reset my icon for it, i could not open the "configure" that appears when you right click. it shows up and i can click on it, but it no longer opens. i checked my other appletts and they don't open configure either. I'm sure its something i did, i've been modifying more things than i can count, but try as i might, i cannot figure out what affected it. Any Ideas guys? Thanks in Advance. :?

Re: Can't Configure Appletts in Cinnamon 19.1

Posted: Sun Mar 03, 2019 3:06 am
by smurphos
Run in a terminal

Code: Select all

tail -f ~/.xsession-errors
Then leaving that terminal window open try to access some applet config screens. Report back with any output from the tail command produced as you do this.

Does it work if you try and access the config via the Applets settings module?

Re: Can't Configure Appletts in Cinnamon 19.1

Posted: Sun Mar 03, 2019 3:41 am
by Spyhunter10
smurphos wrote:
Sun Mar 03, 2019 3:06 am
Run in a terminal

Code: Select all

tail -f ~/.xsession-errors
Then leaving that terminal window open try to access some applet config screens. Report back with any output from the tail command produced as you do this.

Does it work if you try and access the config via the Applets settings module?
Thanks for the reply. i tried that but the only output i got said my laptop wasn't charging or something to that effect. i tried from the applets settings module and that doesn't work either. it may help to know that certain configs will run but not the one for the cinnamon menu or the CinnVIIStarkMenu. i had thought it was any, but either i was somehow mistaken, or that changed.

EDIT: i don't know if this helps but i ran the commands to start various applets in terminal and the ones that worked simply started as normal with no feedback. the two menu applets both said this "Segmentation fault (core dumped)"

Re: Can't Configure Appletts in Cinnamon 19.1

Posted: Sun Mar 03, 2019 4:24 am
by smurphos
Can you post the full terminal output from those attempts?

Re: Can't Configure Appletts in Cinnamon 19.1

Posted: Sun Mar 03, 2019 5:40 am
by Spyhunter10
smurphos wrote:
Sun Mar 03, 2019 4:24 am
Can you post the full terminal output from those attempts?
I had already closed them out, i could run them again but i just realized it makes not sense that i am fixing problems in a system i am trying to compile one perfect clean copy of. i have other issues, residual programming i don't need, all kinds of stuff, so now that i actually know what to put together, i am going to do a fresh install, which renders this issue irrelevant. I apologize for wasting your time, if i had been thinking on my feet i would have done this already.