Page 1 of 1

Conky not showing in Gnome-shell

Posted: Thu Dec 15, 2011 10:41 am
by Stephen Morgan
I'm having the above problem in a new install of Lisa, and I'm baffled by it.

I'm starting it from the console, and it's showing the same messages I'd always expect from Conky, no error messages of any kind. It just never appears on the desktop.

I've tried changing the .conkyrc settings,specifically own_window_class setting, but it doesn't seem to make any difference at all. I've also tried changing the setting which has the file manager manage the desktop, no effect.

In MATE, on the other hand, conky works fine. I also installed Unity through the software centre and Conky doesn't show in that either.

Re: Conky not showing in Gnome-shell

Posted: Thu Dec 15, 2011 12:49 pm
by lurkatron
these window settings work for me in gnome-shell
#############################
own_window yes
own_window_class Conky
own_window_type normal
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
#own_window_argb_visual yes
#own_window_argb_value 100
###################
note the bottom 2 entries are commented out

Re: Conky not showing in Gnome-shell

Posted: Thu Dec 15, 2011 1:13 pm
by Stephen Morgan
Bingo, that's sorted it. The only difference is the own_window_type setting, which I had set to override, rather than normal, which didn't cause a problem in Gnome 2 or MATE but does with Gnome 3.