compiz in startup applicatoin, but does not startup

Forum rules
Before you post please read how to get help
Recko
Level 1
Level 1
Posts: 1
Joined: Sat Jan 07, 2012 11:25 am

compiz in startup applicatoin, but does not startup

Postby Recko » Sat Jan 07, 2012 12:15 pm

Hello, I am a newbie and my English is not good. I hope I can address my question clearly.

I have been trying to have compiz effect in Mint 12 this afternoon. I got a partial success by the help of others' experience. In detail: I installed compiz* packages. After I log in Gnome Classic, I can start the effect with compiz --replace. So I think the hardware support is ok, the only thing I need is to add "compiz --replace" in the startup application. I did it and restarted. No effect. I manually run compiz --replace, the effect came back. Then I did more search and am confused.

The followings are the information I found :

Someone seems get the compiz work with Gnome Classic (in Mint 12 or Ubuntu 11.xx). e.g This is the instruction I followed, but encounter the startup issue.
http://www.howtoforge.com/enabling-comp ... 2-gnome-12

A similar theory in the forum : viewtopic.php?f=90&t=90578&p=521553&hilit=compiz+mint+12#p521553

Then my questions :
1. compiz is compatible with Gnome 2, but that Gnome Classic in Mint 12 runs with the same shell as Gnome 3. Is this true? To be honest, I am confused about these names.

2. people say compiz can not run with Gnome 3 (or Gnome shell). If 1 is true, why I can have the visual effect in Gnome Classic by compiz --replace?

3. If 1 is false, why compiz added in startup does not startup automatically, but can be activate by compize --replace after login Gnome Classic? Some features blocks compiz's startup?

Thanks in advance for any response.

Electroman6913
Level 2
Level 2
Posts: 74
Joined: Mon May 30, 2011 6:57 pm

Re: compiz in startup applicatoin, but does not startup

Postby Electroman6913 » Sun Jan 15, 2012 11:53 am

I think the clasic startup DE is Mate not Gnome 3 because Gnome 2 and Gnome 3 can't be installed on the same computer.

Maybe Compiz is trying to start before the DE session is fully booted. You could write a script with a sleep command before compiz --replace

#!/bin/bash

sleep 5
compiz --replace

save as <filename>.sh
enable permissions as executable.


Return to “Compiz, Conky, Docks, & Widgets”

Who is online

Users browsing this forum: No registered users and 3 guests