Page 1 of 1

[solved]rsync error

Posted: Sun Apr 02, 2017 4:55 pm
by pfd27
Hi Guys

Having a issue with rsync I'm hoping someone can help me with.
I have a bash script with a bunch of rsync commands to back up some folders to my
file server. I recently installed a second drive that is mounted in media/Storage.
I think the permissions are right because I can ssh into the folder and write to it.
The following is the code I am using

Code: Select all

rsync -avz --delete /home/rob/Downloads/

and I get this output

Code: Select all

sending incremental file list
rsync: mkdir "/home/rob/media/Storage/Pfd27/Downloads" failed: No such file or directory (2)
rsync error: error in file IO (code 11) at main.c(674) [Receiver=3.1.1]
It is trying to make the folder in my home folder instead of where the folder is mounted and is not even making it in the home folder.
I have tried everything I can think of and can't fine a answer with google.

Re: rsync error

Posted: Sun Apr 02, 2017 6:31 pm
by slipstick
Shouldn't that destination be /media/rob/Storage... instead of /home/rob/media/Storage... ?

Re: rsync error [Solved]

Posted: Sun Apr 02, 2017 8:07 pm
by pfd27
Thought it was going to be something silly. I had forgot to put a '/' in front of the destination folder

Code: Select all

rsync -avz --delete /home/rob/Documents/