Automatic Login & Last Session not working

Archived topics about LMDE 1
Forum rules
grobi
Level 1
Level 1
Posts: 1
Joined: Tue Jan 08, 2013 2:56 pm

Automatic Login & Last Session not working

Postby grobi » Tue Jan 08, 2013 3:24 pm

Hello,

I recently installed Cinnamon + MDM on my Ubuntu 12.10.

For now this setup behaves fine except of the auto login feature. For my understanding, this should skip the user name prompt on login screen. But it does not. I still need to enter my login name before it comes to enter the password.

Apart from this mdm starts an ubuntu session by default. I need to choose "Cinnamon" manually from the session list to start it.

Any ideas why these things aren't working properly on my system?

Code: Select all

mgrobelin@wopr ~ $ grep -v \# /etc/mdm/mdm.conf | grep -v '^$'
[daemon]
AutomaticLogin=mgrobelin
DefaultSession=cinnamon.desktop
AutomaticLoginEnable=true
[security]
RelaxPermissions=0
CheckDirOwner=false
[xdmcp]
[gui]
AllowGtkThemeChange=false
[greeter]
GraphicalTheme=linuxmint
ChooserButton=false
ConfigAvailable=false
SystemMenu=false
SoundOnLogin=false
[chooser]
[debug]
[servers]

mgrobelin@wopr ~ $ /usr/sbin/mdm --version
MDM 1.0.8

mgrobelin@wopr ~ $ /usr/bin/cinnamon --version
Cinnamon 1.6.7

User avatar
telcnas
Level 1
Level 1
Posts: 12
Joined: Mon Jun 04, 2012 3:16 am
Location: India
Contact:

Re: Automatic Login & Last Session not working

Postby telcnas » Wed Jan 09, 2013 6:03 pm

For automatic login you may need to enable following things....

First in "Users Account" app you must enable automatic login for selected user..
Secondly you must enable Automatic Login Under Security Tab of mdmsetup i.e. $sudo mdmsetup -> Enter Your Password -> Security Tab -> Enable Automatic Login checkbox for selected user....
अभयंसत्वसंशुद्धि........१६/१
Image


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 1 guest