LMDE 2 Betsy with Cinnamon 2.4

Archived topics about LMDE 1
Locked
User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself » Mon Nov 24, 2014 9:45 am

Just wanted to spread the word that Cinnamon 2.4 from the betsy repo is working nicely now and it's possible to upgrade to LMDE 2 by changing your sources and doing a dist upgrade. These are what I used.

deb http://packages.linuxmint.com betsy main upstream import

deb http://ftp.us.debian.org/debian/ jessie main contrib non-free
deb http://ftp.us.debian.org/debian/ jessie-updates main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free

deb http://www.deb-multimedia.org jessie main non-free

deb http://extra.linuxmint.com betsy main

Screenshots
https://dl.dropboxusercontent.com/u/218 ... 9%3A51.png

https://dl.dropboxusercontent.com/u/218 ... 2%3A55.png

https://dl.dropboxusercontent.com/u/218 ... 8%3A15.png

Good Luck!

Edit: Removed some old irrelevant info and updated the screenshots.

Edit: Note that the jessie repos I used are for the U.S. If you live somewhere else then change it to a mirror in your local area. Here's a nifty source list generator I found that can help. http://debgen.simplylinux.ch/
Last edited by reference2myself on Tue Mar 17, 2015 10:13 am, edited 3 times in total.

User avatar
sdibaja
Level 5
Level 5
Posts: 694
Joined: Sun May 08, 2011 12:57 pm
Location: Baja California, Mexico

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by sdibaja » Mon Nov 24, 2014 12:53 pm

Interesting.

I think the vast majority of us that use LMDE are looking for Stable (Stable = very low chance that things will break)
Your procedure and methods could work very well, but Definitely eliminates the Stability...
It would be fun to try that on an experimental machine, but ...

I recommend that you all wait a bit and use the soon to be released updates, newer ain't better.
Peter
Mate desktop https://mate-desktop.org/
Debian GNU/Linux operating system: https://cdimage.debian.org/images/unoff ... -firmware/

User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself » Mon Nov 24, 2014 1:12 pm

sdibaja wrote:Interesting.

I think the vast majority of us that use LMDE are looking for Stable (Stable = very low chance that things will break)
Your procedure and methods could work very well, but Definitely eliminates the Stability...
It would be fun to try that on an experimental machine, but ...

I recommend that you all wait a bit and use the soon to be released updates, newer ain't better.
I pointed out the only trouble I found but yeah there's the risk you'll run into something else. LMDE used to be based on testing and many lmde users still use the debian testing and unstable repos, so there's users who are used to risky updates. I just posted it for anyone who's as impatient as me. If you're scared of updates and don't know how to fix stuff then ignore this thread. However if you're not scared of updates and want LMDE 2 with Cinnamon 2.4 NOW then...

User avatar
sdibaja
Level 5
Level 5
Posts: 694
Joined: Sun May 08, 2011 12:57 pm
Location: Baja California, Mexico

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by sdibaja » Mon Nov 24, 2014 1:56 pm

OK, I tried adding your repos on an experimental LMDE (fairly fresh, fully updated, only a few things added from the default Mint repos)
What did you do before you added those repos?

I must have missed a few steps. not a functional/stable result. I lost printer, scanner, desktop settings, half the menu icons are dead... but FF and Wifi still work!

User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself » Mon Nov 24, 2014 2:58 pm

sdibaja wrote:OK, I tried adding your repos on an experimental LMDE (fairly fresh, fully updated, only a few things added from the default Mint repos)
What did you do before you added those repos?

I must have missed a few steps. not a functional/stable result. I lost printer, scanner, desktop settings, half the menu icons are dead... but FF and Wifi still work!
Hmm, did you just add them to /etc/apt/sources.list? or did you replace the ones in /etc/apt/sources.list.d/official-package-repositories.list? i did the latter. If you just added them to /etc/apt/sources.list you probably have to go into /etc/apt/preferences.d/official-package-repositories.pref and change the pin priority for the mint repos from 700 to 500 so updates aren't held back by the older mint repos. Also you have to do a full dist-upgrade, sudo apt-get dist-upgrade, or just go into synaptic and click "Mark All Upgrades", err well you could if you added that button back into synaptic like I did because mint removes it for some reason.

Morlok8k
Level 1
Level 1
Posts: 7
Joined: Wed Feb 27, 2013 6:46 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by Morlok8k » Sat Nov 29, 2014 4:00 am

So i decided to try this on a VM first.

I installed a 32-bit LMDE (UP8), and upgraded everything to the latest versions.

then i took your instructions, and upgraded.

after resolving broken packages (xchat & mint-meta-cinnamon-debian) and whatnot, i was finally able to log into cinnamon.

but it looks the same.


according to /etc/linuxmint/info i'm still on release 1, and it doesnt say LMDE 2 like your screenshot.
I am running cinnamon 2.4.3 though.

i also have a weird white circle glitch when i put my cursor over the Menu area.

see the attached screenshot:
lmde2.png

User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself » Sun Nov 30, 2014 5:33 pm

Morlok8k wrote:So i decided to try this on a VM first.

I installed a 32-bit LMDE (UP8), and upgraded everything to the latest versions.

then i took your instructions, and upgraded.

after resolving broken packages (xchat & mint-meta-cinnamon-debian) and whatnot, i was finally able to log into cinnamon.

but it looks the same.


according to /etc/linuxmint/info i'm still on release 1, and it doesnt say LMDE 2 like your screenshot.
I am running cinnamon 2.4.3 though.

i also have a weird white circle glitch when i put my cursor over the Menu area.

see the attached screenshot:
lmde2.png
Yeah i edited that file to make it say release 2, it hasn't been updated by the mint team yet (edit: this isn't necessary anymore, was updated a while back). I don't know what's up with that white circle glitch though. I don't use the mint menu so I don't know if it happens for me or not, I use configurable menu. I'd say try a different theme or a different menu from the applets and see if that fixes it. Might just be a weird glitch in virtualbox.
Last edited by reference2myself on Fri Mar 06, 2015 11:11 am, edited 1 time in total.

JosephM
Level 6
Level 6
Posts: 1121
Joined: Sun May 26, 2013 6:25 pm

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by JosephM » Mon Dec 01, 2014 3:54 am

The white circle glitch on the menu is an issue do to debian testing having gtk3.14. For anyone looking to try to use LMDE2 like this with Cinnamon 2.4 be aware that there are several issues caused by the newer gtk3.14 in Cinnamon and with the Mint-X themes. Some of them pretty severe. You should be able to fix the issue with the menu by pointing it to use an icon from the gnome icon theme instead of the stock icon.
When I give opinions, they are my own. Not necessarily those of any other Linux Mint developer or the Linux Mint project as a whole.

Morlok8k
Level 1
Level 1
Posts: 7
Joined: Wed Feb 27, 2013 6:46 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by Morlok8k » Mon Dec 01, 2014 5:09 am

well then... I guess there is no point in updating my main boxes just yet then.

ohell
Level 1
Level 1
Posts: 11
Joined: Sun Sep 07, 2014 12:38 pm

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by ohell » Mon Dec 01, 2014 10:21 am

Thanks! I followed your instructions, and everything updated fine, didn't even need to fix the install or index.themes.

Has been running well, since Friday. My main reason for updating was that I wanted clang 3.4+, which I now have. I was hoping that cinnamon 2.4 would automatically detect HiDPI monitors, but that does not appear to be happening.

Anyways, since I have the updated clang, and everything else appears to be working OK, I am now not going to update anything until official LMDE2 rolls out. Hoping I will find a way to specify monitor DPI manually via xrandr, or in a window manager start-up script :)

mtwebster
Level 1
Level 1
Posts: 13
Joined: Sun Jun 17, 2012 1:29 pm

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by mtwebster » Mon Dec 01, 2014 4:13 pm

Cinnamon does *try* to autodetect hidpi monitors, however it's fairly error-prone, which is why we let you override that in settings. Unfortunately monitors don't come with a "I AM HI-DPI" flag that can just be detected - various methods of figuring out what your true DPI is take place, taking into account vendor-supplied info, screen size, etc... the problem with all of this is that manufacturers do a very poor job of filling all of this information and ensuring that it's correct - garbage in/garbage out is the usual result.

User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself » Mon Dec 01, 2014 11:37 pm

JosephM wrote:The white circle glitch on the menu is an issue do to debian testing having gtk3.14. For anyone looking to try to use LMDE2 like this with Cinnamon 2.4 be aware that there are several issues caused by the newer gtk3.14 in Cinnamon and with the Mint-X themes. Some of them pretty severe. You should be able to fix the issue with the menu by pointing it to use an icon from the gnome icon theme instead of the stock icon.
I'm not using the mint-x theme anymore but I didn't encounter any problems when I was. I haven't seen any gtk3.14 problems yet either besides those other themes needing to be edited that i already mentioned. Cinnamon is more stable for me. I did have lots of problems a week or two ago before the most recent cinnamon updates. I started this post because it finally seemed stable and usable to me now and just wanted to get the word out to those as eager. I use a different menu applet and also point it to a custom icon so maybe that's why i never saw the white icon bug, I don't remember seeing it when I updated a stock VM first either though, hmm. I currently have no problems, I fixed the few small ones I came across. I probably just haven't messed with enough stuff to find them yet.
Last edited by reference2myself on Mon Dec 01, 2014 11:55 pm, edited 1 time in total.

User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself » Mon Dec 01, 2014 11:48 pm

ohell wrote:Thanks! I followed your instructions, and everything updated fine, didn't even need to fix the install or index.themes.

Has been running well, since Friday. My main reason for updating was that I wanted clang 3.4+, which I now have. I was hoping that cinnamon 2.4 would automatically detect HiDPI monitors, but that does not appear to be happening.

Anyways, since I have the updated clang, and everything else appears to be working OK, I am now not going to update anything until official LMDE2 rolls out. Hoping I will find a way to specify monitor DPI manually via xrandr, or in a window manager start-up script :)
You can change the DPI under Settings/General/Desktop Scalling, you can change it from auto to normal to double, nothing inbetween though :/ I just discovered that's also where you can set it to disable compositing for full-screen apps. That should speed up games a little, sweet.

User avatar
sdibaja
Level 5
Level 5
Posts: 694
Joined: Sun May 08, 2011 12:57 pm
Location: Baja California, Mexico

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by sdibaja » Tue Dec 02, 2014 12:17 am

reference2myself wrote:
sdibaja wrote:OK, I tried adding your repos on an experimental LMDE (fairly fresh, fully updated, only a few things added from the default Mint repos)
What did you do before you added those repos?

I must have missed a few steps. not a functional/stable result. I lost printer, scanner, desktop settings, half the menu icons are dead... but FF and Wifi still work!
Hmm, did you just add them to /etc/apt/sources.list? or did you replace the ones in /etc/apt/sources.list.d/official-package-repositories.list? i did the latter. If you just added them to /etc/apt/sources.list you probably have to go into /etc/apt/preferences.d/official-package-repositories.pref and change the pin priority for the mint repos from 700 to 500 so updates aren't held back by the older mint repos. Also you have to do a full dist-upgrade, sudo apt-get dist-upgrade, or just go into synaptic and click "Mark All Upgrades", err well you could if you added that button back into synaptic like I did because mint removes it for some reason.
Yes, I saw that omission, I replaced
Peter
Mate desktop https://mate-desktop.org/
Debian GNU/Linux operating system: https://cdimage.debian.org/images/unoff ... -firmware/

ohell
Level 1
Level 1
Posts: 11
Joined: Sun Sep 07, 2014 12:38 pm

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by ohell » Tue Dec 02, 2014 11:29 am

mtwebster wrote:Cinnamon does *try* to autodetect hidpi monitors, however it's fairly error-prone, which is why we let you override that in settings. Unfortunately monitors don't come with a "I AM HI-DPI" flag that can just be detected - various methods of figuring out what your true DPI is take place, taking into account vendor-supplied info, screen size, etc... the problem with all of this is that manufacturers do a very poor job of filling all of this information and ensuring that it's correct - garbage in/garbage out is the usual result.
Sure, but double scaling looks horrible (too large, and UI scales but not the text in many apps, like Firefox), while auto does not do anything.
I wish there was an advanced option to specify the monitor DPI manually for each detected monitor. Maybe sometime in the future.

User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself » Tue Dec 02, 2014 11:52 am

ohell wrote:
mtwebster wrote:Cinnamon does *try* to autodetect hidpi monitors, however it's fairly error-prone, which is why we let you override that in settings. Unfortunately monitors don't come with a "I AM HI-DPI" flag that can just be detected - various methods of figuring out what your true DPI is take place, taking into account vendor-supplied info, screen size, etc... the problem with all of this is that manufacturers do a very poor job of filling all of this information and ensuring that it's correct - garbage in/garbage out is the usual result.
Sure, but double scaling looks horrible (too large, and UI scales but not the text in many apps, like Firefox), while auto does not do anything.
I wish there was an advanced option to specify the monitor DPI manually for each detected monitor. Maybe sometime in the future.
Yeah that would be nice. I wonder if there's a file u can edit to manually specify.

boban
Level 1
Level 1
Posts: 6
Joined: Thu Sep 18, 2014 6:20 am
Location: India

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by boban » Sun Dec 07, 2014 8:06 am

Will cinnamon 2.4 get backported for LMDE 1?

User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself » Tue Dec 30, 2014 9:09 pm

boban wrote:Will cinnamon 2.4 get backported for LMDE 1?
I don't think so...

Monsta
Level 10
Level 10
Posts: 3029
Joined: Fri Aug 19, 2011 3:46 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by Monsta » Mon Jan 05, 2015 6:48 pm

boban wrote:Will cinnamon 2.4 get backported for LMDE 1?
Cinnamon >= 2.2 needs GTK+3 >= 3.10, so the answer is surely no.

User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself » Wed Jan 14, 2015 9:58 pm

Got lots of cinnamon updates today. Idk what's changed though because I haven't experienced any problems since the few i fixed with the initial upgrade.

Locked

Return to “LMDE 1 Archive”