Clem, please tell me how to enable keyboard shortcut

Archived topics about LMDE 1
Forum rules
vistad
Level 4
Level 4
Posts: 200
Joined: Tue Feb 08, 2011 9:17 am

Clem, please tell me how to enable keyboard shortcut

Postby vistad » Tue Jul 03, 2012 2:30 am

I am on LMDE 201204-32-MATE-DVD and I'm happy with it, but there is one thing missings. Please, tell me:

How to enable keyboard shortcuts to select the whole word with Ctrl+Shift+Right/Left?

I need it badly!!! It was present in Limux Mint Gnome editions. It would also be very desirable if you could tell me how to enable the keyboard shortcuts to select the whole paragraph with Ctrl+Shift+Up/Down.

Thank you in advance!
LM18-64 Mate, i7-6770K fanless Thermalright HR22, Asus Maximus VIII Gene, 32Gb RAM, 480Gb PCIe M.2 Kingston Hyper X Predator, 25Gb ext4 /, 1GB swap, the rest is ext4 /home, Vbox Win8.1-64

User avatar
xenopeek
Level 23
Level 23
Posts: 19377
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Clem, please tell me how to enable keyboard shortcut

Postby xenopeek » Tue Jul 03, 2012 9:07 am

I think that is an application specific keyboard shortcut? Which applications are you using where you want this to work?

Probably Clem won't answer BTW, he's busy developing :wink:
Image

vistad
Level 4
Level 4
Posts: 200
Joined: Tue Feb 08, 2011 9:17 am

Re: Clem, please tell me how to enable keyboard shortcut

Postby vistad » Fri Aug 17, 2012 4:54 pm

I want it to work in any application where I may have to edit text - like Pluma, text editors, may be even terminal.
LM18-64 Mate, i7-6770K fanless Thermalright HR22, Asus Maximus VIII Gene, 32Gb RAM, 480Gb PCIe M.2 Kingston Hyper X Predator, 25Gb ext4 /, 1GB swap, the rest is ext4 /home, Vbox Win8.1-64

User avatar
xenopeek
Level 23
Level 23
Posts: 19377
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Clem, please tell me how to enable keyboard shortcut

Postby xenopeek » Sat Aug 18, 2012 1:58 am

Well, Ctrl+Shift+Left/Right works just fine on Pluma here. Have you perhaps installed Linux Mint on a virtual machine, where the virtual machine software may perhaps not be passing through all keyboard commands?
Image

vistad
Level 4
Level 4
Posts: 200
Joined: Tue Feb 08, 2011 9:17 am

Re: Clem, please tell me how to enable keyboard shortcut

Postby vistad » Sat Aug 18, 2012 3:45 am

No, it's not in virtual machine. I have installed LMDE on hardware as my main operating system and I use it as such. Ctrl+Shift+Left/Right makes the cursor jump over 1 word, but it should jump over a word AND SELECT it! The whole problem is that it does not select it. This is a bug! Here is how it should be:

Shift+Left/Right - select one character
Ctrl+Left/Right - jump over one word
Ctrl+Shift+Left/Right - jump over one word and select it
LM18-64 Mate, i7-6770K fanless Thermalright HR22, Asus Maximus VIII Gene, 32Gb RAM, 480Gb PCIe M.2 Kingston Hyper X Predator, 25Gb ext4 /, 1GB swap, the rest is ext4 /home, Vbox Win8.1-64

User avatar
xircon
Level 5
Level 5
Posts: 771
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Clem, please tell me how to enable keyboard shortcut

Postby xircon » Sat Aug 18, 2012 7:11 am

Must be a Mate problem. Works in Cinnamon (though I never knew it existed!).
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

User avatar
xenopeek
Level 23
Level 23
Posts: 19377
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Clem, please tell me how to enable keyboard shortcut

Postby xenopeek » Sat Aug 18, 2012 8:14 am

xircon wrote:Must be a Mate problem. Works in Cinnamon (though I never knew it existed!).

It's not, now is it :) I already commented it works fine just two comments up. Both on Linux Mint 13 MATE and on LMDE MATE, Pluma is happy to Ctrl+Shift+Left/Right select a whole word.

If you aren't on a virtual machine, perhaps you have installed something else that captures key presses? I don't know, like Compiz or Docky or something. Or possibly you have set a global keyboard shortcut. Check in Keyboard Shortcuts application that none of the shortcuts are set to Ctrl+Shift+Left/Right.

To rule out this being caused by such as I suggest, boot from the LMDE installation DVD/USB. Try Pluma from there. Type some words and try to Ctrl+Shift+Left/Right select them. If you can, this means something you installed or configured on your LMDE installation is causing a conflict. If it also doesn't work from the LMDE installation DVD/USB, I'd suspect a hardware failure in your keyboard.
Image


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 6 guests