disappearing gnome-panel on LMDE/32

Archived topics about LMDE 1
Forum rules
User avatar
Habitual
Level 13
Level 13
Posts: 4866
Joined: Sun Nov 21, 2010 8:31 pm

disappearing gnome-panel on LMDE/32

Postby Habitual » Mon Jan 17, 2011 1:56 pm

LMDE/32.

I had Skype 2.1.0.81-1 installed from the REPO(s), however since uninstalling it this issue is no longer present.
Here's the symptoms.

When installed and running, If I choose to "close" (to system tray) it crashes my gnome-panel and I am forced to restart metacity with a desktop launcher for "metacity --replace." That restores it.
Any Item (Except my added Logout and Shutdown applets) that I choose to close with the X bombs the panel.
Installing the same version as a download from Skype now exhibits this behavior also... God, I love/hate my Job!

Here's the .xsession-errors file dump before I uninstalled Skype.

Code: Select all

/etc/gdm3/Xsession: Beginning session setup...
GNOME_KEYRING_CONTROL=/tmp/keyring-KFDddS
GNOME_KEYRING_CONTROL=/tmp/keyring-KFDddS
SSH_AUTH_SOCK=/tmp/keyring-KFDddS/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-KFDddS
SSH_AUTH_SOCK=/tmp/keyring-KFDddS/ssh

** (gnome-settings-daemon:2620): WARNING **: Invalid value for /desktop/gnome/font_rendering/rgba_order: 'rgba'
Window manager warning: Failed to read saved session file /home/jj2/.config/metacity/sessions/104dd200398a8d311e129528609134188300000025720031.ms: Failed to open file '/home/jj2/.config/metacity/sessions/104dd200398a8d311e129528609134188300000025720031.ms': No such file or directory

** (gnome-settings-daemon:2620): WARNING **: Grab failed for some keys, another application may already have access the them.
x-session-manager[2572]: WARNING: Could not launch application 'docky.desktop': Unable to start application: Failed to execute child process "docky" (No such file or directory)
/usr/lib/python2.6/dist-packages/Crypto/Util/randpool.py:40: RandomPool_DeprecationWarning: This application uses RandomPool, which is BROKEN in older releases.  See http://www.pycrypto.org/randpool-broken
  RandomPool_DeprecationWarning)
Initializing nautilus-open-terminal extension
Initializing nautilus-gdu extension

(polkit-gnome-authentication-agent-1:2668): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:2668): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed


Any ideas?

Thank you for your time.

Update: Firing up seahorse and right mouse clicking "Passwords: login" and "Set as Default" seems to have corrected this issue.
I got the clue from "** (gnome-settings-daemon:2620): WARNING **: Grab failed for some keys, another application may already have access the them."
the them? Really? :?

Comments and suggestions welcomed!

Thanks!

Update: Not solved by "Set as Default" in seahorse.
I am using another "theme" however under Control Center > Appearance and it seems ok, for now.

Stand by for an update.
Thanks for listening.
Image
rkhunter 1.4.3 Tutorial
“The single biggest problem in communication is the illusion that it has taken place.”

User avatar
seeley
Level 7
Level 7
Posts: 1869
Joined: Sun Mar 07, 2010 7:20 am

Re: disappearing gnome-panel on LMDE/32

Postby seeley » Sun Jan 23, 2011 6:59 am

HI!
One of the first things I do is adding TERMINAL to desktop, because my lower panel disappeared several times on different distributions. So I could run on GNOME Desktop, of course:

Code: Select all

killall gnome-panel

After
... delete?...
I agreed and it worked again.
Once I had to "Add to panel" one of the other menus.
seeley
seeley @ Linux multiboot


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests