Getting Windows games Lineage 2 and w.o.t. to run

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
xristianna
Level 1
Level 1
Posts: 1
Joined: Fri Apr 24, 2020 10:50 am

Getting Windows games Lineage 2 and w.o.t. to run

Post by xristianna »

I'm two weeks user of Linux mint 19 Tricia.
My beloved games are linage2 and w.o.t.
I think I tried everything that I found on the internet (official game sites , youtube).
I tried virtual box and play on Linux and Lutris and and and...!!!
Nothing much from the directions with that I am seeing to my monitor...
I'm very confused and :evil: :evil: :evil: :evil: so i register here...!!!
I have 4 PC in my family.
I need 2400 euro to upgrade to windows 10(licence and new machines).
Any help..!!!
Thank you in advance...!!!

Code: Select all

System:
  Host: christianna-desktop Kernel: 5.3.0-46-generic x86_64 bits: 64 
  compiler: gcc v: 7.5.0 Desktop: Cinnamon 4.4.8 wm: muffin 4.4.2 
  dm: LightDM 1.26.0 Distro: Linux Mint 19.3 Tricia 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Desktop Mobo: Gigabyte model: 8I945PL-G serial: <filter> BIOS: Award 
  v: F7 date: 03/31/2006 
CPU:
  Topology: Dual Core model: Intel Pentium D bits: 64 type: MCP 
  arch: Netburst Presler rev: 5 L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 bogomips: 12861 
  Speed: 2400 MHz min/max: 2400/3200 MHz Core speeds (MHz): 1: 2400 2: 3200 
Graphics:
  Device-1: NVIDIA GK208B [GeForce GT 710] vendor: Micro-Star MSI 
  driver: nvidia v: 435.21 bus ID: 01:00.0 chip ID: 10de:128b 
  Display: x11 server: X.Org 1.20.5 driver: nvidia 
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 1680x1050~60Hz 
  OpenGL: renderer: GeForce GT 710/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 
  direct render: Yes 
Audio:
  Device-1: Intel NM10/ICH7 Family High Definition Audio 
  vendor: Gigabyte GA-8I945PG-RH Mainboard driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:27d8 
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0e0f 
  Sound Server: ALSA v: k5.3.0-46-generic 
Network:
  Device-1: Broadcom and subsidiaries NetLink BCM5789 Gigabit Ethernet PCI 
  Express 
  vendor: Gigabyte driver: tg3 v: 3.137 port: 8000 bus ID: 03:00.0 
  chip ID: 14e4:169d 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 232.89 GiB used: 134.91 GiB (57.9%) 
  ID-1: /dev/sda vendor: Western Digital model: WD2500AAKX-08ERMA0 
  size: 232.89 GiB speed: <unknown> rotation: 7200 rpm serial: <filter> 
  rev: 1H19 scheme: MBR 
RAID:
  Hardware-1: Integrated Express IT8212 Dual channel ATA RAID controller 
  driver: pata_it821x v: 0.4.2 port: a400 bus ID: 04:06.0 chip ID: 1283.8212 
  rev: 13 
Partition:
  ID-1: / size: 226.58 GiB used: 67.37 GiB (29.7%) fs: ext4 dev: /dev/dm-1 
  ID-2: /boot size: 703.5 MiB used: 165.0 MiB (23.5%) fs: ext4 
  dev: /dev/sda1 
  ID-3: swap-1 size: 979.5 MiB used: 16.0 MiB (1.6%) fs: swap dev: /dev/dm-3 
Sensors:
  Message: No sensors data was found. Is sensors configured? 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/lutris-team-lutris-bionic.list 
  1: deb http://ppa.launchpad.net/lutris-team/lutris/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com tricia main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
  Active apt repos in: /etc/apt/sources.list.d/oguzhaninan-stacer-bionic.list 
  1: deb http://ppa.launchpad.net/oguzhaninan/stacer/ubuntu bionic main
Info:
  Processes: 204 Uptime: 1h 10m Memory: 3.17 GiB used: 1.60 GiB (50.4%) 
  Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.5.0 alt: 7 Shell: bash 
  v: 4.4.20 running in: gnome-terminal inxi: 3.0.32
User avatar
xenopeek
Level 25
Level 25
Posts: 25463
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: WINDOWS GAMES

Post by xenopeek »

I don't know what "w.o.t." means but Lineage 2 looks like it should work somewhat in Wine: https://appdb.winehq.org/objectManager. ... n&iId=2273. Whether you use Wine or Lutris, it's always going to be a bit involved and hit or miss. Your Wine version, the game's version, your graphics card, what additional Windows libraries need to be installed—all that can play into what you need to do to get it to run and how well it will run. It sounds like you've already tried a lot but I hope somebody can offer help with Lineage 2.

Not talking about Lineage 2 specifically but in general: Linux Mint isn't a gratis version of Windows. You're changing to a different operating system and that may mean making some compromises. Some Windows programs or Windows games you just won't be able to get running on Linux.

There are at least 10,000 Linux & Windows games on Steam alone that you can play on Linux (no setup needed: Steam handles everything to make compatible Windows games run). Maybe there are alternatives to the games you mentioned that you could enjoy?
Image
rujikin
Level 2
Level 2
Posts: 53
Joined: Fri Aug 21, 2015 11:19 pm

Re: Getting Windows games Lineage 2 and w.o.t. to run

Post by rujikin »

I got WOT to run but I had to run the nvidia proprietary drivers and install the newest one via the graphics ppa. I stopped playing because war thunder is so much better but yeah..

If your graphics card doesn't support vulkan you might not be able to run it.

I cant remember how I got it installed because I did it so many ways but it has to use dxvk to work right (direct x -> vulkan). I might have used Lutris last and it worked out.
OS: Linux Mint Cinnamon
xerxes
Level 1
Level 1
Posts: 1
Joined: Wed May 12, 2021 7:13 pm

Re: Getting Windows games Lineage 2 and w.o.t. to run

Post by xerxes »

i was searching google in order to find some info about using vulkan render on Lineage 2
and landed over here

i play lineage 2 player since C1

im currently Fedora user

got Lineage 2 scions of destiny running with playonlinux very smooth tho
there are some guides for how to
a shame i didnt arrive here early i see post is from 2020
but well if you read this do not hestiate in asking me anything you need for

laters!
Post Reply