[Solved] Steam not launching after upgrading Mint from 20.3 to 21

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
amstafa123
Level 1
Level 1
Posts: 3
Joined: Wed Sep 22, 2021 10:29 am

[Solved] Steam not launching after upgrading Mint from 20.3 to 21

Post by amstafa123 »

I have upgraded my Linux Mint 20.3 (Cinnamon) installation to 21 recently via mintupgrade and everything went smoothly aside from the fact that I am no longer able to launch Steam. The following error pops up:
"Could not load module 'vgui2_s.so'"
"For more information visit https://support.steampowered.com/kb_art ... -OZVN-0660"
then it stops. I made sure to check that the file exists and it does.
Launching it via terminal gives the following output:

Code: Select all

steam.sh[20118]: Running Steam on linuxmint 21 64-bit
steam.sh[20118]: STEAM_RUNTIME is enabled automatically
setup.sh[20188]: Steam runtime environment up-to-date!
steam.sh[20118]: Steam client's requirements are satisfied
[2022-09-12 15:49:29] Startup - updater built Aug 20 2022 01:16:55
[2022-09-12 15:49:29] Startup - Steam Client launched with: '/home/krystian/.steam/debian-installation/ubuntu12_32/steam' '-nominidumps' '-nobreakpad'
Installing breakpad exception handler for appid(steam)/version(1661825435)
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2022-09-12 15:49:29] Loading cached metrics from disk (/home/krystian/.steam/debian-installation/package/steam_client_metrics.bin)
[2022-09-12 15:49:29] Failed to load cached hosts file (File 'update_hosts_cached.vdf' not found), using defaults
[2022-09-12 15:49:29] Using the following download hosts for Public, Realm steamglobal
[2022-09-12 15:49:29] 1. http://media.steampowered.com, /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
Installing breakpad exception handler for appid(steam)/version(1661825435)
[2022-09-12 15:49:29] Checking for update on startup
[2022-09-12 15:49:29] Checking for available updates...
[2022-09-12 15:49:29] Downloading manifest: http://media.steampowered.com/client/steam_client_ubuntu12
[2022-09-12 15:49:29] Manifest download: send request
Installing breakpad exception handler for appid(steam)/version(1661825435)
[2022-09-12 15:49:29] Manifest download: waiting for download to finish
[2022-09-12 15:49:29] Manifest download: finished
[2022-09-12 15:49:29] Download skipped: /client/steam_client_ubuntu12 version 1661825435, installed version 1661825435, existing pending version 0
[2022-09-12 15:49:29] Nothing to do
[2022-09-12 15:49:29] Verifying installation...
[2022-09-12 15:49:29] Performing checksum verification of executable files
[2022-09-12 15:49:30] Verification complete
Loaded SDL version 2.25.0-7450656
src/steamUI/Main.cpp (3047) : !"Fatal Error: Could not load module 'bin/vgui2_s.dll'"
src/steamUI/Main.cpp (3047) : !"Fatal Error: Could not load module 'bin/vgui2_s.dll'"
Installing breakpad exception handler for appid(steam)/version(1661825435)
assert_20220912154930_6.dmp[20331]: Uploading dump (out-of-process)
/tmp/dumps/assert_20220912154930_6.dmp
[2022-09-12 15:49:30] Shutdown
Installing breakpad exception handler for appid(steam)/version(1661825435)
Installing breakpad exception handler for appid(steam)/version(1661825435)
Purging, then reinstalling Steam did not help. All non-Steam programs, multiple games included, work correctly.
My system information:

Code: Select all

System:
  Kernel: 5.15.0-47-generic x86_64 bits: 64 compiler: gcc v: 11.2.0
    Desktop: Cinnamon 5.4.12 tk: GTK 3.24.33 wm: Mutter vt: 7
    dm: LightDM 1.30.0 Distro: Linux Mint 21 Vanessa base: Ubuntu 22.04 jammy
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX X570-F GAMING v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 3603
    date: 03/20/2021
CPU:
  Info: 16-core model: AMD Ryzen 9 5950X bits: 64 type: MT MCP smt: enabled
    arch: Zen 3 rev: 0 cache: L1: 1024 KiB L2: 8 MiB L3: 64 MiB
  Speed (MHz): avg: 2749 high: 3595 min/max: 2200/5083 boost: enabled
    cores: 1: 2869 2: 2870 3: 2235 4: 2232 5: 2233 6: 2233 7: 2792 8: 2230
    9: 2870 10: 2868 11: 3588 12: 2874 13: 3590 14: 2889 15: 3592 16: 2873
    17: 2523 18: 2234 19: 2230 20: 2227 21: 2231 22: 2234 23: 2794 24: 2232
    25: 2900 26: 2875 27: 3003 28: 3446 29: 3595 30: 2873 31: 2874 32: 2873
    bogomips: 217185
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] vendor: Gigabyte
    driver: amdgpu v: kernel pcie: speed: 16 GT/s lanes: 16 ports:
    active: HDMI-A-1 empty: DP-1,DP-2,HDMI-A-2 bus-ID: 0a:00.0
    chip-ID: 1002:73bf class-ID: 0300
  Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: amdgpu,ati
    unloaded: fbdev,modesetting,radeon,vesa gpu: amdgpu display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: HDMI-A-0 mapped: HDMI-A-1 model: Acer XB253Q serial: <filter>
    res: 1920x1080 dpi: 90 size: 543x302mm (21.4x11.9") diag: 621mm (24.5")
    modes: max: 1920x1080 min: 720x400
  OpenGL: renderer: AMD Radeon RX 6800 XT (sienna_cichlid LLVM 13.0.1 DRM
    3.42 5.15.0-47-generic)
    v: 4.6 Mesa 22.0.5 direct render: Yes
Audio:
  Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT]
    driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
    bus-ID: 0a:00.1 chip-ID: 1002:ab28 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
    bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: C-Media VIRO Plus type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1:2 chip-ID: 3299:4e4e
    class-ID: 0300
  Sound Server-1: ALSA v: k5.15.0-47-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 04:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 4.55 TiB used: 469.57 GiB (10.1%)
  ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P2SSD8 size: 931.51 GiB
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: P2CR033
    temp: 43.9 C scheme: GPT
  ID-2: /dev/sda vendor: Seagate model: ST4000VX007-2DT166 size: 3.64 TiB
    speed: 6.0 Gb/s type: HDD rpm: 5980 serial: <filter> rev: CV11 scheme: GPT
Partition:
  ID-1: / size: 3.58 TiB used: 469.57 GiB (12.8%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 511 MiB used: 5.2 MiB (1.0%) fs: vfat
    dev: /dev/sda1
Swap:
  ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 59.0 C
    mem: 56.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Repos:
  Packages: 3046 apt: 3039 flatpak: 7
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/lutris-team-lutris-jammy.list
    1: deb http://ppa.launchpad.net/lutris-team/lutris/ubuntu jammy main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
    1: deb https://ftp.icm.edu.pl/pub/Linux/dist/linuxmint/packages vanessa main upstream import backport
    2: deb http://ftp.icm.edu.pl/pub/Linux/ubuntu jammy main restricted universe multiverse
    3: deb http://ftp.icm.edu.pl/pub/Linux/ubuntu jammy-updates main restricted universe multiverse
    4: deb http://ftp.icm.edu.pl/pub/Linux/ubuntu jammy-backports main restricted universe multiverse
    5: deb http://security.ubuntu.com/ubuntu/ jammy-security main restricted universe multiverse
Info:
  Processes: 476 Uptime: 1h 13m wakeups: 0 Memory: 31.25 GiB
  used: 3.73 GiB (11.9%) Init: systemd v: 249 runlevel: 5 Compilers:
  gcc: 11.2.0 alt: 11/9 Shell: Bash v: 5.1.16 running-in: gnome-terminal
  inxi: 3.3.13
Last edited by amstafa123 on Sat Sep 24, 2022 8:45 pm, edited 2 times in total.
User avatar
xenopeek
Level 25
Level 25
Posts: 27585
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Steam not launching after upgrading Mint from 20.3 to 21

Post by xenopeek »

On my system that file is at ~/.local/share/Steam/ubuntu12_32/vgui2_s.so

Does the file exist on your system? In your file manager you can view hidden directories like .local by pressing Ctrl+H or toggling through the View menu to show hidden files.

What I would do—but this will remove all the games you have installed from Steam, savegames and Steam client preferences—is to remove the ~/.local/share/Steam and ~/.steam directories. Then when you start Steam it will actually do a reinstall of Steam in your account.
Image
amstafa123
Level 1
Level 1
Posts: 3
Joined: Wed Sep 22, 2021 10:29 am

Re: Steam not launching after upgrading Mint from 20.3 to 21

Post by amstafa123 »

xenopeek wrote:
Wed Sep 14, 2022 5:14 pm
On my system that file is at ~/.local/share/Steam/ubuntu12_32/vgui2_s.so

Does the file exist on your system? In your file manager you can view hidden directories like .local by pressing Ctrl+H or toggling through the View menu to show hidden files.
On my system it is located in

Code: Select all

~/.steam/debian-installation/ubuntu12_32/vgui2_s.so
.

Code: Select all

~/.local/share/Steam
doesn't exist at all, actually.
What I would do—but this will remove all the games you have installed from Steam, savegames and Steam client preferences—is to remove the ~/.local/share/Steam and ~/.steam directories. Then when you start Steam it will actually do a reinstall of Steam in your account.
That's what I have done and it didn't help. The error still appears and terminal output is the same.
amstafa123
Level 1
Level 1
Posts: 3
Joined: Wed Sep 22, 2021 10:29 am

Re: Steam not launching after upgrading Mint from 20.3 to 21

Post by amstafa123 »

Ended up just reinstalling Linux Mint 21 and it works now, even if it's a somewhat disappointing solution.
Post Reply

Return to “Gaming”