Fix for OpenGL issue on Steam

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
sjmur
Level 1
Level 1
Posts: 8
Joined: Mon Sep 09, 2013 11:54 am
Location: Dublin, Ireland

Fix for OpenGL issue on Steam

Post by sjmur » Mon Sep 09, 2013 3:27 pm

Installed Steam?
Installed AMD/Nvidia Drivers?

Getting this error when you load steam on Mint 13/14/15? ''OpenGL GLX context is not using direct rendering, which may cause performance problems.

For more information visit https://support.steampowered.com/kb_art ... -EYZB-7457.''

Well here is an easy fix for now.

1) Open gedit
2) Copy in the following bash script

#!/usr/bin/env bash
export LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu:/usr/lib/i386-linux-gnu/dri:/usr/lib/i386-linux-gnu/fglrx:/usr/lib/i386-linux-gnu:gconv

steam

3) Save as whatevernameyoulike.sh to wherever you like, I leave it on my desktop as I use Steam often.

4) Right click on the file you have just now created. Go to Properties > Permissions and Allow executing file as program. Then close.

5)Simply double click and select 'Run in Terminal'. Steam will then launch normally without the error. Happy Gaming.


Info.
This issue has only been happening recently and my only guess is that it is the Steam client. It failing to point to the folder location for the dependences. It should be fixed in the near future.

/sjmur

User avatar
Booman
Level 4
Level 4
Posts: 485
Joined: Fri Feb 22, 2013 1:54 pm
Contact:

Re: Fix for OpenGL issue on Steam

Post by Booman » Tue Sep 10, 2013 6:57 pm

Cool fix, thanks for the update
Booman
Mint 19 64-bit
PlayOnLinux 4.3.4
PlayOnLinux GuidesTested Games List

Jamesc359
Level 3
Level 3
Posts: 150
Joined: Sun May 06, 2012 1:42 pm

Re: Fix for OpenGL issue on Steam

Post by Jamesc359 » Fri Sep 13, 2013 5:51 am

Code: Select all

export LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu:/usr/lib/i386-linux-gnu/dri:/usr/lib/i386-linux-gnu/fglrx:/usr/lib/i386-linux-gnu:gconv
You can also add this line to the top of /usr/bin/steam. That way it'll work for all of your users and you can launch Steam from your menu.

The line I added was a little different from yours. Perhaps that's because I'm using an Nvidia card?

Code: Select all

export LD_LIBRARY_PATH=/emul/ia32-linux/usr/lib/
“Gosh, you've... really got some nice toys here.”

sjmur
Level 1
Level 1
Posts: 8
Joined: Mon Sep 09, 2013 11:54 am
Location: Dublin, Ireland

Re: Fix for OpenGL issue on Steam

Post by sjmur » Fri Sep 13, 2013 8:41 am

Even better! Thanks!

Ghostbird
Level 1
Level 1
Posts: 8
Joined: Tue Aug 21, 2012 5:22 pm

Re: Fix for OpenGL issue on Steam

Post by Ghostbird » Tue Oct 22, 2013 7:00 am

Sorry for the necromancy, the fix didn't work for me, I manually fixed it another way, it may be valuable to others.
NOTE: The reason why it was broken was probably different for me than for the people who posted above. However, the error we got was the same. If their fix doesn't work, it may be because you share my problem, not theirs.
The cause of the problem for me:

Code: Select all

/usr/lib32/libGL.so -> /usr/lib32/libGL.so.1
/usr/lib32/libGL.so.1 -> /usr/lib32/libGL.so.310.14
For those not in the know, the linked library is from the nVidia 310.14 driver.
But my installed driver is the nVidia 331.10 driver, its libGL is:

Code: Select all

/usr/lib32/nvidia-331/libGL.so.331.10
To fix the problem I did this:
1. Remove the wrong driver version libGL
2. Create a link to the correct driver version libGL
3. Unlink the now broken link from /usr/lib32/libGL.so.1 to the libGL removed in step 1
4. Re-create the link I removed in step 3, it now links to the link created in step 2.

Code: Select all

sudo rm /usr/lib32/libGL.so.310.14
sudo ln -s -T /usr/lib32/nvidia-331/libGL.so.331.13 /usr/lib32/libGL.so.331.13
sudo unlink /usr/lib32/libGL.so.1
sudo ln -s -T /usr/lib32/libGL.so.331.13 /usr/lib32/libGL.so.1
Maybe do this, but I don't think it's necessary:

Code: Select all

sudo ldconfig

passerby
Level 6
Level 6
Posts: 1369
Joined: Sun Dec 16, 2012 7:29 pm

Re: Fix for OpenGL issue on Steam

Post by passerby » Thu Oct 24, 2013 2:04 am

There are a few different causes of this. In my case, none of the solutions anybody recommended worked.
What DID work was swapping to the mainline kernel. The nvidia modules didn't compile properly with Liquorix, it seems.
This also fixed the 32-bit openGL warning I was receiving with playonlinux.

There's also the easy solution of uninstalling the proprietary drivers and falling back to nouveau (in the case of nvidia cards).
It worked, but the performance was lacking.
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots

User avatar
Booman
Level 4
Level 4
Posts: 485
Joined: Fri Feb 22, 2013 1:54 pm
Contact:

Re: Fix for OpenGL issue on Steam

Post by Booman » Fri Oct 25, 2013 5:15 pm

I'm glad someone is at least giving some attention to this.
I havn't had any problems with OpenGL and my Steam games, so I have been ignoring this error.
Booman
Mint 19 64-bit
PlayOnLinux 4.3.4
PlayOnLinux GuidesTested Games List

TazX
Level 1
Level 1
Posts: 11
Joined: Wed Sep 11, 2013 10:26 am

Re: Fix for OpenGL issue on Steam

Post by TazX » Mon Nov 11, 2013 1:37 am

Ghostbird wrote:Sorry for the necromancy, the fix didn't work for me, I manually fixed it another way, it may be valuable to others.
NOTE: The reason why it was broken was probably different for me than for the people who posted above. However, the error we got was the same. If their fix doesn't work, it may be because you share my problem, not theirs.
The cause of the problem for me:

Code: Select all

/usr/lib32/libGL.so -> /usr/lib32/libGL.so.1
/usr/lib32/libGL.so.1 -> /usr/lib32/libGL.so.310.14
For those not in the know, the linked library is from the nVidia 310.14 driver.
But my installed driver is the nVidia 331.10 driver, its libGL is:

Code: Select all

/usr/lib32/nvidia-331/libGL.so.331.10
To fix the problem I did this:
1. Remove the wrong driver version libGL
2. Create a link to the correct driver version libGL
3. Unlink the now broken link from /usr/lib32/libGL.so.1 to the libGL removed in step 1
4. Re-create the link I removed in step 3, it now links to the link created in step 2.

Code: Select all

sudo rm /usr/lib32/libGL.so.310.14
sudo ln -s -T /usr/lib32/nvidia-331/libGL.so.331.13 /usr/lib32/libGL.so.331.13
sudo unlink /usr/lib32/libGL.so.1
sudo ln -s -T /usr/lib32/libGL.so.331.13 /usr/lib32/libGL.so.1
Maybe do this, but I don't think it's necessary:

Code: Select all

sudo ldconfig
Thanks Ghostbird. This worked for me (Though my leftover NVIDIA driver was 325.15).

For those who may have another culprit, type:

Code: Select all

sudo rm /usr/lib32/libGL.so.3
and then
to auto-complete - make sure you don't remove your current driver though.

User avatar
Incurian
Level 1
Level 1
Posts: 13
Joined: Sun Jun 08, 2014 4:44 pm

Re: Fix for OpenGL issue on Steam

Post by Incurian » Wed Jul 02, 2014 1:51 am

None of these solutions worked for me, but deleting the nvidia drivers and installing newer ones did the trick. If you're new like me then you'll need explicit instructions to do that, so I've cobbled them together from various sources below. I'm sure it's also posted elsewhere, but this thread comes up fast when searching for that error message so I think it will be convenient for others to have it here as well.

I'd really appreciate if someone could look it over and identify which steps are uneccesary or sub-optimal, and correct my [guesses] explanations. I originally typed this up for a friend and I think my guesses are good enough for him, but I'd like to edit this in the future to make it more correct.

1) Go to settings - > System Settings - > Driver Manager: enter password
2) Select the nouvea driver.
3) Open a terminal
4)

Code: Select all

sudo apt-get remove --purge nvidia-*
5)

Code: Select all

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates -y
6)

Code: Select all

sudo apt-get update
7)

Code: Select all

sudo add-apt-repository ppa:xorg-edgers/ppa -y
8 )

Code: Select all

sudo apt-get update
9) Click the application launcher (start menu)
10) Go to settings - > System Settings - > Driver Manager: enter password
11) Select a driver, I chose nvidia-337, but I think you should be good with anything from edgers?
12) Restart
Explanation: You removed existing nvidia drivers, added new software sources (edgers) so newer drivers would be available, then installed and selected those drivers.

Following this method I was able to start steam and portal 2 with no issues. Looks fine. I still need to fine tune the settings (I suspect "multicore" might be causing a slight stutter), and maybe try the less bleeding edge drivers to see if they are more stable or better or whatever. But this method worked for me.

If the game is working but it's all black/missing textures:

1) Open terminal
2)

Code: Select all

aptitude install libtxc-dxtn-s2tc0 libtxc-dxtn-s2tc0:i386
3) Restart Steam
Explanation: You installed 32 bit libraries for textures or something. Steam is 32 bit and doesn't play nice with 64 bit stuff.

If you're still getting an error message of some kind:

1) Open terminal
2)

Code: Select all

sudo Xorg :1 -configure
3) The previous command should have created a filed called xorg.conf.new in the home directory. Might be on your desktop. Do a search if you can't find it.
4) Open that file with a text editor (e.g. kate)
5) Find where it says "noveau" and replace it with "nvidia"
6) Copy the file to /etc/X11/ and rename it "xorg.conf"
6a)

Code: Select all

sudo cp ~/xorg.conf.new /etc/X11/xorg.conf
6b) that might not have worked. so we'll do it the GUI way copy the file xorg.conf.new from wherever
6c) open your file manager (e.g. dolphin) and navigate to /etc/X11
6d) right click in the window. Root actions -> open terminal here
6e) paste file and rename it "xorg.conf"
7) Restart
Explanation: You created and altered a configuration file. I'm not 100% sure why is was necessary, but I think it has something to do with repairing driver installations that don't configure correctly.

Those are the things I had to do. Unfortunately, I did them in reverse order, so it's possible that only the first block of instructions were necessary. I think there's probably a 75% chance that the second one was necessary, and a 10% chance the third one was. So do each block in order and test them.

My computer: Fresh Linux Mint 17 KDE 64bit, Intel Core i7-4800MQ, Nvidia Geforce 770M.

references:
http://askubuntu.com/questions/206283/h ... completely
http://www.binarytides.com/install-nvid ... x-mint-16/
https://rohieb.name/blag/post/portal-on ... -textures/
http://www.howtoeverything.net/linux/ha ... linux-mint
-Inc

User avatar
deivan
Level 1
Level 1
Posts: 3
Joined: Wed Jan 07, 2015 3:23 pm
Location: Ukraine

Re: Fix for OpenGL issue on Steam

Post by deivan » Wed Jan 07, 2015 3:28 pm

Incurian wrote: If the game is working but it's all black/missing textures:
1) Open terminal
2)

Code: Select all

aptitude install libtxc-dxtn-s2tc0 libtxc-dxtn-s2tc0:i386
3) Restart Steam
Explanation: You installed 32 bit libraries for textures or something. Steam is 32 bit and doesn't play nice with 64 bit stuff.
My frend, you are my hero!!!
I spend 2 days for solve this problem, i digged out all StackOverflow, but only you really helped me! GREAT THANX!!!
Do you remember FIDO net?.. I was 2:464/1100 :)

User avatar
DrHu
Level 17
Level 17
Posts: 7537
Joined: Wed Jun 17, 2009 8:20 pm

Re: Fix for OpenGL issue on Steam

Post by DrHu » Wed Jan 07, 2015 7:23 pm

Ok, glad you got it solved
--looking up the error msg you had in your initial posting, gets the same answer
http://steamcommunity.com/app/221410/di ... 103549776/
https://support.steampowered.com/kb_art ... -EYZB-7457
  • As Steam is a 32-bit binary it is important to make sure you're running the 32-bit glxinfo when you do this to match how Steam uses OpenGL. If you do not have a 32-bit glxinfo you can install the mesa-utils:i386 package.
--a link within the searched link provided the answer..

Post Reply

Return to “Gaming on Linux Mint”