[SOLVED] Civilization V is black when I open it

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
fletcher
Level 3
Level 3
Posts: 179
Joined: Thu Oct 15, 2009 2:11 pm
Contact:

[SOLVED] Civilization V is black when I open it

Post by fletcher »

I have an AMD Radeon 8330 graphics card, which should, I am told, be able to handle Civilization. However, when I go into a game, the screen is mostly black.

Is it possible that I need to download and/or activate drivers for the graphics card? When I check on proprietary drviers, there is one checked as in use and two video drivers not in use. If I activate those drivers, seems to me like it should help. I hesitate because the one time that I tried, something froze my computer, but not sure if it was trying to activate the driver or something else.

Thanks.
Last edited by fletcher on Sun May 17, 2015 8:54 am, edited 1 time in total.

habahnow
Level 1
Level 1
Posts: 18
Joined: Thu Nov 13, 2014 11:36 pm

Re: Civilization V is black when I open it

Post by habahnow »

hey, i know its been a while since you asked this question but when i had the same issue with the Civilization 5 textures mostly being displayed in black i ran:

Code: Select all

force_s3tc_enable=true steam
if that dont work you can also try:

Code: Select all

sudo apt-get install libtxc-dxtn-s2tc0:i386
fixed things up for me.
found the answer here in the steam community discussion.

fletcher
Level 3
Level 3
Posts: 179
Joined: Thu Oct 15, 2009 2:11 pm
Contact:

Re: Civilization V is black when I open it

Post by fletcher »

Thank you. Will try that.

If that fails, I have also (for various reasons) broken down and decided that I need a Windows partition on my machine.

Post Reply

Return to “Gaming on Linux Mint”