Emulators on Mint?

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
rperreta
Level 1
Level 1
Posts: 7
Joined: Fri Mar 10, 2017 12:29 am

Re: Emulators on Mint?

Postby rperreta » Wed Mar 15, 2017 6:41 pm

Deep_Thought wrote:Does it work if you start it from the gui?
I run Daphne from the Mahcade frontend, so i am also bypassing the Daphneloader gui.
This is the ini i use for Daphne:

Code: Select all

[name] vldp -framefile /home/mame/emulators/laserdisk/[name]/[name].txt -fullscreen -blank_searches -min_seek_delay 1000 -seek_frames_per_ms 20 -homedir ~/emulators/Laserdisk/daphne -fastboot -sound_buffer 2048 -x 1280 -y 1024

This works with all my laserdisk games.
[/code]


Yes it works perfectly fine if I launch mdm and run it from terminal or even daphne loader. It just if I boot to terminal without a GUI I get that crazy video non-sense above ^^^^

-rj

Deep_Thought
Level 1
Level 1
Posts: 13
Joined: Sat Nov 07, 2015 2:56 am

Re: Emulators on Mint?

Postby Deep_Thought » Thu Mar 16, 2017 2:43 am

So it looks like Daphne needs the x-server to run.
Can't help you on that one.
My arcade cab running Linux Mint Xfce: https://goo.gl/photos/yE1KACHryQjCaaCj7
Based on a core 2 duo e8400 (@3.6 Ghz) with Mame, Daphne (the laserdisk emulator) and lots of others.

Aleron Ives
Level 3
Level 3
Posts: 122
Joined: Sun Sep 17, 2017 2:20 am
Location: California
Contact:

Re: Emulators on Mint?

Postby Aleron Ives » Thu Nov 02, 2017 5:41 am

I'm trying to get Kega Fusion to run on Mint 18.2 Cinnamon x64. I installed the .deb file from http://www.carpeludum.com/kega-fusion, but I'm getting this error:

Code: Select all

/usr/lib/kega-fusion/Fusion: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory


I've already added the i386 architecture, and all of these packages are already installed:

BlueKnight wrote:

Code: Select all

sudo apt-get install libasound2:i386 libsm6:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglu1-mesa:i386 libgtk2.0-0:i386


Installing ia32-libs didn't help, either. This page says:

64-bit users, remember that you have to install the lib32 package corresponding to your GPU. It's one of the lib32-*-dri or lib32-*-utils packages.


but I don't know what that means. Any ideas?


Return to “Gaming on Linux Mint”