Emulators on Mint?

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
BlueKnight

Re: Emulators on Mint?

Post by BlueKnight » Sun Nov 15, 2015 7:57 pm

English Invader wrote: Is your laptop screen 1280x800? The 1024x768 is a mistake on my part. 1280x800 is what I had to change to for a full screen picture. I tried 363 on Windows 7 and it came up with a prompt saying I needed to brute force the graphics through the ini file to get the correct output.
I do not have laptop.

You want full screen with no aspect ratio correction? That would get you a distorted image.

English Invader
Level 4
Level 4
Posts: 225
Joined: Thu Apr 23, 2015 11:53 am

Re: Emulators on Mint?

Post by English Invader » Mon Nov 16, 2015 10:22 pm

I wiped the Windows 7 on the laptop and installed Mint. Kega Fusion 363 runs in full screen with a 1280x800 laptop screen but there are black borders on the left and right sides of the screen. Not ideal but still one up on Windows which just gives you a prompt saying it can't run at full screen.

BlueKnight

Re: Emulators on Mint?

Post by BlueKnight » Mon Nov 16, 2015 10:57 pm

English Invader wrote:Not ideal but still one up on Windows which just gives you a prompt saying it can't run at full screen.
I think it is the ideal. If it fills your screen, it will become distorted. If you think a distorted output is the ideal... Well, everyone has its preferences.

Bladeforce
Level 1
Level 1
Posts: 36
Joined: Sat Oct 27, 2012 6:46 pm

Re: Emulators on Mint?

Post by Bladeforce » Fri Jan 01, 2016 7:46 am

Here's a totally personal opinion on emulators i use

Dreamcast: Reicast Emulator works great and WIP https://github.com/reicast/reicast-emulator
3DO: Freedo / 4DO (Wine) / Phoenix3DO (Russian Only)
Amiga: FS-UAE / WinUAE (Wine)
Atari 800: atari800 / Altirra (Wine)
PSX: ePSXe / PCSX / mednafen
PS2: PCSX2
Gamecube / Wii: Dolphin
N64: mupen64plus / Project64 (Wine) / retroarch
SNES: snes9x / bsnes / zsnes / mednafen / retroarch
Spectrum: FBZX / Fuse
C64: Vice / Micro64 / WinVICE (Wine)
Megadrive (Genesis) / SegaCD / 32X: Fusion / Gens / mednafen / retroarch
GBA: mGBA / mednafen
PC Engine / TG16: Mednafen
MSX: openMSX / mess
BBC: BeebEM / Mess / B-Em
Mac OS 7-9 : Sheepshaver
PSP: PPSSPP
Saturn: yabause
NES: puNES / nestopia / mess
Atari2600 : Stella / mess
Atari7800: Mess / Prosystem (Wine)
DOS: Dosbox
Philips CD-i: cdi-emu (Wine)
Atari Jaguar: virtualjaguar
AmstradCPC: Arnold / Mess
VirtualBoy: mednafen
Gameboy / Colour: mednafen / retroarch
Archimedes: rpcemu / arcem
NintendoDS: desmume


There's many more but these i have succesfully got running on LM17.2KDE

Dukenukemx
Level 3
Level 3
Posts: 154
Joined: Thu Nov 24, 2011 1:06 am

Re: Emulators on Mint?

Post by Dukenukemx » Wed Jan 27, 2016 3:18 am

Anyone here able to get PCSX2 installed in 17.3?

Bladeforce
Level 1
Level 1
Posts: 36
Joined: Sat Oct 27, 2012 6:46 pm

Re: Emulators on Mint?

Post by Bladeforce » Wed Jan 27, 2016 9:23 pm

i just use this ppa

https://launchpad.net/~gregory-hainaut/ ... ficial.ppa

works fine in LM 17.3 KDE

Dukenukemx
Level 3
Level 3
Posts: 154
Joined: Thu Nov 24, 2011 1:06 am

Re: Emulators on Mint?

Post by Dukenukemx » Sat Jan 30, 2016 12:13 am

Tried that PPA. Doesn't work on a fresh install of Cinnamon Mint 17.3. It will work on a upgraded 17.2 to 17.3

Bladeforce
Level 1
Level 1
Posts: 36
Joined: Sat Oct 27, 2012 6:46 pm

Re: Emulators on Mint?

Post by Bladeforce » Sat Jan 30, 2016 6:09 pm

Email the ppa owner about it so to add support

Dukenukemx
Level 3
Level 3
Posts: 154
Joined: Thu Nov 24, 2011 1:06 am

Re: Emulators on Mint?

Post by Dukenukemx » Wed Feb 03, 2016 12:37 am

PPA owner says it's a Mint issue with SDL2. You can see here for yourself.
gregory wrote:If you have install issue due to bad multiarch, please complain on Mint forum. It would help everyone. Honestly it probably misses a line in the control file. Change is 5 minutes and then distribution need to recompile the package.

First goal is the installation of both SDL2 version (i386 and amd64), once you're done you could try to install PCSX2.

JusTertii
Level 3
Level 3
Posts: 171
Joined: Tue Jul 29, 2014 11:21 pm

Re: Emulators on Mint?

Post by JusTertii » Mon Feb 08, 2016 2:34 am

Has anyone had much experience with Mupen -- particularly, can anyone recommend a decent graphical front-end? M64py doesn't seem to work for me.

Bladeforce
Level 1
Level 1
Posts: 36
Joined: Sat Oct 27, 2012 6:46 pm

Re: Emulators on Mint?

Post by Bladeforce » Mon Feb 08, 2016 8:19 pm

mupen64plus-qt? worth a try..

https://github.com/dh4/mupen64plus-qt

rperreta
Level 1
Level 1
Posts: 7
Joined: Fri Mar 10, 2017 12:29 am

Re: Emulators on Mint?

Post by rperreta » Fri Mar 10, 2017 12:34 am

Deep_Thought wrote:
Michael Piziak wrote:Trying to install Kega Fusion.

I guess I need to install the 32 bit architectures to get it to work. Don't know how to do that - ?

Mame - isn't that to emulate coin operated video games - ?
It shouldn't be necessary to install 32 bit libs, i switched from 64 bit Lubuntu to 64 bit Mint Xfce on my multi emulator cab because of that.
On Lubuntu it was increasingly dificult to get Daphne, the laserdisk emulator running, it needed 32 bit libs.
On Mint Xfce it runs out of the box, even on 64 bit.
What version of Mint? I tried Maya v13 and Cin v18 - either one works out the box with Daphne. It's absolutely insane that this is that difficult. Daphne guys should package up an installer with all the necessary binaries or whats needed. The lack of documentation is not a great help either... I could use a helping hand... anyone?

thanks
-rj

Deep_Thought
Level 1
Level 1
Posts: 13
Joined: Sat Nov 07, 2015 2:56 am

Re: Emulators on Mint?

Post by Deep_Thought » Fri Mar 10, 2017 2:48 am

Here's a thread on Daphne-Emu forum i am following: https://www.daphne-emu.com:9443/phpBB3/ ... f=5&t=3024
He (Frotz) has compiled a 64 bit executable of Daphne for linux (debian).
It worked for me as well on linux mint 64 bit.
The problem is Daphneloader.bin which is closed source, Frotz is working on a graphical front-end himself.
Here's the repo: https://github.com/DavidGriffith/daphne
Development is slow, but if more people help him we may be getting somewhere.
By the way. My cab is running Linux Mint 17.3 Xfce 64 bit, the 32 bit Daphne and Daphneloader is running fine on this one.
My arcade cab running Linux Mint Xfce: https://goo.gl/photos/yE1KACHryQjCaaCj7
Based on a core 2 duo e8400 (@3.6 Ghz) with Mame, Daphne (the laserdisk emulator) and lots of others.

rperreta
Level 1
Level 1
Posts: 7
Joined: Fri Mar 10, 2017 12:29 am

Re: Emulators on Mint?

Post by rperreta » Fri Mar 10, 2017 1:06 pm

Deep_Thought wrote:Here's a thread on Daphne-Emu forum i am following: https://www.daphne-emu.com:9443/phpBB3/ ... f=5&t=3024
He (Frotz) has compiled a 64 bit executable of Daphne for linux (debian).
It worked for me as well on linux mint 64 bit.
The problem is Daphneloader.bin which is closed source, Frotz is working on a graphical front-end himself.
Here's the repo: https://github.com/DavidGriffith/daphne
Development is slow, but if more people help him we may be getting somewhere.
By the way. My cab is running Linux Mint 17.3 Xfce 64 bit, the 32 bit Daphne and Daphneloader is running fine on this one.

I don't mind doing the mint 17.3 Xfce but what did you have to install to get the dependencies to work properly? I tried so many variations, forums, links, scripts and nothing seems to work?

thanks
-rj

Deep_Thought
Level 1
Level 1
Posts: 13
Joined: Sat Nov 07, 2015 2:56 am

Re: Emulators on Mint?

Post by Deep_Thought » Sat Mar 11, 2017 7:33 am

On linux mint 17.3 Xfce 64 bit Daphne worked out of the box for me, (as far as i recall, it's been a while).
On linux mint 18 it did not. I think installing 32 bit libs did the trick.
I will try again on a fresh install to recall.
My arcade cab running Linux Mint Xfce: https://goo.gl/photos/yE1KACHryQjCaaCj7
Based on a core 2 duo e8400 (@3.6 Ghz) with Mame, Daphne (the laserdisk emulator) and lots of others.

rperreta
Level 1
Level 1
Posts: 7
Joined: Fri Mar 10, 2017 12:29 am

Re: Emulators on Mint?

Post by rperreta » Sat Mar 11, 2017 10:41 am

Deep_Thought wrote:On linux mint 17.3 Xfce 64 bit Daphne worked out of the box for me, (as far as i recall, it's been a while).
On linux mint 18 it did not. I think installing 32 bit libs did the trick.
I will try again on a fresh install to recall.

CORRECT! I did the install and it did work right out of the box... impressive considering every other flavor or linux didn't.... Thank you so much for you help however I still think the dev's at daphne-emu should still include an installer that adds the correct libraries or maybe update to newer ones... All in all it's working and I'm happy... Thanks for your help..

-rj

Deep_Thought
Level 1
Level 1
Posts: 13
Joined: Sat Nov 07, 2015 2:56 am

Re: Emulators on Mint?

Post by Deep_Thought » Sat Mar 11, 2017 10:56 am

I am afraid the Daphne project has been abandoned, and the developer doesn't want to release the source code.
He is working on a hardware board named Dexter to replace Daphne, and that, of course is not free.
So we have to make do with wat we have.
My arcade cab running Linux Mint Xfce: https://goo.gl/photos/yE1KACHryQjCaaCj7
Based on a core 2 duo e8400 (@3.6 Ghz) with Mame, Daphne (the laserdisk emulator) and lots of others.

User avatar
hobbledehoy899
Level 1
Level 1
Posts: 14
Joined: Sun Mar 12, 2017 6:51 am

Re: Emulators on Mint?

Post by hobbledehoy899 » Sun Mar 12, 2017 7:02 am

I'd recommend that you build/install FCEUX from source because the version that's in the repositories is out of date for no good reason.

rperreta
Level 1
Level 1
Posts: 7
Joined: Fri Mar 10, 2017 12:29 am

Re: Emulators on Mint?

Post by rperreta » Sun Mar 12, 2017 10:49 pm

Hello everyone,

So after a few tips and pointers I was able to get daphne working.. yay me! only problem I'm having now is now that I'm avoiding the GUI and launching it from "quiet splash text" I think a video driver or library is not loading. I don't get any errors but the screen is terrible. See images below.

Image

Image

Deep_Thought
Level 1
Level 1
Posts: 13
Joined: Sat Nov 07, 2015 2:56 am

Re: Emulators on Mint?

Post by Deep_Thought » Wed Mar 15, 2017 9:49 am

Does it work if you start it from the gui?
I run Daphne from the Mahcade frontend, so i am also bypassing the Daphneloader gui.
This is the ini i use for Daphne:

Code: Select all

[name] vldp -framefile /home/mame/emulators/laserdisk/[name]/[name].txt -fullscreen -blank_searches -min_seek_delay 1000 -seek_frames_per_ms 20 -homedir ~/emulators/Laserdisk/daphne -fastboot -sound_buffer 2048 -x 1280 -y 1024
This works with all my laserdisk games.

You could check the Daphneloader output for troubleshooting, it should look something like this:

Code: Select all

Daphne Launcher : Script dir is .
--DAPHNE version 1.0.11
--Command line is: ./daphne.bin dle21 vldp -framefile /home/mame/emulators/laserdisk/dle21/dle21.txt -blank_searches -min_seek_delay 1000 -seek_frames_per_ms 20 -homedir /home/mame/.daphne -bank 0 11111000 -bank 1 00110111 -sound_buffer 2048 -fullscreen -x 1280 -y 1024 
--CPU : GenuineIntel 2000 MHz || Mem : 4096 megs
--OS : Linux 3.16 || Video : NVIDIA Corporation G96 [GeForce 9500 GT] (rev a1)
--OpenGL: Compiled In
--RGB2YUV Function: MMX
--Line Blending Function: MMX
--Audio Mixing Function: MMX
Setting alternate home dir:
/home/mame/.daphne
Setting sound buffer size to 2048
Setting screen width to 1280
Setting screen height to 1024
Set 1280x1024 at 32 bpp with flags: 80000000
Initializing sound system ... 
GI Sound chip initialized at 2000000 Hz
WARNING : requested 2048 samples for sound buffer, but got 1024 samples
No joysticks detected
Remapping input ...
Loading compressed ROM image DLE21_U1.bin...8192 bytes read.
Loading compressed ROM image DLE21_U2.bin...8192 bytes read.
Loading compressed ROM image DLE21_U3.bin...8192 bytes read.
Framefile parse succeeded. Video/Audio directory is: /home/mame/emulators/laserdisk/dle21/./
YUV overlay is hardware accelerated.
Booting ROM ...
Play
LDP : disc is already playing, play command ignored
Play
Display disable received
Search to 323 received - [25] Attract Mode, Sequence 0 Attract Mode
search succeeded d0
Play
Display disable received
Search to 300 received - [25] Attract Mode, Sequence 7 Attract Mode
search succeeded d0
Freeing memory used to store audio stream...

My arcade cab running Linux Mint Xfce: https://goo.gl/photos/yE1KACHryQjCaaCj7
Based on a core 2 duo e8400 (@3.6 Ghz) with Mame, Daphne (the laserdisk emulator) and lots of others.

Post Reply

Return to “Gaming on Linux Mint”