Minecraft Error Message!

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
Gaming Fool
Level 1
Level 1
Posts: 5
Joined: Thu Oct 27, 2016 1:48 pm

Minecraft Error Message!

Post by Gaming Fool » Fri Oct 28, 2016 12:01 am

Hello, I'm quite new to Linux and I have a lot to ask! First off I'm trying to download Minecraft on my computer. I love the game and really want to get into playing, but I have an issue. I have the download for Minecraft and I have the launcher, but every time I try to launch the game it gives me an error message!

Here is the error message:

"could not create the virtual java machine"

This isn't the exact code, but it's the main idea of the error message and I'm so confused on what the heck it means or how I can change that. I have looked at many different tutorials and found ways to fix it, but I can't get it to work. If anyone has any feedback please let me know and if needed I can try and post some images of my Terminal. Please remember that this is on Linux, I've gone through too many Windows 10 tutorials!

User avatar
xenopeek
Level 24
Level 24
Posts: 22283
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Minecraft Error Message!

Post by xenopeek » Fri Oct 28, 2016 1:41 am

Please open the terminal from your menu and type this command and press enter: java -version
Paste its output here. You can select & copy text through the terminal's Edit menu.

Which version of Linux Mint are you using? If you don't know, also share the output of the command: inxi -S

The error you've been given is generic. It could be as simple as passing an option for Java with a typo; that would also give you the "could not create the virtual java machine" error.

The steps to run Minecraft on Linux Mint are as easy as:
  • Download Minecraft.jar from the website https://minecraft.net/en/download/
  • Open your file manager and go to the directory where you have downloaded Minecraft.jar. Right-click the file and select Properties from the context menu.
  • Go to the Permissions tab and select "Allow executing file as program".
  • Go to the Open With tab and select OpenJDK Java and click to set that as default, if that wasn't already the case.
  • Close the Properties dialog and double-click Minecraft.jar in your file manager to start it.
If you did anything more than this, that might be the reason you have errors.
Image

Gaming Fool
Level 1
Level 1
Posts: 5
Joined: Thu Oct 27, 2016 1:48 pm

Re: Minecraft Error Message!

Post by Gaming Fool » Sun Oct 30, 2016 11:44 pm

I have done the steps given and here is the code for my java version:

java version "9-ea"
Java(TM) SE Runtime Environment (build 9-ea+140)
Java HotSpot(TM) 64-Bit Server VM (build 9-ea+140, mixed mode)

Here is the version of my computer version: System:

Host: logan-Inspiron-3521 Kernel: 3.19.0-32-generic x86_64 (64 bit)
Desktop: Cinnamon 2.8.8 Distro: Linux Mint 17.3 Rosa

I changed all of the properties and everything, this is what I have now. Now when I open the program it gives me this new error message. My only thought of why it's giving me this is because I may not have the newest up to date JDK program.

Unrecognized VM option 'CMSIncrementalMode'
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

User avatar
xenopeek
Level 24
Level 24
Posts: 22283
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Minecraft Error Message!

Post by xenopeek » Mon Oct 31, 2016 12:13 am

How are you running the program that you are passing it the argument you are getting an error about? You should not need to pass any arguments. Just double-click the Minecraft.jar file.

As for Java, I'm using OpenJDK 8 without problems (package openjdk-8-jre in Software Manager). You I think have Oracle Java 9 installed. I can't help with determining if Oracle Java is the problem.
Image

Gaming Fool
Level 1
Level 1
Posts: 5
Joined: Thu Oct 27, 2016 1:48 pm

Re: Minecraft Error Message!

Post by Gaming Fool » Mon Oct 31, 2016 12:32 am

I do have Oracle 9, is that a big problem. What do I do from here knowing I'm getting this error message?

Gaming Fool
Level 1
Level 1
Posts: 5
Joined: Thu Oct 27, 2016 1:48 pm

Re: Minecraft Error Message!

Post by Gaming Fool » Mon Oct 31, 2016 12:37 am

Okay, when I double-click the icon, launcher, it launches and brings me to the Minecraft launcher. From there I can edit my profile and everything, but when I click play it shortly gives me an error message in the launcher

Gaming Fool
Level 1
Level 1
Posts: 5
Joined: Thu Oct 27, 2016 1:48 pm

Re: Minecraft Error Message!

Post by Gaming Fool » Mon Oct 31, 2016 12:40 am

I think I have a found a key problem. In my launcher, I go to my settings and the Java setting (Advanced) are set to

Executable:

/usr/lib/jvm/java-9-oracle/bin/java

What is yours set to?

uberdorf
Level 4
Level 4
Posts: 225
Joined: Tue Sep 01, 2015 10:15 am

Re: Minecraft Error Message!

Post by uberdorf » Sat Nov 12, 2016 5:18 am

Unless you have a specific reason for needing Java 9, I would strongly recommend removing Java 9 and installing the standard Oracle Java 8. I personally use these instructions for installing Java 8 on linux https://sites.google.com/site/easylinuxtipsproject/java which happens to be written by a member here. Or you could use the webupd8 ppa.

As long as you have java correctly installed and have the launcher marked as an executable when you right-click it, it should open up. I personally use MultiMC as my launcher, because of all the different mods and instances my kids like to play with.

9se
Level 1
Level 1
Posts: 2
Joined: Sun Jan 07, 2018 7:06 am

Re: Minecraft Error Message!

Post by 9se » Sun Jan 07, 2018 7:08 am

I have discovered that for this error you merely need to go into the launcher settings, check executable and set what is there to /usr/lib/jvm/java-8-oracle/bin/java or change the java-9-oracle to an 8. this worked for me but i do not know about you!

Post Reply

Return to “Gaming on Linux Mint”