The Dark Mod

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
User avatar
MintBean
Level 8
Level 8
Posts: 2163
Joined: Fri Aug 07, 2015 6:54 am
Location: Blighty

The Dark Mod

Postby MintBean » Fri Aug 18, 2017 8:45 pm

This is a cracking free game heavily influenced by the old 'Thief' game series. It even won PC Gamer magazine 'game of the year' in 2013. Not bad for something that's free!

http://www.thedarkmod.com/main/

I had to fiddle around to get the sound working. I think this is all you probably need to get it working.

Code: Select all

apt install libasound2-plugins:i386

User avatar
catweazel
Level 10
Level 10
Posts: 3038
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: The Dark Mod

Postby catweazel » Fri Aug 18, 2017 8:58 pm

Code: Select all

boot@Fartblast ~ $ apt install --dry-run libasound2-plugins:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  gcc-5-base:i386 gcc-6-base:i386 libasound2:i386 libasyncns0:i386 libc6:i386 libdbus-1-3:i386 libflac8:i386 libgcc1:i386 libgcrypt20:i386 libgpg-error0:i386
  libjack-jackd2-0:i386 libjson-c2:i386 liblzma5:i386 libogg0:i386 libpcre3:i386 libpulse0:i386 libsamplerate0:i386 libselinux1:i386 libsndfile1:i386
  libspeexdsp1:i386 libstdc++6:i386 libsystemd0:i386 libvorbis0a:i386 libvorbisenc2:i386 libwrap0:i386 libxau6:i386 libxcb1:i386 libxdmcp6:i386
Suggested packages:
  glibc-doc:i386 locales:i386 rng-tools:i386 jackd2:i386
The following NEW packages will be installed:
  gcc-5-base:i386 gcc-6-base:i386 libasound2:i386 libasound2-plugins:i386 libasyncns0:i386 libc6:i386 libdbus-1-3:i386 libflac8:i386 libgcc1:i386
  libgcrypt20:i386 libgpg-error0:i386 libjack-jackd2-0:i386 libjson-c2:i386 liblzma5:i386 libogg0:i386 libpcre3:i386 libpulse0:i386 libsamplerate0:i386
  libselinux1:i386 libsndfile1:i386 libspeexdsp1:i386 libstdc++6:i386 libsystemd0:i386 libvorbis0a:i386 libvorbisenc2:i386 libwrap0:i386 libxau6:i386
  libxcb1:i386 libxdmcp6:i386
0 to upgrade, 29 to newly install, 0 to remove and 1 not to upgrade.
Inst gcc-6-base:i386 (6.0.1-0ubuntu1 Ubuntu:16.04/xenial [i386])
Inst libgcc1:i386 (1:6.0.1-0ubuntu1 Ubuntu:16.04/xenial [i386]) []
Inst libc6:i386 (2.23-0ubuntu9 Ubuntu:16.04/xenial-updates, Ubuntu:16.04/xenial-security [i386])
Inst liblzma5:i386 (5.1.1alpha+20120614-2ubuntu2 Ubuntu:16.04/xenial [i386])
Inst libpcre3:i386 (2:8.38-3.1 Ubuntu:16.04/xenial [i386])
Inst libgpg-error0:i386 (1.21-2ubuntu1 Ubuntu:16.04/xenial [i386])
Inst libgcrypt20:i386 (1.6.5-2ubuntu0.3 Ubuntu:16.04/xenial-updates, Ubuntu:16.04/xenial-security [i386])
Inst libselinux1:i386 (2.4-3build2 Ubuntu:16.04/xenial [i386])
Conf gcc-6-base:i386 (6.0.1-0ubuntu1 Ubuntu:16.04/xenial [i386])
Conf libgcc1:i386 (1:6.0.1-0ubuntu1 Ubuntu:16.04/xenial [i386])
Conf libc6:i386 (2.23-0ubuntu9 Ubuntu:16.04/xenial-updates, Ubuntu:16.04/xenial-security [i386])
Conf libgpg-error0:i386 (1.21-2ubuntu1 Ubuntu:16.04/xenial [i386])
Conf libgcrypt20:i386 (1.6.5-2ubuntu0.3 Ubuntu:16.04/xenial-updates, Ubuntu:16.04/xenial-security [i386])
Conf liblzma5:i386 (5.1.1alpha+20120614-2ubuntu2 Ubuntu:16.04/xenial [i386])
Conf libpcre3:i386 (2:8.38-3.1 Ubuntu:16.04/xenial [i386])
Conf libselinux1:i386 (2.4-3build2 Ubuntu:16.04/xenial [i386])
Inst libsystemd0:i386 (229-4ubuntu19 Ubuntu:16.04/xenial-updates [i386])
Inst libjson-c2:i386 (0.11-4ubuntu2 Ubuntu:16.04/xenial [i386])
Inst libxau6:i386 (1:1.0.8-1 Ubuntu:16.04/xenial [i386])
Inst libasyncns0:i386 (0.8-5build1 Ubuntu:16.04/xenial [i386])
Inst libogg0:i386 (1.3.2-1 Ubuntu:16.04/xenial [i386])
Inst libsamplerate0:i386 (0.1.8-8 Ubuntu:16.04/xenial [i386])
Inst libwrap0:i386 (7.6.q-25 Ubuntu:16.04/xenial [i386])
Inst gcc-5-base:i386 (5.4.0-6ubuntu1~16.04.4 Ubuntu:16.04/xenial-updates, Ubuntu:16.04/xenial-security [i386])
Inst libstdc++6:i386 (5.4.0-6ubuntu1~16.04.4 Ubuntu:16.04/xenial-updates, Ubuntu:16.04/xenial-security [i386])
Inst libdbus-1-3:i386 (1.10.6-1ubuntu3.3 Ubuntu:16.04/xenial-updates [i386])
Inst libxdmcp6:i386 (1:1.1.2-1.1 Ubuntu:16.04/xenial [i386])
Inst libxcb1:i386 (1.11.1-1ubuntu1 Ubuntu:16.04/xenial [i386])
Inst libasound2:i386 (1.1.0-0ubuntu1 Ubuntu:16.04/xenial [i386])
Inst libjack-jackd2-0:i386 (1.9.10+20150825git1ed50c92~dfsg-1ubuntu1 Ubuntu:16.04/xenial [i386])
Inst libflac8:i386 (1.3.1-4 Ubuntu:16.04/xenial [i386])
Inst libvorbis0a:i386 (1.3.5-3 Ubuntu:16.04/xenial [i386])
Inst libvorbisenc2:i386 (1.3.5-3 Ubuntu:16.04/xenial [i386])
Inst libsndfile1:i386 (1.0.25-10ubuntu0.16.04.1 Ubuntu:16.04/xenial-updates, Ubuntu:16.04/xenial-security [i386])
Inst libpulse0:i386 (1:8.0-0ubuntu3.3 Ubuntu:16.04/xenial-updates [i386])
Inst libspeexdsp1:i386 (1.2~rc1.2-1ubuntu1 Ubuntu:16.04/xenial [i386])
Inst libasound2-plugins:i386 (1.1.0-0ubuntu1 Ubuntu:16.04/xenial [i386])
Conf libsystemd0:i386 (229-4ubuntu19 Ubuntu:16.04/xenial-updates [i386])
Conf libjson-c2:i386 (0.11-4ubuntu2 Ubuntu:16.04/xenial [i386])
Conf libxau6:i386 (1:1.0.8-1 Ubuntu:16.04/xenial [i386])
Conf libasyncns0:i386 (0.8-5build1 Ubuntu:16.04/xenial [i386])
Conf libogg0:i386 (1.3.2-1 Ubuntu:16.04/xenial [i386])
Conf libsamplerate0:i386 (0.1.8-8 Ubuntu:16.04/xenial [i386])
Conf libwrap0:i386 (7.6.q-25 Ubuntu:16.04/xenial [i386])
Conf gcc-5-base:i386 (5.4.0-6ubuntu1~16.04.4 Ubuntu:16.04/xenial-updates, Ubuntu:16.04/xenial-security [i386])
Conf libstdc++6:i386 (5.4.0-6ubuntu1~16.04.4 Ubuntu:16.04/xenial-updates, Ubuntu:16.04/xenial-security [i386])
Conf libdbus-1-3:i386 (1.10.6-1ubuntu3.3 Ubuntu:16.04/xenial-updates [i386])
Conf libxdmcp6:i386 (1:1.1.2-1.1 Ubuntu:16.04/xenial [i386])
Conf libxcb1:i386 (1.11.1-1ubuntu1 Ubuntu:16.04/xenial [i386])
Conf libasound2:i386 (1.1.0-0ubuntu1 Ubuntu:16.04/xenial [i386])
Conf libjack-jackd2-0:i386 (1.9.10+20150825git1ed50c92~dfsg-1ubuntu1 Ubuntu:16.04/xenial [i386])
Conf libflac8:i386 (1.3.1-4 Ubuntu:16.04/xenial [i386])
Conf libvorbis0a:i386 (1.3.5-3 Ubuntu:16.04/xenial [i386])
Conf libvorbisenc2:i386 (1.3.5-3 Ubuntu:16.04/xenial [i386])
Conf libsndfile1:i386 (1.0.25-10ubuntu0.16.04.1 Ubuntu:16.04/xenial-updates, Ubuntu:16.04/xenial-security [i386])
Conf libpulse0:i386 (1:8.0-0ubuntu3.3 Ubuntu:16.04/xenial-updates [i386])
Conf libspeexdsp1:i386 (1.2~rc1.2-1ubuntu1 Ubuntu:16.04/xenial [i386])
Conf libasound2-plugins:i386 (1.1.0-0ubuntu1 Ubuntu:16.04/xenial [i386])


uRGH...
Mint Donor #6036
If your problem is fixed, please mark your thread as [SOLVED] by editing the title of the first message in the thread.

User avatar
MintBean
Level 8
Level 8
Posts: 2163
Joined: Fri Aug 07, 2015 6:54 am
Location: Blighty

Re: The Dark Mod

Postby MintBean » Fri Aug 18, 2017 9:03 pm

You pays your money (or not), you takes your choice.

User avatar
catweazel
Level 10
Level 10
Posts: 3038
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: The Dark Mod

Postby catweazel » Fri Aug 18, 2017 9:08 pm

I'll light a pipe and quaff an Irish whiskey instead, thanks :D
Mint Donor #6036
If your problem is fixed, please mark your thread as [SOLVED] by editing the title of the first message in the thread.

User avatar
MintBean
Level 8
Level 8
Posts: 2163
Joined: Fri Aug 07, 2015 6:54 am
Location: Blighty

Re: The Dark Mod

Postby MintBean » Fri Aug 18, 2017 9:43 pm

Sounds most civilised! :wink:

User avatar
kyphi
Level 8
Level 8
Posts: 2109
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: The Dark Mod

Postby kyphi » Fri Aug 18, 2017 11:29 pm

No sound trouble encountered with The Dark Mod, it all worked without a flaw. Great game but stealing goes against the grain with me - I am not devious enough.

You can keep the pipe but I will say "cheers" to the whisky.
Linux Mint 18.2 Cinnamon - 64bit


Return to “Gaming on Linux Mint”

Who is online

Users browsing this forum: No registered users and 2 guests