Where is the gfx.wad file?

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
flatiron
Level 3
Level 3
Posts: 198
Joined: Fri Nov 24, 2017 2:27 am

Where is the gfx.wad file?

Post by flatiron » Mon Nov 27, 2017 1:08 am

I was trying to play quake using quake spasm.

These are the errors I got.

"Playing shareware version.

ERROR-OUT BEGIN


QUAKE ERROR: W_LoadWadFile: couldn't load gfx.wad"

I was using the GOG files while following these instructions

https://steamcommunity.com/sharedfiles/ ... =540913274

I searched my PC and there is no gfx.wad... confused.

flatiron
Level 3
Level 3
Posts: 198
Joined: Fri Nov 24, 2017 2:27 am

Re: Where is the gfx.wad file?

Post by flatiron » Mon Nov 27, 2017 6:09 am

I got it to work! But there is some issue on how to solve the screen size and resolution problem. See the bottom of this post for more info.


I based this off the instructions I found here. https://steamcommunity.com/sharedfiles/ ... =540913274

1) First install PlayOnLinux

2) In PlayOnLinux update to the latest wine. I do not think this really matters, but this is what I did.

3) Install Quake using play on linux. (Buy quake from gog. Download it. Go into POL. Click "Install a Program". Then click "install and non listed program", READ the promts and do what they say.

4) Find the id1, hipnotic, and rogue files (some people call files directories for some bizarre reason. Keep that in mind). Move them either to your home screen or another file.

5) Just change the name of the pak files under the "id1" folder to lower case. The rogue and hypnotic folders should already have lower case names for the pak files.

6) Right click on the home screen. Select "open in terminal" to open a terminal window. Install quakespasm by typing "apt-get install quakespasm" into the terminal window. if that does not work type in "sudo apt-get install quakespasm". Type this in, do not copy and paste it, and do not include the quotation marks. If you had to type in "sudo" to get it to work then you will have to type in your log on password. Beware that there will be no indication of you password being typed in. No cursor movement. No nothing. Just make sure you click on the terminal window before you type it in. And type it right.

7) Right click on the "Id1" file. Select "properties". Now click on the terminal window and type in " quakespasm -basedir" followed by one space and then type in what you see next to "Location" in the properties window, exactly as you see it, even if it doesn't make sense. Do not add anything to it even if you think it makes sense to.

8) Now hit enter and it should run.

DO NOT HAVE ANY SPACES IN THE NAME YOU CHOSE FOR THE FILE TO PUT ALL OF THIS IN OTHERWISE IT WILL NOT RUN!

If there are any questions please let me know.

Questions I have are, how do I get it to play in 1080 full screen? I tried selected 1080 in the video options, but when I tested it my screen went crazy like an old NES game with corrosion on the copper connectors.

And how do I make the mouse faster? It seems slightly slow. It is not a lag issue. Never mind. Found mouse controls. Just need screen size adjust. Everything but 800x600 screws up.


Per the thread here

https://www.gog.com/forum/quake_series/ ... sing/page1

1. Please delete opengl32.dll from C:\GOG Games\Quake.

I just deleted all the quake files I was not using and uninstalled it from from play on linux. Now, when you go to set it to 1080, make sure it is in full screen mode first and it will work.

Now what do I do about lack of music?

Post Reply

Return to “Gaming on Linux Mint”