Civilization 6 on steam : launch problem

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Fri Dec 22, 2017 8:42 am

Civilization 6 on steam : launch problem

Post by r1mk4 » Fri Dec 22, 2017 10:10 am


First, take in mind that I'm a beginner in Linux's world. I promise to do my homework, but please, be patient :roll:

I've installed Linux mint 18.3 Cinnamon on a HP PAVILION POWER -15-cb016nf- Core I5-7300HQ - 4 Go - HDD 1To - GEFORCE GTX 1050 2 Go.

I just installed Civilization 6 Digital Deluxe on steam, the downloading seemed to work great. But, when I try to start it, only a steam window appears (verifying updates, connecting to my steam account and then "launch civ 6") , it close and then nothing ever happen.. I couldn't find any solution on the web. I can't even picture where the problem is.. Any idea ? Solutions ?

Thanks in advance,


Level 4
Level 4
Posts: 221
Joined: Tue Sep 01, 2015 10:15 am

Re: Civilization 6 on steam : launch problem

Post by uberdorf » Wed Dec 27, 2017 7:00 am

Make sure you have installed the proprietary NVIDIA graphics driver and the Intel microcode, that is my guess as to why it won't start. Unfortunately I have had trouble in the past with the NVIDIA 384 series drivers on Ubuntu derivatives, I would recommend 387 if available.

For diagnosing, try opening a terminal and enter the word steam. That should start steam, and any errors should show up in the terminal.

Post Reply

Return to “Gaming on Linux Mint”