Shogun 2 - green screen instead of cinematic sequences

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
Hynek
Level 1
Level 1
Posts: 1
Joined: Fri Dec 29, 2017 1:44 pm

Shogun 2 - green screen instead of cinematic sequences

Post by Hynek » Fri Dec 29, 2017 2:12 pm

The Game (Total War: Shogun 2),
worked fine on my Linuxmint Kde 18.1 "Serena" - Lenovo E50-80, Intel integrated graphic card. However, during cinematic sequences the whole screen was green - I could hear sounds, but had nothing but the green screen to look at. However, I could play the webm movies manually by clicking on them in the Shogun 2/share/data/data/movies folder.

I solved the problem by installing latest drivers from intel: https://01.org/linuxgraphics/downloads/update-tool
Upgrading the drivers was not a straightforward process. I had to set a name of required version of Ubuntu in the "/etc/lsb-release" file, as LinuxMint is not recognized
In my case, it was:

Code: Select all

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS"
I also had to install "packagekit" from the repository.
After the process I reset "/etc/lsb-release" to its original values.

Post Reply

Return to “Gaming on Linux Mint”