Page 1 of 1

Minecraft won't launch in Linux Mint 19 MATE

Posted: Thu Jul 05, 2018 6:34 pm
by Outis
This is similar to the other LM19 Minecraft thread, but my launcher is generating a completely different error message, and updating the certs did not fix it.

Error message:

Code: Select all

Bootstrap (v5)
Current time is Jul 5, 2018, 3:23:52 PM
System.getProperty('os.name') == 'Linux'
System.getProperty('os.version') == '4.15.0-24-generic'
System.getProperty('os.arch') == 'amd64'
System.getProperty('java.version') == '10.0.1'
System.getProperty('java.vendor') == 'Oracle Corporation'
System.getProperty('sun.arch.data.model') == '64'

Downloading: https://s3.amazonaws.com/Minecraft.Download/launcher/launcher.pack.lzma
Exception: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Downloading: https://s3.amazonaws.com/Minecraft.Download/launcher/launcher.pack.lzma (try 2/10)
Exception: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Downloading: https://s3.amazonaws.com/Minecraft.Download/launcher/launcher.pack.lzma (try 3/10)
Exception: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Downloading: https://s3.amazonaws.com/Minecraft.Download/launcher/launcher.pack.lzma (try 4/10)
Exception: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Downloading: https://s3.amazonaws.com/Minecraft.Download/launcher/launcher.pack.lzma (try 5/10)
Exception: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Downloading: https://s3.amazonaws.com/Minecraft.Download/launcher/launcher.pack.lzma (try 6/10)
Exception: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Downloading: https://s3.amazonaws.com/Minecraft.Download/launcher/launcher.pack.lzma (try 7/10)
Exception: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Downloading: https://s3.amazonaws.com/Minecraft.Download/launcher/launcher.pack.lzma (try 8/10)
Exception: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Downloading: https://s3.amazonaws.com/Minecraft.Download/launcher/launcher.pack.lzma (try 9/10)
Exception: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Downloading: https://s3.amazonaws.com/Minecraft.Download/launcher/launcher.pack.lzma (try 10/10)
Exception: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Unable to download remote file. Check your internet connection/proxy settings.
FATAL ERROR: net.minecraft.bootstrap.FatalBootstrapError: Unable to download while being forced
	at net.minecraft.bootstrap.Bootstrap.execute(Bootstrap.java:95)
	at net.minecraft.bootstrap.Bootstrap.main(Bootstrap.java:381)


Please fix the error and restart.

I've also tried downloading the .jar file from the Minecraft website and running that, with the same result.

I'm working off a fresh install of LM19. It worked fine in LM18.3.

Anyone have any ideas?

Re: Minecraft won't launch in Linux Mint 19 MATE

Posted: Fri Jul 06, 2018 3:19 am
by uberdorf
How are you installing java? It looks like there might be a problem with the java 10 installation method in LM 19. I am tempted to try to reproduce that in a virtual machine.

This is how I usually install java, the page happens to be by Pjotr at this forum. https://sites.google.com/site/easylinux ... LINUX-MINT However the duinsoft and webupd8 scripts do work. I am just wary of scripts. Make sure to completely uninstall java 10 first if you try this.

Another possibility is using a snap if you don't want to wait for responses and troubleshoot. I haven't tried this myself. https://ubuntu-mate.community/t/fatal-e ... raft/16677

Code: Select all

sudo snap install minecraft

Re: Minecraft won't launch in Linux Mint 19 MATE

Posted: Fri Jul 06, 2018 9:09 pm
by Outis
I was using the default LM19 installation for Java.

I read elsewhere that sometimes changing to the previous version used by LM18.3 worked, so I uninstalled Java 10, reinstalled the older version that's in the software manager, then updated the cacerts. That allowed Minecraft to launch, but it's not the greatest solution. I think I'll try the snap method sometime this weekend when I have a bit more time.

Re: Minecraft won't launch in Linux Mint 19 MATE

Posted: Sun Jul 08, 2018 12:10 am
by Alpha_sh
i was having the same problem you had, and i came to the same solution. installing the snap version does nothing outside of downloading the minecraft.jar to my knowledge and had the same problem, and installing openJDK 8 and changing the executable in the profile options to use it (change the path of the default openJDK version to OpenJDK 8) worked flawlessly and with great performance (i use mods and shaders and it performs like my hardware would on any other operating system).

Re: Minecraft won't launch in Linux Mint 19 MATE

Posted: Wed Jul 11, 2018 6:18 pm
by uberdorf
Hi, did you get the game to work? I reproduced the problem with a fresh install of LM 19 (Cinnamon), and found that installing openjdk 8 just allowed the launcher to start, but it couldn't play the game from the default launcher. So I got tired of messing with the open source version of java that LM uses by default, and instead install Oracle Java from the webupd8 PPA. http://www.webupd8.org/2012/09/install- ... a-ppa.html Four copy and paste terminal commands from that site and the game was able to play.

Here is the video I made messing with openjdk, and finally installing Oracle Java in the end to get minecraft to fully work, in case anyone is interested. https://youtu.be/tbaDU1l3Onk