Page 1 of 1

Steam problems

Posted: Mon Jul 09, 2018 5:44 pm
by Black Swordsman
I have been trying to install steam onto my computer since I have updated to LM 19 and have not had any luck.

I have tried doing

Code: Select all

sudo apt-get install steam
and tried installing to only get about 3/4 of the installation finished before I get

Code: Select all

FATAL ERROR: Steam needs to be connected to the internet to complete updates
I have even tried downloading from steampowered and I receive

Code: Select all

raun@raun-Game:~$ steam
Running Steam on linuxmint 19 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver:
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: unable to load driver:
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: unable to load driver:
libGL error: failed to load driver: swrast
I tried fixing this problem using ... untu-play/ and following the instructions (which worked for LM18.3) and I still receive the libgl errors

Any ideas as to what I can do to get steam installed and working?

inxi -Fxz

Code: Select all

raun@raun-Game:~$ inxi -Fxz
System:    Host: raun-Game Kernel: 4.15.0-24-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.7 (Gtk 3.22.30) Distro: Linux Mint 19 Tara
Machine:   Device: desktop Mobo: ASUSTeK model: P8Z77-V LX v: Rev X.0x serial: N/A
           BIOS: American Megatrends v: 2501 date: 07/21/2014
CPU:       Quad core Intel Core i7-3770K (-MT-MCP-) 
           arch: Ivy Bridge rev.9 cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28560
           clock speeds: max: 4100 MHz 1: 1632 MHz 2: 1632 MHz 3: 1632 MHz
           4: 1632 MHz 5: 1632 MHz 6: 1633 MHz 7: 1632 MHz 8: 1632 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X]
           bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: AMD TAHITI (DRM 2.50.0 / 4.15.0-24-generic, LLVM 6.0.0)
           version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card-1 Intel 7 Series/C216 Family High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Advanced Micro Devices [AMD/ATI] Tahiti HDMI Audio [Radeon HD 7870 XT / 7950/7970]
           driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.15.0-24-generic
Network:   Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (8.7% used)
           ID-1: /dev/sda model: ST500DM002 size: 500.1GB
Partition: ID-1: / size: 458G used: 41G (10%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 54.0
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 246 Uptime: 10:48 Memory: 2839.4/15988.2MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 

Edit: I was able to get steam up and running using Playonlinux but I just recently got myself a Steam Controller and cannot go into steam's BPM in order to change the controller settings

Re: Steam problems

Posted: Tue Jul 10, 2018 10:35 am
by olay1
You should try this code. Are you running a AMD graphics card?
find ~/.steam/steam/ubuntu12_32/steam-runtime \( -name "*" -o -name "*" -o -name "*" -o -name "*" \) -print -delete

Install steam and put this in the terminal. Then it should work

Re: Steam problems

Posted: Tue Jul 10, 2018 6:35 pm
by rene
It's so hard to not post this for the tenth or so time now... just use the bloody flatpak version!

Re: Steam problems

Posted: Wed Jul 11, 2018 5:11 pm
by Black Swordsman
I ended up following after doing a fresh install of LM19 and I got it to work for me.

I am curious though...what is the difference between the flatpack installation and the i386 that are on the repositories?

Re: Steam problems

Posted: Wed Jul 11, 2018 6:07 pm
by rene
Seems you installed Steam as/through a snap then. That is essentially the same thing as a flatpak, at the very least for purposes of my above recommendation.

Both flatpak and snap are "application container systems": applications (to some degree) supplied with and contained to the well-defined and well-tested environment against which they were originally compiled. Which description is also immediately what the big difference is with the through the repository installed version of Steam.

See e.g. olay1's reply just above. For the repository version his advise was for at least both Mint 17 and 18 sound, and consists of having the through the repository-installer in your home directory installed version of Steam use the system-supplied versions of the shared libraries he names rather than the versions that it supplies itself. If I'm not mistaken this was at least on Mint 17 a GCC ABI issue, where the system- and steam-supplied versions of those libraries used incompatible calling-conventions.

That is, an issue of solving an obscure incompatibility between an application and the system onto which it is deployed. If you've been around Linux for a bit (and not fully wed to repository-only model) you will have noticed similar incompatibilities: with the multitude of Linux distributions and versions thereof, with different GCC versions, different shared library versions -- different environments -- binary distribution on Linux is a nightmare. The only workable solution IS the repository model where distribution maintainers take care of the integration of individual applications into the overall environment of the specific distribution.

This is of course a problem for closed-source applications such as Steam but also just for most any big cross-distribution application: given its dependencies on the specific environment, the repository-version of an application tends to fairly often be semi-frozen: be quickly outdated wrt. the upstream version. The flatpak or snap (or appimage) application-container system battles this by shipping an application alongside its environment: the two are then always in sync.

Don't worry: although I don't know details of snap, at least flatpak defines a few standard environments (called runtimes) whereby not every flatpak-installed application pulls in an entire environment of its own in reality but conceptually that's still very much the idea. Big cross-platform ISV stuff such as Steam are prime candidates for this kind of system and I heartily recommend using it.

On Mint, I would find it better to use the flatpak version as available directly through Software Manager simply seeing as how it's the system that Mint decided upon, but as to snap, knock yourself out. With respect to this recommendation they both solve the same Linux pains.