Minecraft Not Working - Mint Cinammon 19.1

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
Zonafer
Level 1
Level 1
Posts: 1
Joined: Wed Mar 27, 2019 11:29 am

Minecraft Not Working - Mint Cinammon 19.1

Post by Zonafer » Wed Mar 27, 2019 12:15 pm

Hello.

So, I made the switch to Linux Mint from Windows after doing some research and concluding that it would make my computer run faster and have a cleaner interface. I had a problem with WiFi drivers (the Archer T6E I use didn't have available drivers), so I turned to the r/linux4noobs subreddit for answers. Someone noted the chipset, for which I found open-source drivers. Once those were installed, everything was up and running.

Now, this is where Minecraft comes in. I installed Java, LabyMod, and set out to play. A new problem arose, though; the launcher spat back a game crash error. Looking into the output log, the launcher warns that it couldn't get the hash and SHA1 for OptiFine or LabyMod. After loading some more, it then says that an exception in the 'main' thread has occured: java.lang.ClassCastException and then crashes with exit code 1. Looking a bit in debug, I didn't find anything of much use. Apparently, this was actually a very prevalent bug in October of 2017, but it was 'resolved' shortly after. I have also tried playing without any modifications, and the game loads properly, but when attempting to connect to a server, I get a runtime exception error that just states it can't access the address of the buffer. The on-the-fly fix for all of this is to re-install Minecraft, which I tried to no avail. Some other fixes I have also tried include reinstalling the certificates, installing Java instead of OpenJDK (Oracle's JDK won't show up, though), and installing some of the dependencies separately. Is there anything else I, a complete Linux noob, can do to fix the problem?

EDIT: After following these instructions to remove Java, Minecraft now does not crash. However, it still refuses to work; starting up, then showing exit code 0 and just disappearing. The window does not return after that. Any ideas?

My (java -version) output is:

Code: Select all

openjdk version "10.0.2" 2018-07-17
OpenJDK Runtime Environment (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.4)
OpenJDK 64-Bit Server VM (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.4, mixed mode)
My (inxi -Fxz) output is:

Code: Select all

System:
  Host: Desktop Kernel: 4.15.0-46-generic x86_64 bits: 64 compiler: gcc 
  v: 7.3.0 Desktop: Cinnamon 4.0.9 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Desktop System: Hewlett-Packard product: HP Compaq 6000 Pro MT PC 
  v: N/A serial: <filter> 
  Mobo: Hewlett-Packard model: 3048h serial: <filter> BIOS: Hewlett-Packard 
  v: 786G2 v01.09 date: 08/25/2009 
CPU:
  Topology: Dual Core model: Intel Core2 Duo E8500 bits: 64 type: MCP 
  arch: Penryn rev: A L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 12634 
  Speed: 1995 MHz min/max: 1998/3166 MHz Core speeds (MHz): 1: 1995 2: 1995 
Graphics:
  Device-1: AMD Oland XT [Radeon HD 8670 / R7 250/350] 
  vendor: Hightech Information System driver: radeon v: kernel 
  bus ID: 01:00.0 
  Display: server: X.Org 1.19.6 driver: ati,radeon 
  unloaded: fbdev,modesetting,vesa resolution: 1600x900~60Hz 
  OpenGL: renderer: AMD OLAND (DRM 2.50.0 4.15.0-46-generic LLVM 7.0.0) 
  v: 4.5 Mesa 18.2.8 direct render: Yes 
Audio:
  Device-1: Intel 82801JD/DO HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: AMD Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] 
  vendor: Hightech Information System driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 
  Sound Server: ALSA v: k4.15.0-46-generic 
Network:
  Device-1: Intel 82567LM-3 Gigabit Network vendor: Hewlett-Packard 
  driver: e1000e v: 3.2.6-k port: 2100 bus ID: 00:19.0 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network 
  Adapter 
  driver: wl v: kernel port: 1100 bus ID: 30:00.0 
  IF: wls2 state: up mac: <filter> 
Drives:
  Local Storage: total: 232.89 GiB used: 22.24 GiB (9.5%) 
  ID-1: /dev/sda vendor: Samsung model: HD254GJ size: 232.89 GiB temp: 27 C 
Partition:
  ID-1: / size: 228.23 GiB used: 22.24 GiB (9.7%) fs: ext4 dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 33.0 C mobo: N/A gpu: radeon temp: 31 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 184 Uptime: 1h 37m Memory: 3.79 GiB used: 1.99 GiB (52.5%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27
Thanks.

HaveaMint
Level 5
Level 5
Posts: 696
Joined: Fri Feb 02, 2018 9:56 pm
Location: Somewhere in the USA
Contact:

Re: Minecraft Not Working - Mint Cinammon 19.1

Post by HaveaMint » Sun Mar 31, 2019 6:39 am

Zonafer wrote:
Wed Mar 27, 2019 12:15 pm
.
This link may help you.
viewtopic.php?p=1562919#p1562919
"Tune for maximum Smoke and then read the Instructions".

User avatar
twodogs
Level 4
Level 4
Posts: 311
Joined: Sat Jun 09, 2007 9:18 pm

Re: Minecraft Not Working - Mint Cinammon 19.1

Post by twodogs » Sat Jun 01, 2019 9:21 pm

I used Synaptic. Searched for 'openjdk' and removed all versions except eight (openjdk-8-jre). Works great!

Post Reply

Return to “Gaming on Linux Mint”