Page 1 of 1

Steam not opening.

Posted: Tue Apr 16, 2019 9:58 pm
by JustLikeCurisin
New post up scratch this

Hello, I've been trying to figure out why my Steam won't open but i can't find anything to fix the problem. It would be really helpful if someone knew how to fix this. I've tried uninstalling it and reinstalling but nothing happens when i try to open it.

When i type "steam" into the Terminal i get this;

colin@colin-PC:~$ steam
tar: This does not look like a tar archive
xz: (stdin): File format not recognized
tar: Child returned status 1
tar: Error is not recoverable: exiting now
find: ‘/home/colin/.steam/ubuntu12_32/steam-runtime’: No such file or directory

Re: Steam not opening.

Posted: Tue Apr 16, 2019 10:36 pm
by RIH
How are you trying to run it?
If you open a terminal & type
steam
then it should either open as the below picture, or give you some error messages.
The content of any error messages may give readers a clue as to how to help you..
steam.png

Re: Steam not opening.

Posted: Tue Apr 16, 2019 10:39 pm
by JustLikeCurisin
I have the shortcut on my desktop and i normally open it from there.

These are the results what i get when i type "steam"

colin@colin-PC:~$ steam
tar: This does not look like a tar archive
xz: (stdin): File format not recognized
tar: Child returned status 1
tar: Error is not recoverable: exiting now
find: ‘/home/colin/.steam/ubuntu12_32/steam-runtime’: No such file or directory

Re: Steam not opening.

Posted: Tue Apr 16, 2019 10:42 pm
by RIH
From where did did you download/install steam..

Re: Steam not opening.

Posted: Tue Apr 16, 2019 10:44 pm
by JustLikeCurisin
I watched a tutorial on how to do it. When i completed that tutorial Steam was working fine and i was able to play games.

Steam not opening

Posted: Mon Apr 22, 2019 12:23 pm
by bennieset
So I just got TF2 today using PacSteam but every time I go on a server it says that Ive lost my connection to Steam and I cant access any of my achievements or unlocks. Does anyone know how to fix it?

Re: Steam not opening.

Posted: Sat Apr 27, 2019 2:04 pm
by elmarts
RIH wrote:
Tue Apr 16, 2019 10:36 pm
How are you trying to run it?
If you open a terminal & type
steam
then it should either open as the below picture, or give you some error messages.
The content of any error messages may give readers a clue as to how to help you..
steam.png
Jumping in on this thread, I get:
ets@Shinobi-L ~ $ steam
Running Steam on linuxmint 19.1 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
ets@Shinobi-L ~ $
But the icon doesn't show on the bar, and no window opens. This just happened after upgrading from Mint 18 where it worked fine to Mint 19. Now 19.1 doesn't change this. Help?

Re: Steam not opening.

Posted: Mon Apr 29, 2019 5:01 pm
by ShyGuy
I had my Steam break after I upgraded my Nvidia drivers. I had to switch to the Flatpak version of Steam.

Re: Steam not opening.

Posted: Wed May 08, 2019 1:51 pm
by Gugi
few weeks ago, also had same problem, my steam start but not load.. i reinstall packages and it works.

Re: Steam not opening.

Posted: Sun May 12, 2019 8:20 pm
by elmarts
ShyGuy wrote:
Mon Apr 29, 2019 5:01 pm
I had my Steam break after I upgraded my Nvidia drivers. I had to switch to the Flatpak version of Steam.
Reinstalling the deb latest doesn't work. Where did you get the flatpak version?

Re: Steam not opening.

Posted: Sun May 12, 2019 8:22 pm
by elmarts
RIH wrote:
Tue Apr 16, 2019 10:36 pm
How are you trying to run it?
If you open a terminal & type
steam ../.
I get
ets@Shinobi-L ~ $ steam
Running Steam on linuxmint 19.1 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
ets@Shinobi-L ~ $

but no steam ...

Re: Steam not opening.

Posted: Sun May 12, 2019 8:32 pm
by elmarts
elmarts wrote:
Sun May 12, 2019 8:20 pm
ShyGuy wrote:
Mon Apr 29, 2019 5:01 pm
I had my Steam break after I upgraded my Nvidia drivers. I had to switch to the Flatpak version of Steam.
Reinstalling the deb latest doesn't work. Where did you get the flatpak version?
nemind :) found it at https://www.omgubuntu.co.uk/2017/06/ste ... le-flatpak and installing it, it now works again. But - I have to reinstall all my games :(

Re: Steam not opening.

Posted: Fri May 17, 2019 12:09 pm
by ShyGuy
Sorry I didn't see your message earlier, glad you got it working. https://flathub.org/apps/details/com.va ... ware.Steam

Re: Steam not opening.

Posted: Fri Jun 28, 2019 2:26 pm
by elmarts
Problem still not really solved. Yes the flatpak version runs, and it will let me install a game, but I need to install the game folders on a new etx4 drive I added to the system to avoid filling my boot drive. But I could not find the steam library folders anywhere (side note - where are they? not in .local/share/steam - which folder does not exist). So I uninstalled the existing steam (flatpak) and reinstalled the latest deb version from the Steam website. That resulted in the expected folders showing up again, but the steam program itself still refused to run, although the process explorer in the system monitor said it was running (sleeping).

Now here it gets weird - I shut down steam (killed it). Then moved the steam folders from,local/share to the new drive. Then restarted steam, and it complained that I had moved its folders! I pointed it to its new folder location, and it seemed happy, but would not continue to run (i.e. would not show the connecting window or kick up the graphical interface).

Could this be a graphics issue? I am running nvidia 390, but I have seen talk of version 430. I found that on the nvidia site (a "run" file that demands I run it from outside of x-window and as root). Ideas? Help?

Re: Steam not opening.

Posted: Wed Jul 03, 2019 1:04 am
by sirrandoom
I also installed steam via .deb in the steam site and got the same error. The steam simply doesn't launch and finishes the application on terminal.

Image

Re: Steam not opening.

Posted: Sat Jul 13, 2019 8:50 pm
by elmarts
I'm running kernal 4.15. I tried updating to kernal 5.1.16 via ukuu, and my system became essentially unusable - jerky mouse, second screen gone. So still no fix. And the newer kernals bork my system. And Steam still won't run. grrrr.......

Re: Steam not opening.

Posted: Wed Jul 31, 2019 2:04 pm
by elmarts
Changed the kernel to 5.0. Steam still won't start. No further ideas?