Steam fails to connect on Kernel 5.0.0-17

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
ugly
Level 4
Level 4
Posts: 221
Joined: Thu Nov 24, 2016 9:17 pm

Steam fails to connect on Kernel 5.0.0-17

Post by ugly » Tue Jun 18, 2019 9:36 am

Yesterday I received an update to Kernel version 5.0.0-17. After rebooting, I have been unable to connect to Steam.

Steam attempts to login, but after about a minute, I get the Steam error message 'Can't connect to Steam network'.

There doesn't appear to be any issues with the actual Steam network (no reported outages). I can connect to a version of Wine Steam that I have. I did some searching that recommended deleting the ./.steam/steam/appcache folder, which worked one time, but failed the next. I also tried deleting the entire ./.steam folder, which resulted in Steam re-downloading and running. That also worked one time but then failed to restart.

Switching back to Kernel version 5.0.0-16 and Steam runs just fine.

For reference, here is my output of inxi -FGz:

Code: Select all

System:
  Host: rickpc Kernel: 5.0.0-16-generic x86_64 bits: 64 
  Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa 
Machine:
  Type: Desktop System: Gigabyte product: Z170-HD3P v: N/A serial: <filter> 
  Mobo: Gigabyte model: Z170-HD3P-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F22g date: 03/09/2018 
CPU:
  Topology: Quad Core model: Intel Core i5-6600K bits: 64 type: MCP 
  L2 cache: 6144 KiB 
  Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 
Graphics:
  Device-1: AMD Pitcairn PRO [Radeon HD 7850 / R7 265 / R9 270 1024SP] 
  driver: amdgpu v: kernel 
  Display: x11 server: X.Org 1.19.6 driver: amdgpu unloaded: radeon 
  resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: AMD Radeon HD 7800 Series (PITCAIRN DRM 3.27.0 
  5.0.0-16-generic LLVM 9.0.0) 
  v: 4.5 Mesa 19.2.0-devel - padoka PPA 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio 
  driver: snd_hda_intel 
  Device-2: AMD Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] 
  driver: snd_hda_intel 
  Device-3: XMOS type: USB driver: snd-usb-audio 
  Sound Server: ALSA v: k5.0.0-16-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 8.54 TiB used: 5.81 TiB (68.1%) 
  ID-1: /dev/nvme0n1 model: SBX size: 238.47 GiB 
  ID-2: /dev/sda vendor: Crucial model: M4-CT128M4SSD2 size: 119.24 GiB 
  ID-3: /dev/sdb vendor: HGST (Hitachi) model: HMS5C4040ALE640 
  size: 3.64 TiB 
  ID-4: /dev/sdc vendor: Seagate model: ST3000DM001-1CH166 size: 2.73 TiB 
  ID-5: /dev/sdd vendor: Toshiba model: HDWD120 size: 1.82 TiB 
Partition:
  ID-1: / size: 59.83 GiB used: 20.05 GiB (33.5%) fs: ext4 
  dev: /dev/nvme0n1p2 
  ID-2: /home size: 86.58 GiB used: 41.61 GiB (48.1%) fs: ext4 
  dev: /dev/nvme0n1p3 
Sensors:
  System Temperatures: cpu: 36.0 C mobo: N/A gpu: amdgpu temp: 44 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
Info:
  Processes: 246 Uptime: 1m Memory: 15.62 GiB used: 1.25 GiB (8.0%) 
  Shell: bash inxi: 3.0.27

rene
Level 11
Level 11
Posts: 3603
Joined: Sun Mar 27, 2016 6:58 pm

Re: Steam fails to connect on Kernel 5.0.0-17

Post by rene » Sun Jun 23, 2019 11:50 am

Just ran into this; It's a known problem, with fix in process: https://lkml.org/lkml/2019/6/21/875. Should arrive also in Ubuntu kernels relatively shortly therefore. Starting Steam with the -tcp parameter may work for you in the mean time.

ugly
Level 4
Level 4
Posts: 221
Joined: Thu Nov 24, 2016 9:17 pm

Re: Steam fails to connect on Kernel 5.0.0-17

Post by ugly » Fri Jun 28, 2019 6:36 pm

Today's kernel update has the fix. Kernel 5.0.0-20 works.

Post Reply

Return to “Gaming on Linux Mint”