Trouble running Hearthstone with Lutris on 18.3, any help?

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
Caravaggio
Level 1
Level 1
Posts: 18
Joined: Tue May 15, 2018 4:52 pm
Location: Scotland

Trouble running Hearthstone with Lutris on 18.3, any help?

Post by Caravaggio » Sun Jul 21, 2019 4:43 am

Hi all,

For the past couple of days I have been trying to install and run Hearthstone on my machine (Mint 18.3 Sylvia, Cinnamon 64-bit) without success.
I have tried several tutorials and my understanding is that the most viable option at the moment is Lutris (+Wine), however I keep encountering two errors:
DX11 to Vulkan (DXVK) version - this version allows me to fully install the game, however as the Battle.net launcher start up it crashes, right after logging into my account. All it says is that "an unexpected error occured", without any indication of what I might need to change.
DX9 to OpenGL version - this version gives me a series of different errors during installation, the main one being "installer cannot be found", therefore being unable to even run the the game.

I keep bashing my head against a wall and I cannot find a single guide that goes over the errors that I'm getting.
Is there any kind soul in here willing to lend a hand?

calran
Level 1
Level 1
Posts: 1
Joined: Sat Aug 03, 2019 5:49 pm

Re: Trouble running Hearthstone with Lutris on 18.3, any help?

Post by calran » Sat Aug 03, 2019 5:52 pm

I created an account to bump this issue.

DX9 to OpenGL version - this version gives me "installer cannot be found", therefore being unable to even run the the game.

(Mint 19.1 Cinnamon)

Post Reply

Return to “Gaming on Linux Mint”