3d steam games wont work

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
Savatoge74
Level 1
Level 1
Posts: 6
Joined: Mon Jul 27, 2020 6:53 pm

3d steam games wont work

Post by Savatoge74 »

I switched to linux back in January when windows 7 lost its support. I immediately had issues with 3d steam games specifically no mans sky, my time at portia, skyrim and wolcen refused to launch. My 2d games starbound and stardew valley work fine. I have proton 4.11, lutris, and wine installed. During my research, I read that my geforce gtx 760 was a generation too old to be supported by vulkan or measa, so I bought and installed a amd rx580. However, my problem still persists. I have no idea where to start to fix this. I have tried following the steam set up tutorials, but that hasnt fixed the problem. Anyone have any ideas where to start?
User avatar
J-103
Level 1
Level 1
Posts: 1
Joined: Sun Feb 03, 2019 8:49 am

Re: 3d steam games wont work

Post by J-103 »

I don't know where you read that info about the 760 being a generation too old for vulkan support because my 650 is doing a more than decent job running games with vulkan, I even finished Doom 2016 using that gpu. I don't know much about amd cards but usually with them you only need the open source driver which is already in the kernel, so make sure that you have the latest version available to avoid problems and don't try to install any other driver unless it's absolutely necessary.

How are you trying to run your games? Doing something with lutris and wine or using only Steam? For Steam games Steam should be more than enough. I haven't opened Skyrim in a very long time but last time I checked it worked fine with proton and according to ProtonDB both the original version and the Special Edition should work. The latest proton version is 5.0-9 so you might want to make sure that's the one you have. Also, you should see if that you have checked the "Enable Steam Play for all other titles" option in the Steam settings to be sure that it works with more games than the ones that were officially whitelisted by Valve, and have the shader pre-caching enabled to get better performance.
Savatoge74
Level 1
Level 1
Posts: 6
Joined: Mon Jul 27, 2020 6:53 pm

Re: 3d steam games wont work

Post by Savatoge74 »

I'm trying to run al the mentioned games through steam. Just tried proton 5.0-9 and the games try to launch. The window comes up saying preparing to launch No Man's Sky or whatever other 3d game I try. Then it says "processing vulkan shaders", eventually the little window just disappears and the play button goes from cancel back to play. The enable steam play for other titles box is checked and proton 5.0-9 is selected from the drop down menu. I'm missing something somewhere, but have no clue what it is. Everyone claims it's so easy to play steam windows games on linux. but so far it's just been a headache for me.
ajgringo619
Level 8
Level 8
Posts: 2127
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California, USA

Re: 3d steam games wont work

Post by ajgringo619 »

Try another version of Proton. I did that with Worms Armageddon when v5 wouldn't work (backed up to v3.6). Check the Proton Database for more info: https://www.protondb.com/
Mint 20 XFCE [kernel 5.4.0-56-generic]
Ryzen 7 2700X Eight-Core w/16 GB RAM
GTX 1070 w/8GB RAM [Folding]
GTX 1050Ti w/4GB RAM [Nvidia v450.80.02]
Image
cretsiah
Level 2
Level 2
Posts: 60
Joined: Wed Jul 22, 2020 5:44 am

Re: 3d steam games wont work

Post by cretsiah »

I be thinking you maybe missing some packages like

- i386 architecture
- dxvk (for direct x 9, 10, 11)
- libfaudio

you will need to enter synaptic package manager for those if gui, or know your command line stuff.

but it might help to give us an " inxi report " as well.
Savatoge74
Level 1
Level 1
Posts: 6
Joined: Mon Jul 27, 2020 6:53 pm

Re: 3d steam games wont work

Post by Savatoge74 »

Code: Select all

System:    Kernel: 5.4.0-42-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.6.6 
           wm: muffin dm: LightDM Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:   Type: Desktop Mobo: ASUSTeK model: M5A97 R2.0 v: Rev 1.xx serial: <filter> 
           UEFI: American Megatrends v: 1602 date: 02/25/2013 
CPU:       Topology: 8-Core model: AMD FX-8350 bits: 64 type: MCP arch: Bulldozer 
           L2 cache: 2048 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 64216 
           Speed: 4183 MHz min/max: 1400/4000 MHz Core speeds (MHz): 1: 4189 2: 4146 3: 1404 
           4: 1398 5: 1393 6: 1404 7: 1404 8: 1402 
Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Micro-Star MSI driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati 
           unloaded: fbdev,modesetting,radeon,vesa resolution: 1920x1080~60Hz 
           OpenGL: 
           renderer: Radeon RX 580 Series (POLARIS10 DRM 3.35.0 5.4.0-42-generic LLVM 10.0.1) 
           v: 4.6 Mesa 20.2.0-devel (git-18fe130 2020-07-26 focal-oibaf-ppa) direct render: Yes 
Audio:     Device-1: AMD SBx00 Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 chip ID: 1002:4383 
           Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
           vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 1002:aaf0 
           Device-3: Creative Labs Sound Core3D [Sound Blaster Recon3D / Z-Series] 
           driver: snd_hda_intel v: kernel bus ID: 06:00.0 chip ID: 1102:0012 
           Sound Server: ALSA v: k5.4.0-42-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: ASUSTeK P8 series driver: r8169 v: kernel port: d000 bus ID: 02:00.0 
           chip ID: 10ec:8168 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.07 TiB used: 248.70 GiB (22.6%) 
           ID-1: /dev/sda vendor: Seagate model: ST31000524AS size: 931.51 GiB speed: 6.0 Gb/s 
           serial: <filter> 
           ID-2: /dev/sdb vendor: Intel model: SSDSC2BW180A3L size: 167.68 GiB speed: 6.0 Gb/s 
           serial: <filter> 
Partition: ID-1: / size: 163.55 GiB used: 57.74 GiB (35.3%) fs: ext4 dev: /dev/sdb2 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 5 rev: 2.0 chip ID: 1d6b:0002 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 5 rev: 2.0 chip ID: 1d6b:0002 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 chip ID: 1d6b:0002 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 5 rev: 1.1 chip ID: 1d6b:0001 
           Device-1: 4-5:2 info: Razer USA Razer Naga Chroma type: Mouse,Keyboard 
           driver: hid-generic,usbhid rev: 2.0 chip ID: 1532:0053 
           Hub: 5-0:1 info: Full speed (or root) Hub ports: 5 rev: 1.1 chip ID: 1d6b:0001 
           Device-2: 5-1:2 info: Microsoft Natural Ergonomic Keyboard 4000 V1.0 type: Keyboard,HID 
           driver: microsoft,usbhid rev: 2.0 chip ID: 045e:00db 
           Hub: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 chip ID: 1d6b:0001 
           Hub: 7-0:1 info: Full speed (or root) Hub ports: 4 rev: 1.1 chip ID: 1d6b:0001 
           Hub: 8-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 chip ID: 1d6b:0002 
           Hub: 9-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 chip ID: 1d6b:0003 
           Hub: 10-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 chip ID: 1d6b:0002 
           Hub: 11-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 27.1 C mobo: N/A gpu: amdgpu temp: 38 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 979 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/additional-repositories.list 
           1: deb https: //dl.winehq.org/wine-builds/ubuntu/ focal main
           Active apt repos in: /etc/apt/sources.list.d/lutris-team-lutris-focal.list 
           1: deb http: //ppa.launchpad.net/lutris-team/lutris/ubuntu focal main
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http: //packages.linuxmint.com ulyana main upstream import backport #id:linuxmint_main
           2: deb http: //archive.ubuntu.com/ubuntu focal main restricted universe multiverse
           3: deb http: //archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
           4: deb http: //archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
           5: deb http: //security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http: //archive.canonical.com/ubuntu/ focal partner
           Active apt repos in: /etc/apt/sources.list.d/oibaf-graphics-drivers-focal.list 
           1: deb http: //ppa.launchpad.net/oibaf/graphics-drivers/ubuntu focal main
Info:      Processes: 249 Uptime: 2h 33m Memory: 7.67 GiB used: 2.03 GiB (26.4%) Init: systemd 
           v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 7/9 Client: Unknown python3.8 client 
           inxi: 3.0.38 
cretsiah
Level 2
Level 2
Posts: 60
Joined: Wed Jul 22, 2020 5:44 am

Re: 3d steam games wont work

Post by cretsiah »

I would try installing those packages i mentioned above and try again.....

although i dont have the same graphics card and cpu as you -
maybe look at this thread as im going through my steam library now
viewtopic.php?f=225&t=325836
start around the 16th post.

doing what ive done i now have "Company of Heroes" and " Far Cry " up and running. - waiting for the rest to download.

ive also changed down/across to XFCE it feels lighter than cinamon,

you may need to also turn off steam overlay and vr options.

PS:
- im doing the "Force steam to use a specific steam play compat tool " on a per game basis under game properties
- in steam global settings
"Shader pre-cahing " i only have the top entry ticked "enable shader pre caching" I DO NOT have "allow background processing of vulkan shaders " ticked.
"steam play " settings only the top one is ticked " enable steam play for supported titles" .... the other setting here I do not have ticked
Savatoge74
Level 1
Level 1
Posts: 6
Joined: Mon Jul 27, 2020 6:53 pm

Re: 3d steam games wont work

Post by Savatoge74 »

I installed the packages you suggested via the synaptic package manager and set set steam so it is forced to use proton 5.0-9. I've tried multiple versions of proton(they recommend 5.0-9 with a gold rating for No Man's Sky). I also changed the steam settings you suggested. They still don't work. The games act like they're going to play, but then the steam logo just turns for a while, the turns back to play. Do I maybe need to uninstall steam completely and reinstall it using the terminal? I've seen posts suggesting that's the best way to install it. I've also seen youtubers who simply install steam through the package manager, click "allow steam play for other titles" and have their games work. Wish I knew what I'm doing wrong, this is very frustrating.
Savatoge74
Level 1
Level 1
Posts: 6
Joined: Mon Jul 27, 2020 6:53 pm

Re: 3d steam games wont work

Post by Savatoge74 »

It seems to only be the no native games that don't work. Just installed and played team fortress 2 and it worked fine. Must be a problem with proton then?
Savatoge74
Level 1
Level 1
Posts: 6
Joined: Mon Jul 27, 2020 6:53 pm

Re: 3d steam games wont work

Post by Savatoge74 »

The problem was that the drive I was installing my games to is formatted ntfs which proton apparently doesn't work with. I reinstalled no man's sky to my operating systems drive and it works fine. Problem solved guess I'll be formatting the old drive.
cretsiah
Level 2
Level 2
Posts: 60
Joined: Wed Jul 22, 2020 5:44 am

Re: 3d steam games wont work

Post by cretsiah »

Well Done.......

Sorry but ive had my own issues with isp :(
Post Reply

Return to “Gaming on Linux Mint”