Missing the following 32-bit libraries, and Steam may not run

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
Tyde
Level 1
Level 1
Posts: 1
Joined: Sun Aug 02, 2020 5:53 pm

Missing the following 32-bit libraries, and Steam may not run

Post by Tyde »

Hello, brand new to Linux. I'm trying to get steam to work but every time i run it i get
You are missing the following 32-bit libraries, and Steam may not run: libc.so.6

looked it up online and found these commands

sudo dpkg --add-architecture i386
sudo apt-get update

sudo apt-get install libgl1-mesa-dri:i386

but the last command still didn't work so i look up the command and put in missing dependencies and found a bunch of commands on the inernet and eventualy gave up and now the output looks like

Steam needs to install these additional packages:
libgl1-mesa-dri:i386, libgl1:i386, libc6:i386
[sudo] password for tyde:
............
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
apt : Breaks: aptitude:i386 (< 0.8.10)
aptitude:i386 : Depends: libapt-pkg4.12:i386 (>= 0.8.16~exp12ubuntu6) but it is not installable
Depends: libboost-iostreams1.46.1:i386 (>= 1.46.1-1) but it is not installable
Depends: libcwidget3:i386 but it is not installable
Depends: libept1.4.12:i386 but it is not installable
Depends: libgcc1:i386 (>= 1:4.1.1)
Depends: libncursesw5:i386 (>= 5.6+20070908) but it is not going to be installed
Depends: libsigc++-2.0-0c2a:i386 (>= 2.0.2) but it is not installable
Depends: libsqlite3-0:i386 (>= 3.6.5) but it is not going to be installed
Depends: libstdc++6:i386 (>= 4.6) but it is not going to be installed
Depends: libtinfo5:i386 but it is not going to be installed
Depends: libxapian22:i386 but it is not installable
Recommends: apt-xapian-index:i386 but it is not installable
Recommends: libparse-debianchangelog-perl:i386 but it is not installable
aptitude-common : Breaks: aptitude:i386 (< 0.8.10-4)
Recommends: aptitude but it is not going to be installed
libapt-pkg6.0 : Breaks: aptitude:i386 (< 0.8.9)
libc6:i386 : Depends: libgcc-s1:i386 but it is not going to be installed
Depends: libcrypt1:i386 (>= 1:4.4.10-10ubuntu4) but it is not going to be installed
Recommends: libidn2-0:i386 (>= 2.0.5~) but it is not going to be installed
libgl1:i386 : Depends: libglvnd0:i386 (= 1.3.1-1) but it is not going to be installed
Depends: libglx0:i386 (= 1.3.1-1) but it is not going to be installed
libgl1-mesa-dri:i386 : Depends: libdrm-amdgpu1:i386 (>= 2.4.100) but it is not going to be installed
Depends: libdrm-intel1:i386 (>= 2.4.38) but it is not going to be installed
Depends: libdrm-nouveau2:i386 (>= 2.4.66) but it is not going to be installed
Depends: libdrm-radeon1:i386 (>= 2.4.31) but it is not going to be installed
Depends: libdrm2:i386 (>= 2.4.75) but it is not going to be installed
Depends: libelf1:i386 (>= 0.142) but it is not going to be installed
Depends: libexpat1:i386 (>= 2.0.1) but it is not going to be installed
Depends: libgcc-s1:i386 (>= 4.2) but it is not going to be installed
Depends: libglapi-mesa:i386 (= 20.0.8-0ubuntu1~20.04.1) but it is not going to be installed
Depends: libllvm10:i386 (>= 1:9~svn298832-1~) but it is not going to be installed
Depends: libsensors5:i386 (>= 1:3.5.0) but it is not going to be installed
Depends: libstdc++6:i386 (>= 5.2) but it is not going to be installed
Depends: libvulkan1:i386 (>= 1.2.131.2) but it is not going to be installed
Depends: libzstd1:i386 (>= 1.3.2) but it is not going to be installed
Depends: zlib1g:i386 (>= 1:1.1.4) but it is not going to be installed
mintbackup : Depends: aptitude but it is not going to be installed
mintsystem : Depends: aptitude but it is not going to be installed
ppa-purge : Depends: aptitude but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
Press return to continue:

I am completely lost and can't seem to find a working solution on the internet.
kalondoothrash
Level 1
Level 1
Posts: 1
Joined: Sun Aug 02, 2020 11:14 pm

Re: Missing the following 32-bit libraries, and Steam may not run

Post by kalondoothrash »

I am having the same issue, if steam requires some 32 bit libraries and linux dropped them.
How are people running steam games?
it just tells me "check internet connection"
Last edited by xenopeek on Mon Aug 03, 2020 1:21 am, edited 1 time in total.
Reason: removed swearing
User avatar
RandomStranger
Level 1
Level 1
Posts: 12
Joined: Thu Jul 16, 2020 2:41 am
Contact:

Re: Missing the following 32-bit libraries, and Steam may not run

Post by RandomStranger »

I had the same issue a couple of weeks ago. This is what worked for me:
viewtopic.php?f=225&t=325167&sid=edee83 ... aad431642c
Image
mr_raider
Level 7
Level 7
Posts: 1889
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: Missing the following 32-bit libraries, and Steam may not run

Post by mr_raider »

What vesrion of Mint are you using?

How did you install steam?
Image
Post Reply

Return to “Gaming on Linux Mint”