Setting GPU Execution Cap

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
Titan91
Level 2
Level 2
Posts: 54
Joined: Mon May 23, 2016 8:30 am

Setting GPU Execution Cap

Post by Titan91 »

I'm running Linux Mint 20 x64 Cinnamon edition with Mesa drivers. I have a game (Planet Coaster) that uses 90%-100% GPU at all times, even when the game is paused and in menus. It's a common issue and my AMD RX 580 is more than adequate to handle the game. It does this regardless of graphics settings, resolution, or frame rate cap. It's a known issue on Windows as well. Can I limit the GPU utilization in the kernel or using some other method? Trying to get around poor game/engine design.
User avatar
RandomStranger
Level 1
Level 1
Posts: 12
Joined: Thu Jul 16, 2020 2:41 am
Contact:

Re: Setting GPU Execution Cap

Post by RandomStranger »

I'd never tried this, but AMD's official driver should (https://www.amd.com/en/support/graphics ... eon-rx-580) allow you to assign dedicated tuning setup for each game (it does on Windows at least).

So I guess you can just set an underclolck for that specific game. It will still use 100% of the available GPU power, but it will be less than its full power.
Image
Titan91
Level 2
Level 2
Posts: 54
Joined: Mon May 23, 2016 8:30 am

Re: Setting GPU Execution Cap

Post by Titan91 »

I found something similar to MSI Afterburner and RivaTuner... on Linux! It's called CoreCtl and I'm 100% confident this will resolve my Radeon power consumption issue with certain games. Looks like a fantastic program. Hopefully this helps others as well.

https://www.youtube.com/watch?v=Zi77qiZzChg
Eric23
Level 1
Level 1
Posts: 35
Joined: Sun Oct 11, 2020 11:45 am
Location: UK

Re: Setting GPU Execution Cap

Post by Eric23 »

I'm also a Planet Coaster player, but I have Nvidia graphics.
On windows, if I minimized the game it would slow the GPU usage right down as if it were running in the background. When running it using Proton it just runs flat out even when minimized. This makes multitasking quite sluggish. Firefox will crawl and YouTube videos are unwatchable while Planet Coaster is running.
It seems there is no background mode. Other than that I think the game actually runs smoother with Proton compared to windows 7. Though in windows I could actually do other things with it running.

The only thing that doesn't work for me is custom music. I found the user music folder and dropped in some music. They show up in the game menus, but they don't actually play when selected. The startup video also has no sound, I wonder if the two are related. I actually found the startup video in the game files and playing it in VLC does have sound. Does anyone know of a fix for custom music?
Post Reply

Return to “Gaming on Linux Mint”