How should I add Crossover gstreamer plugins

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help
Post Reply
asteroth
Level 1
Level 1
Posts: 9
Joined: Mon Oct 26, 2020 5:03 pm

How should I add Crossover gstreamer plugins

Post by asteroth »

Hello! I'm relatively new to mint and not all that familiar with the why and wherefore of things. That aside I would like to play a game I had been playing on a previous system, League of Angels. I believe I've found a way to do that with crossover from codeweavers; however, when trying to install the game it produces this
[MissingGStreamer1Bad2]
"Title"="The gst-plugins-bad 32-bit GStreamer plugins appear to be missing h264parse"

[MissingGStreamer1Ugly]
"Title"="The gst-plugins-ugly 32-bit GStreamer plugins appear to be missing asfdemux"

[MissingGStreamer1Libav]
"Title"="The gst-libav 32-bit GStreamer plugins appear to be missing avdec_eac3"
Now I looked at their site and found this ,https://www.codeweavers.com/support/wik ... eamer1Bad2. But it doesn't show the full command line and I am loath to experiment.
What should I do?
anonymous

Re: How should I add Crossover gstreamer plugins

Post by anonymous »

hello,

run the following:

sudo /opt/cxoffice/bin/csfix --auto

that will automatically fix your missing libraries.
User avatar
AndyMH
Level 14
Level 14
Posts: 5023
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: How should I add Crossover gstreamer plugins

Post by AndyMH »

neko-cha you got it wrong (typo), should be

Code: Select all

sudo /opt/cxoffice/bin/cxfix --auto
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
anonymous

Re: How should I add Crossover gstreamer plugins

Post by anonymous »

ah...typo ^^;

thanks for the correction!
User avatar
AndyMH
Level 14
Level 14
Posts: 5023
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: How should I add Crossover gstreamer plugins

Post by AndyMH »

I only know because I recently had to use it to get the 32 bit libraries required for office 2013 :)
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
Post Reply

Return to “Gaming on Linux Mint”