Page 1 of 1

x220 Touchpad stopped working

Posted: Tue Apr 24, 2012 5:58 am
by timbo
I am using LMDE latest with Cinnamon.

Yesterday I used the Laptop pretty much all day on battery mode. When I came home, the thing was plugged in and connected to an external monitor. I adjusted the screen and x crashed telling me to log out and back in. Since then the internal Touchpad quit its job while the Trackpoint works just fine. I reinstalled the Synaptic driver and Cinnamon, but it still doesn't function.

Maybe this problem is Cinnamon or Gnome related, I don't know.

UPDATE: A fresh system install, checking BIOS settings and updating to the latest version did not do the trick.

Re: x220 Touchpad stopped working

Posted: Tue Apr 24, 2012 10:28 pm
by lashes
The fact you've done a fresh install and no go has thrown me a bit - my solution may be useless but worth a try. I'm running Cinnamon on standard Mint 12 on a lenovo T60 laptop. Lost my touchpad while fooling around with settings - don't know what happened really. Trackpad still working. After trying a number of things, I found a Cinnamon applet called Touchpad indicator here - http://cinnamon-spices.linuxmint.com/applets/view/44.
Instal by downloading and unzipping to /home/.local/share/cinnamon/applets.
Add to panel and open - set enable touchpad to on.
Good luck

Re: x220 Touchpad stopped working

Posted: Wed Apr 25, 2012 10:03 am
by timbo
Hey Iashes.

Thanks for your suggestion. Actually I didn't get to try it because I added the PPA, installed some additional applets and tried them. Some don't work and others just completely crash Cinnamon. Who knows which setting or file it was in the end, but deleting all Cinnamon folders in /home did the trick. The touchpad works for now.

Again, thanks!

Re: x220 Touchpad stopped working

Posted: Fri May 04, 2012 2:13 am
by lostpoetjj
It isn't Cinnamon -- I have the same problem and don't use Cinnamon. It's Gnome, or something deeper, 'randomly' disabling the trackpad.

Anyway there is a long discussion about this in the following thread: http://forums.linuxmint.com/viewtopic.p ... t=trackpad

But the immediate fix is to open a terminal (eg, by pressing Control-Alt-T) and type

Code: Select all

sudo apt-get install gpointing-device-settings
gpointing-device-settings
In the window that subsequently appears, uncheck 'Disable touchpad'. (What a useful little app -- it should be installed by default.)

Alternatively type

Code: Select all

sudo rmmod psmouse
sudo modprobe psmouse
to restart the mouse drivers. (I haven't tried that yet myself.)

Neither of these are permanent fixes -- it may happen again, and you'll have to reset it again.

Re: x220 Touchpad stopped working

Posted: Mon Aug 27, 2012 8:43 am
by doctor_y
I've been having this exact problem on and off for a while now. Seemingly random on an Inspiron 1521. I figured it was something else happening because the mouse would just stop working so id restart X and it would work again. Recently that seemed to not work and then i got the idea to try plugging a usb mouse in which worked. I searched for a solution and found this one.

I've used the modprobe psmouse and it solved the problem. The module was not loaded so the rmmod wasnt needed in my case.

thanks for a solution(even if its temporary!)

Re: x220 Touchpad stopped working

Posted: Sun Sep 09, 2012 7:16 am
by timbo
Great work. Thanks for the solution, lostpoetjj!