Unable to install Dropbox

Archived topics about LMDE 1
Locked
rmcellig
Level 4
Level 4
Posts: 226
Joined: Sat May 28, 2011 11:47 am

Unable to install Dropbox

Post by rmcellig » Wed Apr 25, 2012 5:20 pm

I just installed the newly released Mint LXDE today. When I try to install Dropbox, I get this error. What should I do? I never had a problem installing Dropbox before. I tried the 32 and 64bit versions for Ubuntu and Debian from the Dropbox install page.
Attachments
dropboxerror.png
dropboxerror.png (52.6 KiB) Viewed 4281 times
Take care,

Randy
www.mcran.com - my web site
www.chuo.fm - My radio show every Sunday from noon-2pm or 89.1 fM

tenfoot
Level 6
Level 6
Posts: 1009
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Re: Unable to install Dropbox

Post by tenfoot » Wed Apr 25, 2012 5:27 pm

Go to Synaptic Package Manager and search for "libnautilus-extensions..." and install it.
tenfoot
"Light thinks it travels faster than anything but it is wrong. No matter how fast light travels, it finds darkness always got there first, and is waiting for it." Terry Pratchett (Reaper Man)

rmcellig
Level 4
Level 4
Posts: 226
Joined: Sat May 28, 2011 11:47 am

Re: Unable to install Dropbox

Post by rmcellig » Wed Apr 25, 2012 5:51 pm

I did that and restarted my computer. I still get the same error.
Take care,

Randy
www.mcran.com - my web site
www.chuo.fm - My radio show every Sunday from noon-2pm or 89.1 fM

User avatar
bu99zy
Level 3
Level 3
Posts: 135
Joined: Wed Jan 18, 2012 12:59 am

Re: Unable to install Dropbox

Post by bu99zy » Fri Apr 27, 2012 9:21 pm

Try installing from the terminal, works fine for me.

Code: Select all

lmde bu99zy # apt-cache policy dropbox
dropbox:
  Installed: (none)
  Candidate: 1.0.1
  Version table:
     1.0.1 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages
lmde bu99zy # apt install dropbox
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  nautilus-dropbox python-gpgme
The following NEW packages will be installed:
  dropbox nautilus-dropbox python-gpgme
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 189 kB of archives.
After this operation, 782 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://packages.linuxmint.com/ debian/main dropbox all 1.0.1 [1,468 B]
Get:2 http://debian.linuxmint.com/latest/ testing/main python-gpgme amd64 0.2-2 [83.4 kB]
Get:3 http://debian.linuxmint.com/latest/ testing/non-free nautilus-dropbox amd64 0.7.1-2 [104 kB]
Fetched 189 kB in 3s (60.1 kB/s)           
Selecting previously unselected package python-gpgme.                                                                                      
(Reading database ... 224158 files and directories currently installed.)                                                                   
Unpacking python-gpgme (from .../python-gpgme_0.2-2_amd64.deb) ...                                                                         
Selecting previously unselected package nautilus-dropbox.                                                                                  
Unpacking nautilus-dropbox (from .../nautilus-dropbox_0.7.1-2_amd64.deb) ...                                                               
Selecting previously unselected package dropbox.
Unpacking dropbox (from .../archives/dropbox_1.0.1_all.deb) ...
Processing triggers for man-db ...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Processing triggers for hicolor-icon-theme ...
Setting up python-gpgme (0.2-2) ...
Setting up nautilus-dropbox (0.7.1-2) ...

Dropbox is the easiest way to share and store your files online. Want to learn more? Head to http://www.dropbox.com/

Downloading Dropbox... 100%
Unpacking Dropbox... 100%
Please restart all running instances of Nautilus, or you will experience problems. i.e. nautilus --quit
Dropbox installation successfully completed! You can start Dropbox from your applications menu.
Setting up dropbox (1.0.1) ...

madwoollything
Level 3
Level 3
Posts: 154
Joined: Sun Jul 20, 2008 8:46 am

Re: Unable to install Dropbox

Post by madwoollything » Fri May 04, 2012 11:03 am

I've just made the upgrade to pack 4 and dropbox is no longer working and cannot be installed due to unmet dependencies with nautilus-dropbox package.

I already have the nautilus extensions installed as mentioned at the start of this thread ..... any other ideas as I really need to get dropbox working again. (I've checked synaptic for an broken packages and all seems to be fine).

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: Unable to install Dropbox

Post by zerozero » Fri May 04, 2012 11:08 am

madwoollything,
if you follow bu99zy advise in the post just above yours what happens?

Code: Select all

apt install dropbox
Image

[ bliss of ignorance ]

madwoollything
Level 3
Level 3
Posts: 154
Joined: Sun Jul 20, 2008 8:46 am

Re: Unable to install Dropbox

Post by madwoollything » Fri May 04, 2012 1:26 pm

zerozero wrote:madwoollything,
if you follow bu99zy advise in the post just above yours what happens?

Code: Select all

apt install dropbox
If I attempt to install from the terminal I get the following:

"The following packages have unmet dependencies:
dropbox : Depends: nautilus-dropbox
E: Broken packages"

I've looking in synaptic and there are no broken packages ..... bit of a mystery.

----------------------------------------------------------------------------------------------

Just managed to install dropbox from the deb file on the dropbox site - version 1.4.0

..... strange but dropbox is now working although the integration in caja appears to be broken (not sure if caja has dropbox integration yet).

The Diamond Geezer
Level 1
Level 1
Posts: 35
Joined: Thu Jun 23, 2011 3:47 am

Re: Unable to install Dropbox

Post by The Diamond Geezer » Fri May 04, 2012 6:20 pm

First of all, completely uninstall nautilus-dropbox in Synaptics, then download the .deb package from the Dropbox website, and install it. The latest version is 1.40 and this method gave me the Dropbox integrated context menu in Nautilus. I hope this works for you as well.

Clawinus
Level 3
Level 3
Posts: 170
Joined: Wed Mar 14, 2012 10:08 am

Re: Unable to install Dropbox

Post by Clawinus » Sat May 05, 2012 11:33 am

Please tell me what is the command to install a downloaded .deb program.

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: Unable to install Dropbox

Post by zerozero » Sat May 05, 2012 12:06 pm

Clawinus,
the easiest way:
right-click on the deb file > open with > choose gdebi; the process is fairly straightforward after that.
Image

[ bliss of ignorance ]

The Diamond Geezer
Level 1
Level 1
Posts: 35
Joined: Thu Jun 23, 2011 3:47 am

Re: Unable to install Dropbox

Post by The Diamond Geezer » Tue May 08, 2012 5:35 am

Clawinus,

Please note that the .deb package is for the addition of the context menu in Nautilus only. The instructions on how to install Dropbox from CLI are detailed on the Dropbox website here:

https://www.dropbox.com/install?os=lnx

I hope this helps! :)

Locked

Return to “LMDE 1 Archive”